Kenwood Food Mixers - Recent Questions, Troubleshooting & Support


Contact Kenwood directly to order.

Kenwood Food... | Answered on Sep 09, 2019


there is one here...
http://web.archive.org/web/200707171...tions-A701.pdfbut the pages are in the wrong order and i think some are missing.

Kenwood Food... | Answered on Sep 07, 2019


I couldn't remove the K-Beater as when I tried to turn it the whole mechanism turned with it. I couldn't even remove the splashguard! I was going to take it to the Kenwood factory (a few miles from home) but then I thought I'd give it one more go and this is what I did...
  1. Next to where the K-Beater attaches in the middle of the circular plate is a lug with a pointed-shape bolt on the end. Remove this with a spanner and the beater plus gear cog can be removed.
  2. Place some mole grips or wide pliers on a worktop and sit the cogged gear in to it and grip so that it won't turn.
  3. Now you should be able to remove the K-Beater!
Perhaps someone can suggest how to stop it happening again. I haven't attached anything since but will update this post if I have any other helpful tips.

Kenwood KM400 /... | Answered on May 30, 2019


There is a Triac that controls the speed. It is probably short circuit. A qualified Electronics engineer with mechanical skills can repair it. Probably a BT139-600.

Kenwood Food... | Answered on May 18, 2019


KMX50 would start and accelerate to high speed, then slow down some with fairly erratic speed. I tried changing the triac on the main speed control board, then also the whole board (£45). It made no difference.

The only other component I realised it might be was the speed control board which is on the rear end of the motor under the main cover (I found this component on a site selling Kenwood parts, and was where I got the main board from, which is how I know it's speed control). When I inspected it I found two of the terminals broken. You had to look very closely to see they were broken. It's a poor design as the three legs of the terminals are quite long, and very thin, so on high speed when kneading there is much vibration, which is why I suspect the terminals broke. I cut them back just enough to resolder. The component isn't quite fully inside the sensor wheel on the motor shaft, but it still picks up sufficient signal to control the speed and now works fine. Haven't tried it under load yet, but no reason to think it won't work correctly. So check this before ordering a £45 board!

Kenwood Kmix... | Answered on May 16, 2019


Hi Carol!
Here is a link to your mixer Manual.
Hope it is helpful to you,
JP
Kenwood KMX50 series Instructions Manual

Kenwood Kmix... | Answered on May 11, 2019


Need to take a 2x4 balance it between the outlet for the grass and maybe a pair of vise scrips and then try to take it off.

Kenwood Food... | Answered on Mar 31, 2019


Sounds as if the amplifier is overheating? Does it do this at all volume levels or only when turned up to higher levels- if so it's likely the amplifier inside of the receiver.
ac096182-5c40-4da4-aee7-2a0ee52a59a0-nuhf2ssaswwsu1mfl2kxuue2-5-0.jpeg

Kenwood Food... | Answered on Mar 17, 2019


DNO IT CAN NOT BLENDERS OR FOOD PEOCESSERS WILL NOT HAND MIXERS

Kenwood Food... | Answered on Jan 22, 2019

Not finding what you are looking for?
Kenwood Logo

880 questions posted

Ask a Question

Usually answered in minutes!

Top Kenwood Food Mixers Experts

Peter GW Fleming

Level 1 Expert

3 Answers

Treefrog15
Treefrog15

Level 2 Expert

130 Answers

Yitz Diss

Level 1 Expert

9 Answers

Are you a Kenwood Food Mixer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...