Kipor Logo

Kipor Recent Questions, Troubleshooting Help & Support

Do you work here? Claim your company

  • 26 Products
  • 184 Answers
  • 14K Views

Not knowing exactly which model you are running, I would check the usual areas: -

  • Check the coolant level in the radiator and expansion tank. Don't just add water, mix the correct ratio of water to coolant for your climate.
  • Check the oil levels as the oil also plays a part in cooling an engine.
  • Check that nothing is obstructing the radiator grille.
  • Check there is good ventilation space around the gennie - that is, its not stuck in a corner or up against a wall..
  • Check the hoses are not blocked - when you remove them to check them, top up the fluid levels again after you reconnect them.
Hope this gives you something to work on.

Kipor Electrical... | Answered on Mar 30, 2015


Check de-compression lever. Motor will not start if de-compression lever is operated. The lever stops the valves from closing. If lever is operated then there will be no compression when motor is pulled over with starter cord or electric starter operated.



Check fuel cut off at injector pump is not operated. This is how motor is normally stopped.



There must be no air in the fuel line, fuel filter, injector jump or injector. Undo the fuel line at the injector and pull starter or operate electric starter. Fuel should spit out. If not, crank some more until fuel comes through.

if there is fuel in the tank, filter not blocked and injector pump working then if not fuel at injector then maybe injector pump faulty.



If fuel at injector line then remove injector, crank motor and look for spray of fuel.



If if you have checked for spray of fuel and motor compression then motor should start.

Kipor Kde 5000ta... | Answered on Mar 29, 2015


Check engine isn't locked down, rotate by hand, then check starter motor, and solenoid. The click you hear is probably the solenoid clicking in.

Kipor Electrical... | Answered on Mar 01, 2015


that washer is just a friction washer to keep the valve tight within it self just put the 3 pieces together and give it a try

Kipor Electrical... | Answered on Feb 11, 2015


what watt is the jenny and what whatt is the tool ur using are u drawing to much power ?

Kipor Kge3500ti | Answered on Nov 28, 2014


Is it tripping under load? or not under load. If it is under load have breaker checked and unit tested on a load bank. If it trips under no load check for wiring shorts on the main AC lines to the plugs

Kipor Electrical... | Answered on Aug 11, 2014

Not finding what you are looking for?

Ask a Question

Usually answered in minutes!

Top Kipor Experts

Vernon Taylor

Level 3 Expert

5244 Answers

pawnpower

Level 3 Expert

851 Answers

Wayne McNeil

Level 2 Expert

177 Answers

Are you a Kipor Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...