20 Most Recent Optoma H30 Multimedia Projector Questions & Answers


I had the same problem. I changed the power consumption setting from normal mode to eco mode. Fixed it

Optoma H30... | Answered on Dec 14, 2018


if all lamp are red, and no light on, It is power supply issue,
you need to replace power supply, it will be ok.

you can send me your old power supply photos, perhaps i have same parts,

Optoma H30... | Answered on Dec 18, 2014


DONT THROW AWAY YOUR BULB JUST YET!!! IT MAY BE THE COLOR WHEEL!

I have an optoma hd70 and was having the same problems. I also tried the "dust blob" tutorial, but unfortunately it did not work for me (and I ended up getting dust on the lens I couldn't get off myself). I started searching on the net for more answers and found some information regarding the angling of the projector. Apparently, if you tilt the projector with the back raised too high, the ventilation system does not work properly and this increased amount of heat damages the color wheel inside (this causes the wheel not to spin correctly and display a flickering effect...and that's also why it works for a few minutes on start-up but then gets too hot and the wheel skips and creates the flicker).

Luckily, I have a very extended warranty and was fortunate enough to send it in and have the dust removed & color wheel repaired/replaced. Now, I've lowered the stand for the projector to not have it tilting at such a high angle and haven't had any problems yet...but it does take awhile to get effected (had mine for about 1 & 1/2 years)

I know I should have probably just sent it for repairs in the first place...but who wants to miss out on having a projector for two weeks when a tutorial says I could've fixed it in like 20 miutes?!?! Oh well. Hope this helps someone...good luck;)

Optoma H30... | Answered on Oct 14, 2013


Hi tassos2000

I'm afraid this is indeed a Mainboard problem that will require either repair or replacement.

You nearest dealer / repairer of Optoma Projectors in Greece is in Athens , details of the company is as follows:

LEC Hellas S.A.
31 Salaminos Street
Athens
Attica
14343
Tel : +30-210-2851948

They should be able to sort you out mate.

Thanks for using Fixya and good luck !

Optoma H30... | Answered on Jul 08, 2013


Dear Sir,
i can supply many kinds of projector spare parts, coul you tell me more details on your request? perhaps i can help you,
waiting for your further news,
my mail: wanmingjun@gmail.com

Optoma H30... | Answered on Mar 25, 2013


Hi, genelewis! Well good news for me, and also hope for you; I got my projector to work correctly again, at least it has not had the problem for a couple of days of probably 10 to 12 hrs use of movie watching, before it could not go an 1hr without the purple issue.

I was looking at other sites and this one with other projectors and it sounded like just dust in the projector... after just about 3 years now without a cleaning I think it needed some maintenance, so I carefully took the bulb out (1 black screw on the bottom) and opened the projector (7 metal screws in total), and after some investigating on any wiring that may interfere (only on the inside back of the white top cover, were the inputs are: a wire band and some small metal sheets that kind of grab the top) I pop the top, not that hard.

After that I just carefully used a can of compressed air to blow away from the projector any dust I could reach and in some of the crevices I saw, being careful were the mirror is (were the bulb was); I was tempted to get the glass that covers it off to get some dust off but the screws are small and kind of hard to get out, so I left that alone. Cleaned any dust accumulated on the air intakes with a clean soft cloth and closed it up again. I did not want to touch anything else unless this did not work, but this did the trick! I'm happy with my H31 once more.

I hope this helps you, good luck. Let me know if you need some more details

Optoma H30... | Answered on Feb 10, 2013


It's probably the color-wheel problem. Maybe the color-wheel stucked because of dust and/or color-wheel sensor is covered with dust.

The simple way to check this, without reinstalling drivers or so, you just tap menu button on remote. If you will see only black-white user interface it is definitly color-wheel.

Good luck.

Optoma H30... | Answered on Apr 17, 2011


If the lamp light is orange then the lamp ballast circuit or power to it is no good.

I presume the lamp is not on at all, and it's not the hide function that is stopping the light coming out.

Optoma H30... | Answered on Mar 11, 2011


Reset the lamp timer and you should be fine.

Optoma H30... | Answered on Mar 10, 2011


OK, found the solution on the net, you have to use the buttons on the projector instead of the remote to access the menu item.

Optoma H30... | Answered on Mar 10, 2011


Go into projectors inputs and assign it to the correct input. There's multiple choices

Optoma H30... | Answered on Mar 08, 2011


The problem is not over-heating. The Optoma HD72 has a known problem that Optoma won't advertise. The lamp driver is faulty. They simply have to replace the lamp driver. I purchased a spare lamp with my original purchase. I had the exact same experience as you at around 1200 hours on the lamp in ECO mode. I used the spare lamp. Same thing happened at about 1200 hours. I had a friend at Optoma. he confided to me the problem. I sent it in and they replaced the lamp driver at no charge. I got another 800 hours out of the first lamp and am now using my second lamp and have about 600 hours on it. The pic quality is so good with this projector (used Digital Video Essentials to calibrate) that I'll just order a bare lamp or two and use the existing lamp housings when I need a new bulb.

Optoma H30... | Answered on Sep 20, 2010


When you replace the lamp, you need to reset the lamp counter as well. The procedure for this should be in the owner's manual. This counter is a guide only. Lamps have an expected lifetime and the message indicates that the lamp is nearing that lifetime. Once reset, the counter will again trigger the message once this new lamp reaches that usage time.

Dan

Optoma H30... | Answered on May 06, 2010


software related problem, may check for an upgrade on the web.

Optoma H30... | Answered on Feb 24, 2010


Hello:
You have a faulty main board and or Digital main board assembly, Replacing this board will solve the Vertical lines in the unit. I suggest you have the Main digital board assembly replaced, this board might house the main ctrl also, depending on the model.

Optoma H30... | Answered on Jan 21, 2010


Use the warranty! since you anly had it for 8 weeks, and the waaranty last for one year, go back with it and get it repaired or get a new bulb. A buld last at least 2500 hours, in eco mode it last for over 3000 hours.

Good luck to you

Optoma H30... | Answered on Dec 26, 2009


if the fans come on and the lamp doesn't, it's the ballast or the colorwheel. if no fans either, it's the power supply. also, did you reset the lamp timer?

Optoma H30... | Answered on Dec 08, 2009

Not finding what you are looking for?
Optoma H30 Multimedia Projector Logo

75 questions posted

Ask a Question

Usually answered in minutes!

Top Optoma Office Equipment & Supplies Experts

jasbo
jasbo

Level 3 Expert

2239 Answers

Ekse

Level 3 Expert

13434 Answers

Richard C Cohen
Richard C Cohen

Level 2 Expert

157 Answers

Are you an Optoma Office Equipment and Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Optoma Office Equipment & Supplies

  • Optoma Office Equipment & Supplies

Most Popular Question

projects in black white

  • Office Equipment & Supplies
Loading...