20 Most Recent KLH DVZ-2500 System - Page 8 Questions & Answers


Okay sounds like there is Fault in the power supply or the output transistor have shorted and is pumping the driver with DC....remove the driver and test with a muti-meter and using the 200 Ohm setting. put it across the terminals of the subwoofer make sure it is disconnected from the amp module....if it is a 8 ohm driver you may get somewhere from 4-8 ohm reading if its a 4 ohm somewhere from 3-6 ohms....if you are getting a 0 ohm or "short" or a really high or infinity "open" reading then the driver probably has caused damaged to the output transistors in the amplifier module. connect the muti-meter to to the red a black leads from the amp module that was going to the speaker...put the muti-meter on the highest possible DC voltage setting Mine goes to 1000VDC and power up the sub amp module now you may get a jump and power up but then it will drop to around 1.0v (or less) that is normal but if it stays high like anywhere from 30-150 VDC then you have blown output transistors (remember if you dont have this issue just skip forward!)...if this is the case pull out the amp module (remember to follow warnings and disconnect from mains power) now the DC filter caps in the module stay charged for long time after power is removed remember: test before touching!! now hopefuly all transistors are laid out infront and you wont have to dig for them the're normally are mounted flat and bolted to a external heatsink on the back. test between all junctions of the transistors B+E C+E C+B make sure there are no shorts...if there is a short replace the transistor. across from it there is its partner...replace him to! more than likely he's faulty because they work in whats called a Complimentary pair...the PNP pulls up the postive and the NPN pulls up the negative..together making a full audio signal. now after replacing all the faulty transistors test for DC on output leads. If there is none carefully connect a NEW driver of the same impendance as the old one.....but do not connect up the old one because you will blow the amp again....now power up and test for sound....all good????


Now if there is NO DC leaking on the Output leads but its still blows fuses there is a power supply fault! pull out the amp module now there is two types of power supply that this sub (or any amp for that matter) uses Switchmode Power supply (SMPS) or the normal transformer supply.im hoping for your sake it is a normal transformer supply it makes it soo much easier to fix....now be very careful you need to check the DC filter capacitors for shorting or any other issues! so undo the board from whatever it is mounted on, now remeber these capcitors can stay charged for along time so be sure to test before touching...if they are still charged and you want to dischrge them i use a 100W bulb (not an energy effiecnt bulb...but a Normal filament globe ) and connect up two leads to it...now put it across the capcitor banks...it will glow brightly and it will slowly dimm....power discharged!!
remeber to check that all caps are fully discharged!!
now test with muti-meter again on ohms mode and check for any shorts...now as you test the resistance will get greater as the caps charge up...this means all is good but if the meter stays at short then you have an issue with one of the filter caps (now if there is a short the caps will not have charge in them but still test!!) Now carefully remove each cap and test to finally locate the shorted one(s)...if there is no fault in Filter caps i would check the power transformer on the primarys so disconnect the leads from the power input socket (remembering the whole time we're doing this power is disconnected!!) and check with ohms meter there could be fault in which case you need to get a new transformer..if its not a faulty transformer.. i would be checking all mains power connections: the switch,interconnection leads,the fuse holder ect...to make sure there is no shorts...now if the power supply is a switchmode supply i would not even go there! i can repair them but it is way to hard to describe here and is not suggested for a DIY'er to attempt to repair but if its 6 years old it should be the way i have described above (normal transformer supply)......feel free to contact me if you need some more help in repairing this..E: ben@xdcpro.com.au
Depending where you are in the world most of the parts for amps can be sourced at local electronic stores or you could ask local repair stores to order parts in for you..if you are in Australia..if you want you can send me the numbers on the parts i can arrange them for you and post them out to you! good luck and i hope this can fix it,ben

KLH Audio... | Answered on Aug 11, 2009


The clicking noise is the protection circuit., sounds like you have a grounded speaker wire, but you say the speakers are not connected so the amp may be toast. Is there any smell of burnt wires? This is ussuallt noticable near the circuit board if something failed!

KLH Audio... | Answered on Jul 07, 2009


Get a set of wireless speakers (such as Advent AW-820 900 MHz Wireless Stereo Speaker System).  Connect the transmitter to the earphone jack of your computer.

KLH Audio... | Answered on May 20, 2009


Hi there,

It sounds like you have blown the amp that has been built into it.

As its builts into the system, you wont be able to replace it yourself.

Im affraid to say that your going to have to take this to a local repairs store, and too see if they can have a look at it for you... but i would say it would be cheaper to buy a new one.

Other than that... heres a few things you could try to check that it is the amp... Try plugging in some other external speakers into the system, if the same occurs then you know its not the speakers and it is deffo the amp.

Hope this helps

alex

KLH Audio... | Answered on May 04, 2009


Hi, you can get the fuse at Polk Audio. 800-377-7655. You can talk to technical, too.

KLH Audio... | Answered on Jan 22, 2009


Hi Twa DeLong, from what you say, it would seem that you have a bad battery
Hola Twa DeLong, por lo que comentas, pareceria que tienes mal la bateria

Audio Players &... | Answered Yesterday


Hi Jean DeShields, indicate brand, model and type of equipment you are commenting on, in order to find the best possible solution
I wait your answer
Greetings Franco Dosil

Hola Jean DeShields, indica marca, modelo y tipo de equipo del que estas comentando, para poder encontrar la mejor soluci?n posible
Espero tu respuesta
Saludos Franco Dosil

Audio Players &... | Answered on Oct 14, 2019


Hi George Dimas, indicate brands and models of the equipment you are commenting on, in order to find the best possible solution
I wait your answer
Regards Franco Dosil

Hola George dimas, indica marcas y modelos de los equipos que estas comentando, para poder encontrar la mejor soluci?n posible
Espero tu respuesta
Saludos Franco Dosil

Audio Players &... | Answered on Oct 14, 2019

Not finding what you are looking for?
KLH DVZ-2500 System Logo

16 questions posted

Ask a Question

Usually answered in minutes!

Popular Products

Top KLH Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5699 Answers

The Knight
The Knight

Level 3 Expert

76140 Answers

Gil Shultz

Level 3 Expert

3388 Answers

Are you a KLH Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

KLH Audio Players & Recorders

  • KLH Audio Players & Recorders

Most Popular Question

preset password

  • Audio Players & Recorders
Loading...