MTX Thunder 421D Car Audio Amplifier "amp" Questions

Ad

Question about Sony Car Audio & Video

1 Answer

I have two 12 inch rockford p1 punches powered by an 800 watt sony explode amp (2 Channel) and i want to install another 15 inch kicker with a 1200 watt amp not sure the model, i got it from a friend ...

Ad

Question about Hifonics Car Audio & Video

1 Answer

How to conect a hifonic amp class d to four How to conect a hifonic 1600watt class d amp to four kickers cvrs + too - & - too + & + too - & - too +& + too -

Ad

Question about Solid Audio Car Audio & Video

1 Answer

I have 2 amps instalkled in my car one is sony 1200w 2 channel amp for speakers and one is solid audio f2500d for 3 subs my sound and every thing was good but suddenly from yesterday im having trouble

Question about Soundstream Car Audio & Video

1 Answer

not powering up no current tried every thing Hi apart from the + & - connections to the big terminals, the terminal marked "REM" or "REMOTE" needs 12 volts on it too to start the amp up. If no ...

Question about Car Audio & Video

1 Answer

Amp cuts out Sub Woofer Amp cuts out. Power to amp is okay. Amp is well grounded. Trigger wire from dash unit feeding Sub Woofer amp is 12volts. I have checked voltages at amp.all ok. However even ...

no power to the amp i touched the power wire to the side of the amp i touched my power wire to the side of my amp on accident. Right above the part where the power wire goes i sliped on my tail gate ...

Question about AudioBahn Car Audio & Video

1 Answer

amp stuck in protection mode, help!! my entire system was installed by a person @ tweeter... got 2 12" mtx's, a zx750 kicker amp, pioneer deck... my amp usually functions very well.. recently it has ...

Question about SPL Car Audio & Video

2 Answers

SPL AMPLIFIER YES I HAVE THE SPL PHANTON DK2-1000 EVERTHING WAS GOOD UNTILL ONE DAY IT JUST QUIT ON ME. THE AMP STILLS COMES ON NO PROTECTION MODE BUT WHEN I PLUG IN MY AUX NO SOUND AND THE AMP GETS ...

Question about Legacy Audio Car Audio & Video

1 Answer

subs and amp dont work i had a working system 2 subs and an amp. I was not sure if my friends amp was working so i disconnected my amp and connected the cables to his amp. When his amp did not ...

Question about Phoenix Gold Car Audio & Video

1 Answer

I have the Rsd 1200.1 and + - and remote wire are connected good but amp doesnt come on nor does the lights come one either... Make sure that you have power at the amp; test the power wire at the amp.

Not finding what you are looking for?
MTX Thunder 421D Car Audio Amplifier Logo

17 questions posted

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

93 Answers

Mike Duncan
Mike Duncan

Level 2 Expert

219 Answers

Philip Armitage

Level 3 Expert

437 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...