Question about 1991 Oldsmobile Ninety Eight Regency

2 Answers

91 olds eliTe, STarTing in drive car seems to be in high gear. Manually sHifT to low gear and it seems to be in second. CHEcK ENGINE codes are 26 and 36

Posted by on

  • james_hoffma Dec 19, 2009


    to start off, I would not believe that the car should ever start in high, no matter what gear you have the shif lever in.

    Are the solenoids internal to the transmission or can I see then outside? Is there more than one?
    Are the wires going to them easy to get to?

  • james_hoffma Dec 21, 2009

    91 Olds Elite: When shifing into drive, the car seems to be in high and has a hard time getting up to speed. I can shift down to low and then it seems to be in 2nd gear and I am able to get going. Cheeck engine codes 26 and 36 appear.

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Oldsmobile Master
  • 85,206 Answers

26 quad-driver module (computer) circuit #1 fault
36 ignition system circuit error. ignore this unless the engine stalls on the road

Code 26 is the issue here, i thnk you will need to remove the transmission pan and replace the shift solenoid pack, it is attached to the valve body inside the trans.

Posted on Dec 21, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Contributor
  • 1,326 Answers

I would first make sure you in drive when shifting, don't go by the dashboard (you could have some slop in the shifter cable/rod) I you shift down 3 gears from park you should be in D and see if that still does the same, if it does your shift solenoids may be bad or worn clutch packs in the tranny.

Posted on Dec 18, 2009

  • James Brooks
    James Brooks Dec 19, 2009

    Shift solenoids are inside the tranny, 1 for each gear. They will have a wire going to each on the exterior of the tranny, but the only way to test for certain is with a pressure guage as each actuates when the flulid gets to a specific pressure which triggeres the solenoid to move forward/backwards and this upshifts/downshifts the car. The only true way to diagnos is for some to physically drive the car to see if it is demonstrating the problems associated with the solution. This is truly not a guaranteed solution but merely a suggestion as I/anyone can't accurately diagnos tranny failure over the net. Start witih the simple things, hows your fluid level, is it smelling burned when was the last time it was flushed (by removing the pan) and filter changed. And also you never answered if you go down 3 clicks from park to D (don't look at the indicator) go by feel does it drop into R at 2 clicke, D at 3 clicks, 2 at 4 clicks and 1 at 5 clicks??

  • James Brooks
    James Brooks Dec 21, 2009

    Also could be your clutch packs as well if they are worn you will get slippage and hesitation in one or more gears, if they are worn your looking at a tranny rebuild. Its possible the 1st gear clutch paks are worn and thats why its has no power when off the line and you switch it to another gear with more friction pad on the discs...

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1989 Toyota Camry automatic transmission starting off on high gear.Stalls on drive like pulling heavy loads.


It is quite likely to be a failed shift solenoid, causing inability to find low gears. There should be a trouble code stored, causing the O/D lamp to blink.

Nov 18, 2014 | 1989 Toyota Camry

1 Answer

2003 Ford ZX2 automatic transmission will not drive in drive or overdrive when at a stop light. But will move is first gear.


check your linkages from your gear stick to the gearbox .need adjustment.and check the kick down cable ,at the throttle needing adjustment.

Oct 02, 2012 | 2003 Ford ZX2

1 Answer

Dodge dakota 2005 automatic transmission, when starting from a stop or low speed sounds as if it is low on fluid rpms high started doing this on tollway when pulling out from the toll both ????seems to...


Manually shift thru all gears up & down the scale. Try adding Motorcraft Additive Friction Modifier, available from Ford parts dept. This REALLY STINKS!!! Don't get any on you. Pour into trans fluid. Drive a few miles shifting manually thruthe gears, then do a normal start stop drive several times. This will luburcate trans, normally used for differential but has worked in automatic transmissions of all makes for years. Otherwise mechanical problem for transmission repair facility.

Nov 07, 2010 | 2005 Dodge Dakota

1 Answer

What is a shift solenoid!


A shift solenoid is an electrical switch that is located in the transmission on the valve body assembly.
This solenoid is commanded on or off based on inputs from the electronic control module or "ECM".
These commands are based on inputs from multiple sensors and the predetermined shift patterns of the computer program. Any diagnostic trouble codes (check engine light) need to be diagnosed first as other sensors may cause shifting concerns.
I hope this answers your question, additional diagnostics need to be performed.

Mar 23, 2010 | 1995 Oldsmobile Cutlass Supreme

1 Answer

Ford Escape Automatic Only Goes Into 1st Gear Manually


it sound like you have a vacum leak or your shifter cable may need adjusted

Oct 26, 2009 | Ford Escape Cars & Trucks

1 Answer

When i try to shift from park to reverse the car jumps into gear very hard when it is shifed from reverse to drive same problem exept the car seems to be in a high gear very slow to get moving like i have...


Go to Trans repair shop NOW!! Major electromechanical problems are present starting with too high of internal line pressure causing harsh gear engagement, the second concern is your 1st gear clutch pack will not apply or there is major internal damage.

I'm sorry for the bad news..

Dec 21, 2017 | 2006 Suzuki Forenza

1 Answer

Transmission , idle, check engine


My 1st suggestion would be to get a scan done for the check engine light. I'm not talking about a simple 'code reader' but an actual scan tool so all of the different sensors and perimeters can be read. You will need to get one or find someone with a scan tool which can do OBD I vehicles.

If the engine isn't running correctly this could cause the transmission not wanting to shift. 2 vehicles that come to mind where I've seen this happen.

One was a Pontiac and it wouldn't shift into overdrive. Problem was the thermostat which was stuck open and it wouldn't allow the engine to get up to proper temperature which kept the transmission from shifting.

The other was a Ford Explorer that the lady thought for sure the transmission was bad. After a test drive and investigation it was found the catalytic converter was mostly plugged which wouldn't allow the engine to achieve the proper torque and RPMs to get the transmission to shift.

Now granted neither of these examples are an exact duplicate of the problems you are having. They are simply to illustrate that engine performance (or the lack of) CAN affect the way the transmission shifts.

Hope this helps.

Sep 28, 2017 | 1991 Buick Century

3 Answers

My 1989 Jeep with AW4 transmission does not downshift or ?


This model has a tranny computor under the dash on the right side screwed to the bottom of the dash. If I remember correctly, there is also an inline fuse attached to the harness. Check the fuse.

Feb 12, 2009 | 1989 Jeep Cherokee

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

51 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

Jonah Oneal

Level 3 Expert

14092 Answers

Marvin
Marvin

Level 3 Expert

85206 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...