Question about 2009 Chevrolet Aveo

1 Answer

My aveo speedometer and RPM was stop working today ??

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Just happened to me. The solution is find the 10A fuse in the "Room Lamp / Cluster" spot. May only say "Room Lamp" too. This fixed it instantly for me.

Posted on Feb 09, 2019

  • C Williams
    C Williams Feb 09, 2019

    Just happened to me. The solution is find the 10A fuse in the "Room Lamp / Cluster" spot. May only say "Room Lamp" too. This fixed it instantly for me.

×

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
Auto Master
  • 139 Answers

SOURCE: rpm gauge and speedometer stoped working

It sounds like you have a faulty Instrument panel Cluster (IPC) Your local dealer will have to confirm this as independant shops don't have the scanner capabilities for this diagnostic procedure.
I hope this helps.
Thank You,
Roy

Posted on Aug 06, 2009

  • 250 Answers

SOURCE: Fule gauge speedometer and rpm gauges stopped

Go to the fuse box and change the fuse for "Gauges". I think this might solve the problem.

Posted on Feb 23, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Please Help!!! 1999 Mercury Sable doesn't seem to accelerate past first gear..engine revs up to very high rpms.


If the speedometer stops working the odometer stops also. Sounds like it is stuck in first gear. The RPM went up because the throttle was response to pedal but transmission not response. Check transmission fluid color. Whip off dipstick on a white paper towel look for gray if see any that is metal shavings and transmission is bad.

Feb 16, 2016 | 1999 Mercury Sable

1 Answer

My 95 ford tauraus rpm shifts up and down irradicly and the speedometer stopped working


Sound like a vehicle speed sensor go to bad. If this is right, the RMP dont showing details.

Feb 27, 2013 | Cars & Trucks

1 Answer

The hold light is flashing, and the temperature gauge is not working. problem just started. Drove about 10 miles home.


my 2009 aveo hold light and rpm gauge stop working at the same time,what we did was change the coolent sencer. that worked

Aug 19, 2011 | 2009 Chevrolet Aveo

2 Answers

The speedometer gauge and RPM gauge is not working. The speedometer gauge goes to the max while I am driving. The car itself seems to be running ok. Help! It is a Yukon Denali 2005.


I suspect that your sender is malfunctioning. Todays speedometers and RPM is sent from a sensor/sender near the drive shaft. A magnet on the drive shaft is sensed and the revolutions are converted to RPM and speed.

For information see:

http://wiki.answers.com/Q/Speedometer_on_2003_Yukon_XL_doesn%27t_work_most_of_the_time_is_this_a_common_problem_how_much_to_fix_it

Jan 09, 2011 | 2003 GMC Yukon Denali

1 Answer

Fule gauge speedometer and rpm gauges stopped


Go to the fuse box and change the fuse for "Gauges". I think this might solve the problem.

Feb 23, 2010 | 2004 Chevrolet Monte Carlo

2 Answers

Idler is too high on start-up, goes up to 2.5-3 rpm. and comes back to normal. just started a week ago. what could be the problem? 2005 Chevy Aveo


I bought my 2004 aveo 49 miles. I've had several issues with the car. But recently I been experiencung high idle at start up and clutching. I change IAC. Plugs and wireds. Nothing worked. Today the high idle became constant. It was a metal bubble flex tube near the IAC unit that goes to the exhaust stuff down behind the motor. It apparently was cracked cause today it broke causing the constant high idle sound like a vacumn. We blocked it off with a stick to get the idle back down to 900 rpm instead of 3-4000 rpm took we can get to auto zone for high temp hose per Chevy dealer. I hope this helps someone cause it was fustrating and costly.

Mar 08, 2009 | 2005 Chevrolet Aveo

3 Answers

Car speedometer quit working


the tramission is not shifting its the output sensor on trasm that broken drive slowly the shop gonna pass the scanner on the trasm it should be the input and output sensor not a rebuilt trasm if the shop tell you you need a rebuilt ask for a second opignion hope it help fixya our post thanks pierre

Jul 15, 2008 | 2000 Dodge Grand Caravan

Not finding what you are looking for?
2009 Chevrolet Aveo Logo

Related Topics:

404 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

84027 Answers

Jonah Oneal

Level 3 Expert

14053 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22483 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...