Question about Televison & Video

1 Answer

I have owned my Mitsubishi WD-60C9 for about 1.5 yrs now with no problems. I recently purchased a new Onkyo HTIB to utilize the HDMI connections on my TV. Everything worked fine for about 3 weeks but recently I keep getting the "New Device Detected" blue screen telling me there has been a new device found for input 2. However, I don't have anything plugged into the input 2, only the one HDMI from the receiver to the back of my TV. I have tried the soft and hard resets for the TV with no luck. After about 10 minutes of watching the TV the new device found screen continues to pop back up. Any thoughts?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 81 Answers

First thing I would rule out is the firmware version of your TV. The newest version of your firmware is version 11.03. This newest version may be able to fix this problem. You can download it from Mitsubishi's website and there will also be a set of instructions along with the download. These are very important steps that you need to follow to repair your TV correctly.

Posted on Jul 18, 2011

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mitsubishi WD-60C9 changing inputs on its own whats the cause of that?


HDMI auto is ON. Go to menu settings and turn OFF auto HDMI. That will stop the auto switching. Regards.

Aug 18, 2015 | Mitsubishi WD-60C9 60" DLP HDTV

1 Answer

I have a mitsubishi 60 inch tv model wd-60c9 and i purchased it this year ..aug 06 2010 and the picture has became very dark..i am using hdmi conection and purchased new and better cables..issue still dark


The tv projection lamp have problems,it shorting out some how.That why,u have a dim picture.Tries websites like Partstore.com,Ebay.com to buy a new projection lamp for the replacement.New tv,call mitsubishi for a warrenty repair.

Oct 18, 2010 | Mitsubishi WD-60C9 60" DLP HDTV

1 Answer

Hdmi 2 wont work on mitsubishi wd-y65


It sounds similiar to a problem we've had with ours, all components would work in hdmi 1, but hdmi 2 would only work intermitently. They ended up replacing the digital board (fortunately we have the extended warrenty, I'm sure it's not cheap). Sorry hope this helps.

Feb 14, 2009 | Mitsubishi WD-Y65 65" HDTV

1 Answer

Wavy diagonal lines only with component cables, not hdmi


You have a bad format board which is no longer available. the DM chassis can be sent in for repair by an authorized Mitsubishi servicer Call mit at 1 800 332-2119 they might help with cost of repair have receipt and purchase date available.

Jan 12, 2009 | Mitsubishi WD-62725 62" Rear Projection...

1 Answer

What is the best audio configuration with this setup?


You can't just plug in optical cables. Both the TV and amp have to be adjusted to allow the different type of signals to pass. I have an Onkyo receiver myself and you have to set the sound type up for each input. It's a bit tricky to do without a manual, but you can probably download one for free if you have lost yours.

Mar 12, 2017 | Onkyo HT-S5100 Theater System

1 Answer

HELP: Onyo Remote Does Not Recognize Receiver when using Cable


Since you have the cable connected to the reciever thru the HDMI, you may have accidently changed the input source of the reciever from HDMI or digital to analog.

When you have the reciever set to listen to the cable, check the input mode and make sure it is set to use the HDMI or digital input and not the analog.
The rca jacks are analog, and they worked, so I think you have just solved your own problem without realizing it.

Let me know if this works and if so a good rating would be appreciated. Thanks and have a great day

Jun 16, 2008 | Audio Players & Recorders

1 Answer

Onkyo 605 HDMI Sound


Change the setup in the Hardware control/HDMI/ HDMI Audio...

Jan 17, 2008 | Onkyo TX-SR605 Receiver

5 Answers

Mitsubishi HDMI connection trouble


I have the same issue with my 73". Rather then going over all of my connections and equipment I'll just say htat I feel your frustration. I have been on the phone with Mitsubishi directly and it appears as though they have a free software upgrade that should address this problem. If you call 1-800-332-2119 and press 4 in the menu you will get someone to help you. Be patient. They will make you go through all of the fixes that you have already tried. They will mail you a flash drive that goes right into the front USB port of your TV. I hope this is of help. Good luck.

ret4good

Jan 04, 2008 | Mitsubishi WD-73833 73" HDTV

1 Answer

Onkyo HT-SR750


Check out Onkyo's website: The HT-SR 800 description says "a separate audio connection is necessary" Maybe it is true for the --750 too.

Jan 01, 2008 | Onkyo TX-SR605 Receiver

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

116 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76173 Answers

Cindy Wells

Level 3 Expert

6048 Answers

Marvin
Marvin

Level 3 Expert

85216 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...