Question about Sony KDE-42XS955 42 in. Plasma HDTV

1 Answer

Sony Plasma KDE 42xs955 has delay in of 5 to 10 minutes for picture to appear. Sound turns on immediately

TV used to work correctly. Now turn set on and sound turns on immediately. The picture is blank for 5-10 minutes with several clicking sounds every 30 seconds or so. Then picture appears.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Sony Master
  • 76,177 Answers

Contact the authorized service centre for Sony. This is not a fault that a normal user can do anything. Electro help

Posted on Oct 22, 2014

Ad

6 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Anonymous

SOURCE: losing picture and sound

It needs a new bulb, same thing happen with me. jut get a bulb for this model and change it. if you call sony service, it will cost you about $500.

Posted on Aug 12, 2007

jomabug76

Josh Whitehead

  • 1148 Answers

SOURCE: unable to turn sound on, picture is fine. volume numbers increases but still no audio

check menu make sure ,,internal speakers are on,,check rca jacks

Posted on May 15, 2009

ginko

Ginko

  • 19396 Answers

SOURCE: Tv Turn sound on, No Picture, turns itself off within seconds

The TV is trying to go on protect mode because an internal fault had been detected. For that reson the protection circuit keeps turning off TV continuously.

Try first leaving the TV power cord unplugged for some times, let say one hour or so.

Also ensure that the fault is not coming from a faulty receiver box sending bad signal, check if you get same problem with no receiver box or dvd connected.

If that does not work, and you keep having a flashing led on front of the TV, and tv turning off by itself after a while, that indicates a fault condition.

The flashing light indicates a diagnostic state called protection.
When the TV goes on protection there are only two possible reasons.

1The internal circuits are jammed because of electrostatic charges accumulating on capacitors, or because of a wrong voltage read by the main chip on your monitor controller board. this started the protection circuit.

2 The protection circuit detected a wrong voltage or abroken contact, identified an internal fault and kicked in , startingthe flashing light.


If you are in situation one, then theTV will reset just unplugging power cord for one or two hours,sometimes even minutes.

If you are in situation 2 , then there is an internal fault.

Common faults that can occur are a blown capacitor on power board, a convergence IC has blown, or a fault on Digital board.

Check also the video cable or any external connection cable, if the cable is shorting, or the connector is bad, you can get same flashing state because of the video cable.


If under warranty contact the manufacturer ringing the number on the user manual

Posted on May 23, 2009

Anonymous

  • 1 Answer

SOURCE: Sony Plasma TV.

I have the same problem. since I have 3 of these TV's, I switched boards around, and I came to the conclution that is the power board. I will try to repair it, and I'll let you know the component that is bad. Gaston

Posted on Oct 31, 2009

jhinsincity

Julio Hernandez

  • 616 Answers

SOURCE: My Sony plasma tv made a pop sound and now picture is dark.

You will need the y and x sustain boards replaced, possibly the buffers. very expensive repair. you can replace one board but its best to do all of them.

Posted on Jan 22, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No sound or picture but lights come on sony wega plasma


Typical failure for all plasma tv's is a blown Y-sustain board. Another high failure for all tv's is dried out bulging capacitors in any of the power boards. You likely have one of these problems.

Mar 18, 2015 | Sony KDE-42XS955 42 in. Plasma HDTV

1 Answer

Sony Wega Plasma 42XS955. Over 2 wks., gradually


I would check the capicitors on the power supply to see if the they are bulging at the top or leaking. I had a Samsung lcd that starting taking and hour to turn on then eventually it would not turn on. So I checked the power supply and saw four bulging capacitors that I replaced and now it's working like new.

Oct 31, 2013 | Sony Televison & Video

1 Answer

Are there installations recommendations regarding above gas fireplaces?


dont understand the ?, sure there are better units than others and better suited units for someones needs, ex. btu rating, if you want heat bigger btu,

Jan 19, 2010 | Sony KDE-42XS955 42 in. Plasma HDTV

1 Answer

Repairing a ribbon for X Y board Plasma TV


REPLACED PDP PANEL
Manufacturer Sony Part Number 9-885-081-88 Description PANEL (NP50C4MF01FA

Oct 04, 2009 | Sony WEGA KDE-50XBR950 50 in. Plasma HDTV

1 Answer

My component cable is not showing any video.


it is a a/v hook up not a component hook up
try that like av1 av2 av3
should work a lot better
ron

Aug 29, 2009 | Sony KDE-42XS955 42 in. Plasma HDTV

1 Answer

Sound but no picture


try this simple test i know its kinda weird, but it helps to know what seems to be the problem.tap your unit three times, while tapping look at the screen, see if it flicker or the screen has picture.then, check all connection, if its all ok. then, you'll need a tech to do a manual troubleshooting.

May 18, 2009 | Sony KDE-42XS955 42 in. Plasma HDTV

1 Answer

Small vertical stripe about 6" from left side


go to the settings menu and try to reset the screen position...

Apr 02, 2009 | Sony KDE-42XS955 42 in. Plasma HDTV

1 Answer

Power


today i did repaired same problem same tv.
cold solders on powersupply board. resolder all cracks!

Aug 26, 2008 | Sony KDE-42XS955 42 in. Plasma HDTV

1 Answer

Delay to see the picture


Your power supply is going south, I have an old sony with the same problem. The voltage level drops and does not have enough 'kick' to start. It will work better when it is warm. The module will need to be replaced.

Nov 29, 2007 | Sony KV-27XBR45 27" TV

Not finding what you are looking for?
Sony KDE-42XS955 42 in. Plasma HDTV Logo

244 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76177 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1691 Answers

Ekse

Level 3 Expert

13434 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...