Question about 1995 Oldsmobile Aurora

1 Answer

I just had fuel pump repalced and it seems as if somthing is draining my battery. there are no lights on but if my car isn't running for 15 min then it needs a jump but if i unhook the battery from the car after i use it and then hook it up to use the car it works. what is draining my battery?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 836 Answers

Could be the fuel pump relay staying on, it should turn off when turn off the key, sometimes the Tech will jump the system to drain the fuel out and may have installed the relay incorrectly.

Posted on Jan 11, 2011

Ad

1 Suggested Answer

Anonymous

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1994 ACCORD DX RUNS FINE, THEN JUST SHUTS OFF AFTER ABOUT 20 MINS WITH NO WARNING LIGHTS, NO ENGINE LIGHT, NO CODES??! SOMETIMES IT TAKES 10-15 MINS TO RE-START. ANY SUGGESTIONS ON TROUBLESHOOTING? A


Likely you are draining the battery with your system use during the car operating. This drag down of the battery means that your alternator may not be working properly. Check the alternator to see if it is putting out voltage. Otherwise check the battery during operation to see a higher voltage on the terminals if it is getting charge from the alternator.

Feb 01, 2015 | 1994 Honda Accord

1 Answer

Runs min shuts off


Sounds like a fuel pump failure

Check for Codes
Check Fuel Pressure,listen for pump at the tank
Check for Spark or Injector Pulse
Check Battery Voltage & Alternator Output

Your loosing one of them or other things

Aug 29, 2013 | Ford Cars & Trucks

1 Answer

Battery flat


Yes-- to most of your questions
I would take it to a repair shop & not
be stressed over all the issues,let the
shop figure it out

Jul 24, 2013 | Cars & Trucks

1 Answer

1998 gm pickup truck tail lights came on when no switches were on now fuel pump is not pumping


YOU STILL NEED TO HAVE THE BATTERY FULLY CHARGE . LIGHT USE 5 TO 7 AMP FOR THE ECM TO POWER UP. IT NEED A FULL CHARGE. THE TAIL LIGHT WILL DRAIN THE BATTERY AND WILL NOT WORK. JUMP TRUCK AND REPLACED BRAKE STWITH OR ADJEST IT.WITH A GOOD BATTERY KEY ON YOU WILL HEAR THE PUMP RUN FOR 15 TO 20 SECONDS AND IT SHOULD RUN

Jan 19, 2013 | 1999 Chevrolet Silverado 1500

1 Answer

1999 Bonn,the car runs for about 15 mins and shuts down,replaced ignition mod,cam/crank sensors,filters, fuel pump (3) times,because it seems as though after it shuts down and I try the key agian there is...


did you check the connector that plugs into the fuek pump the termianls get burned and that causes multiple pump failures. its the 4 wire connector

Jul 29, 2011 | 1999 Pontiac Bonneville

1 Answer

I have a 1990 isuzunpr 4bd1t diesel.Truck won't stay running.It is a fuel issue.Drained water seperator,changed fuel filter,cleaned inline screen before the primer pump.Had primer pump rebuilt.Replaced...


G'day
I dont know if this will help but i had a similar problem with an isuzu sbr and after doing all that you have done i took the fuel tank off and drained it. Every thing looked fine so i washed it out with a little bit of petrol and a small piece of clear plastic came out. What it was doing was floating up when the truck was not running but after i started the truck it would slowly get sucked down to the outlet and block the fuel line.
It was very frustrating and it took me quite a while to find the problem.
hope this helps.

Dec 06, 2010 | 1992 Isuzu Trooper

1 Answer

96 buick riviera


malfunction with security system,wait 15 min. when this happens to see if it will start.the car should not run with this light on.there was probably nothing wrong with the fuel pump last yr.

Oct 04, 2009 | 1996 Buick Riviera

1 Answer

Van runs great until it heats up. generally about 15-20 min.


i would check to see if your fuel pump is working properly maybe first try replacing the fuel filter and running a fuel treatment.

May 23, 2008 | 1996 Nissan Quest

Not finding what you are looking for?
1995 Oldsmobile Aurora Logo

72 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

Jonah Oneal

Level 3 Expert

14092 Answers

Marvin
Marvin

Level 3 Expert

85223 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...