Question about 1997 Buick Century

3 Answers

Buick Century 97 runs rough and stutters when cold and gas applie

Engine runs rough and stutters when gas is applied, runs normal when idling. Problem shows up only when car was not used for more than 12 hours and is worse the longer it was not used. ''Check engine light'' was on one time with failure code for ''catalytic converter defective (possibly caused by engine misfire or vacuum leak or engine oil leak into exhaust valve)''. Cat converter was exchanged and failure code disappeared but engine runs still rough and stutters - so cat converter might break again soon. What is the reason?

Posted by on

  • 1 more comment 
  • Anonymous Aug 14, 2009

    I forgot to mention, engine computer was changed, too - problem is still there.

  • Anonymous Aug 14, 2009

    Is it possible that spark plugs and wires can cause problems only when engine was not running for some/longer time ... maybe because of humidity crawling somewhere?

  • Marvin
    Marvin May 11, 2010

    I would replace the spark pugs and wires for a start.

×

Ad

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Buick Master
  • 85,206 Answers

Start by replacing the plugs and plug wires, this is esp true if car has over 100,000 miles on it. damp air can make the problem worse.

Posted on Aug 14, 2009

Testimonial: "helpful"

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,896 Answers

Your cat should last quite a while now it is replaced. I recommend testing coil packs and module. Change plugs and wires and double check your vacuum hoses.

Posted on Aug 14, 2009

Testimonial: "Helpful hint"

  • Nate Stansfield
    Nate Stansfield Aug 14, 2009

    yes it can. anything electrically connected an cause this. THis is why light bulb sockets have the lighiu electronical grease in them to avoid shortening out.

×

Ad
  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

You might even try changing the fuel filter...when you let it idle it is getting enough gas to run and when you give it gas you might not be getting enough fuel through the filter to keep it running...

Posted on Oct 11, 2011

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

97 park ave ultra is hesitatating when I start using the gas as I start an incline mostly but sometimes just randomly an it's getting worse


Engine Stalling Due to Mass Air Flow/Crankshift Position ...

repairpal.com > Problems > Buick > Park Avenue
Buick Park Avenue Engine Stalling Due to Mass Air Flow/Crankshift Position Sensor Failure. This is a verified ... 1997 Buick Park Avenue- 3.8L V6160,000Visitor. Engine stalls ... car runs then stalls and won't start for thirty minutes. Upvote (36).

Buick stuttering Questions & Answers - Fixya

www.fixya.com > Forum > Tags > stuttering
94 Buick Park Avenue that stutters under a light load I have a 94 Buick Park Avenuethat ... Buick Century 97 runs rough and stutters when cold and gas applie Engine runs rough ... I have a 1994 buick lesabre it starts ok but stutters and stalls.

Oct 30, 2015 | Cars & Trucks

1 Answer

I've a 1981 Vette that idles very rough with a cold engine start.


You need to have the choke adjusted so it runs on a fast idle so the engine can warm up or you may need the carb to be rebuild and adjusted properly.

Jan 31, 2014 | 1981 Chevrolet Corvette

1 Answer

Engine runs rough when idling


Check the firing order, The push rod has 2 differnent sizes for intake and exhaust, If they get switch you get the rough idle

Feb 24, 2013 | 1998 Buick Century

1 Answer

Idle good when cold, hotter it gets the worst it idles especially when sitting at stop lights


simple test for a vacuum brake booster
star and run the engine at idle without applying the foot brake
if it gets worse when the foot brake is applied , it is a vacuum leak in the booster ( replace the booster )
otherwise check for failed vacuum hoses including under dash control lines , vacuum leak at the manifold or EGR unit

Apr 16, 2017 | Chevrolet Astro Cars & Trucks

1 Answer

I have a problem with my 1988 Buick Century, 2.5L 4 cyl engine. I think it has to do with maybe the MAP sensor. Problem: when it's really cold outside, I can not get the engine to start unless I floor...


a bad thermostat-testit--have car scanned for bad codes--giv it a tuneup-new plug wires and distributer cap--then throttle body and idle air cleanin--get a haynes book at parts place

Apr 01, 2011 | 1988 Buick Century

1 Answer

Buick 2001 century check has the code p1404. is it safe to drive the car until we can have it fixed?


Hello Momma.
This code has set because a fault was detected in the exhaust gas recirculation system (EGR).
If your car is running normally, no chugging or rough running, it isn't a serious issue. But you should have it looked at to determine why it set.
Often it's because the pin inside the EGR valve is sticking or carboned.
If this valve sticks it can allow exhaust gas into the intake when it should not be and cause your engine to stumble at idle or low speeds.
It will not damage anything over a short period of time.

Thank you for using FixYa.
Best of the season to you.

KL

Dec 26, 2010 | 2001 Buick Century

2 Answers

Replaced the water pump on our '97 Buick Century because we thought that is where the leak was originating. Replaced the hose from the radiator to the water pump as well. It is still leaking with fluid...


YEP YOU HAVE LEAK AT THERMOSTAT HOUSING.YOU NEED REMOVE THERMOSTAT HOUSING OUTLET AND CLEAN THE MATING SURFACE THOROUGHLYTHEN APPLY RTV SEALANT IN THE GROOVE OF THE WATER OUT LET HOUSING.INSTALL THERMOSTAT WITH SPRING TOWARD THE ENGINE TORQUE THERMOSTAT OUTLET HOUSING BOLTS 89 INCH LBS.IF STILL LEAKS OUTLET HOUSING COULD HAVE CRACK IN IT CAUSING LEAKING.

Sep 08, 2010 | Buick Century Cars & Trucks

1 Answer

Idles okay, runs rough when gas applied


Either a bad MAP sensor, or TPS. What is the code for the check engine light? This will most likely tell you what it is.

May 27, 2009 | 1994 Chevrolet C1500

3 Answers

Engine stalls


your on the right route but also check egr valve

Jul 07, 2008 | 1989 Buick Century

Not finding what you are looking for?
1997 Buick Century Logo

916 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

Marvin
Marvin

Level 3 Expert

85206 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...