Question about 2004 Dodge Ram 1500

1 Answer

2004 Dodge Ram 1500 4.7L has crank no start condition. It did start, but after a few seconds the idle would shoot to 4000 rpm. I disconnected battery and reconnected after fixing vacuum leak. Now no start. I have spark. Fuel. Compression. I even sprayed starter fluid in to no avail. Any ideas? Changes cam and crank sensors tps map

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Dodge Master
  • 85,223 Answers

I see no mention of a PCM (engine computer) fault code test, buy a code reader or rent one and read the fault codes, it is the 1st step in diagnosing these problems.

Posted on Apr 10, 2019

Ad

5 Suggested Answers

Anonymous

  • 321 Answers

SOURCE: buick lesabre nightmare

Need to get a scan tool and look at the data stream while it is running for alot more info.Also any trouble codes.Sounds like initially,the engine isn't getting any fuel.I would have a pressure gauge connected to the fuel rail on the engine,so i could monitor the fuel pressure while all this is going on.Items to look at on the data stream would be timing,what timing is the PCM commanding for the engine.Also,have you checked for continuos power feed to the coils during this no start condition,and fire at the plugs while cranking.You could possibly still have spark,but maybe it is extremely weak?I have seen bad ignition switches cause weird problems before too.Many things power up through the ignition switch,just a thought.Have also seen bad PCM's cause strange problems..38 volts is a little on the low side for GM.Usually see those at,at least .50 and up,and rise steadily while pressing the throttle,up to just under 5.0 volts.Potentiometer with 5 volt supply.Vacuum leak can be checked with engine running at a steady idle speed,spray brake cleaner all around the intake manifold and listen for engine speed change.

Posted on Jul 31, 2008

Ad

Tony Rodriguez

  • 255 Answers

SOURCE: buick lesabre no start

Hi you have replaced allmost everything ,(try fuel pump relay)

Posted on Aug 18, 2008

Anonymous

  • 367 Answers

SOURCE: 2004 kia optima

Try the ignition switch,

For the Crank sensor there is a small metal disc that mounts behind the sensor if that is cracked or dammaged or installed backwards you will get same results as if it wasn't Make sure the timing marks line up on your timing belt. www.kiatechinfo.com

Posted on Jan 19, 2009

Anonymous

  • 7 Answers

SOURCE: 1997 Dodge Ram 1500 5.2 liter won't start

I WOULD SAY IT IS THE COMPUTER {BRAIN} THAT IS WHAT SENDS THE FIREING ORDER AND VOLTAGE AND SETS THE TIMEING SPECK I WOULD SAY CHECK THE COMP

Posted on May 26, 2009

Anonymous

  • 1 Answer

SOURCE: 2004 Kia Optima no start after timing belt, crank, cam sensor replacement

did you use aftermarket crank sensor? if so that might be your problem. dealer has several different ones, by providing vin number, but there is only one after market for all optimas 01-05. try to connect thick pink wire and thick orange wire together on the ignition failure sensor. you might have the same problem as me. good luck.

Posted on Jan 15, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1997 dodge ram 1500 4x4 abs light on runs fine idles good but put it into gear wont go past 35 mph engine running smooth even at 35 mph


Bernard's Blog: Dodge Transmission Output Speed Sensor

bernardsblog.blogspot.com/.../dodge-transmission-output-speed-sensor.h...
Sep 8, 2009 - My 99 Dodge 2500 Ram won't accelerate..transmission is NOT slipping,.... It has been running fine and the check engine light even cleared itself yesterday.... So it wouldn't go into first gear and then 3 minutes later my check engine ... I have a1997 Dodge Ram 1500 with a 5.9L instead of the stock 5.2L. It ...

Dodge Ram Idle and Stalling Problems - Car Forums at Edmunds.com

forums.edmunds.com > Dodge > Dodge Ram Pickup 1500

Aug 17, 2011 - 30 posts - ‎25 authors
Learn more about Dodge Ram Pickup 1500 at the Edmunds.com ... The crank sensorwas put on however it started stalling again. ... The truck starts fine, but will only runat 2000's RPM and only then if .... Then as I start driving about 1/3 of a mile go dead again, I knockout of gear, crank back up immediately.

WILL NOT GO OVER 30MPH WITH PEDLE TO METAL ...

repairpal.com > Questions > Dodge > Charger > 2006 Dodge Charger
I WAS DRIVING FINE AND THE CAR ACTED LIKE IT GOT STUCK IN ... Then the transmission didn't want to change into 2nd gear. .... Whenever i start up my car theabs and esp light turn on and when i try driving it doesnt go over 30 mph even .... in neutral but not it just wont go up hills and i think it has something to do with

Jan 07, 2016 | Dodge Cars & Trucks

1 Answer

Just bought. 5.9 cummins Can`t get it to start without pushing gas pedal slightly. Runs good after warms up. Still have to give it fuel to start.


Numerous Conditions May Cause Engine to Crank But Not ...

repairpal.com > Problems > Dodge > Ram 2500
2006 Dodge Ram Laramie 2500, 5.9i liter Cummins ... I know in the old days the dodges had a way about starting up an engine and that would be where.

White smoke, rough idle at startup - Dodge Cummins Diesel Forum

www.cumminsforum.com > ... > 3rd Gen. Powertrain
Jun 5, 2010 - 9 posts - ‎7 authors I have an 06 Dodge 5.9L that has a light white smoke and rough idle when first ... 2006Ram 2500 QCSB 4x4, 3" Carli coils w/ 1" Daystar spacer, ... Still ran good tho, dispite the exact conditions you describe on Cold Start up.

Oct 20, 2015 | 1995 Dodge Ram 3500

1 Answer

I have a 2004 dodge neon that I pressure washed the engine in. After doing so it would run and sounds fine till it hits 4000 rpm. the it just bogs down.It wont rev over 4000 rpm no matter what I do to...


You obviously got water in an electrical connector. Disconnect each one and blow it out with compressed air. This is why you should NEVER power wash an engine.

Mar 05, 2018 | 2004 Dodge Neon

1 Answer

2009 volvo S40 rpm's up from 3000 to 6000 without any gas acceleration. It will stay between 6000 and 7000 doing 65 mph without touching gas at all for a few second then drastically decrease in rpm's to...


Yeah, the Volvo dealer that you are dealing with is the proverbial POS - if possible cancel the deal, get your dinero back and get the car from an outfit that can properly service the vehicle.

Jul 17, 2017 | 2002 Volvo V40 Wagon

1 Answer

95 Ram occasionally wont start


Have you checked fuel pressure before and after cranking the engine ?

Jun 22, 2013 | 1995 Dodge Ram

2 Answers

My 1996 dodge 1500 with a 318 will not idle why is that?


stop and idle stops, starts right back up and runs fine with a few rpm

Jun 28, 2010 | 1996 Dodge Ram

1 Answer

Acceleration problem


the computer would have a fault code.. disconnect negative terminal on battery for 10 seconds. that should clear the fault.

Aug 25, 2009 | 1998 Dodge Ram 1500 4WD

2 Answers

2004 stratus 2.7L Erratic idle, sometimes dies, sometimes revs at stops


hey-I have has this before different car but same - idle control valve is failing - computer at shop will pick this up on diagnostic

Oct 12, 2008 | 2004 Dodge Stratus

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

41 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

Marvin
Marvin

Level 3 Expert

85223 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...