Question about Kia Cars & Trucks

1 Answer

HI ,I HAVE A 2005 KIA DEISIL IT HAS THE EML LIGHT ON AND WHEN I TRY TO MOVE CAR IT CUTS OUT ,AND WONT START AGAIN FOR AROUND 10 MINS.

1991CC

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Kia Master
  • 199 Answers

Here's the link and I'm sure you will get the solution of your problem
How to repair and service any Kia vehicle

Posted on Jul 17, 2016

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2005 1.0 kia picanto cel flickering wont start


Try to scan it and retrieve code from check engine light it could cause so many things. You need to start from tehere to reveal code.

Feb 06, 2012 | 2005 Kia Picanto

1 Answer

I have a 1999 e320 that runs fine when its cool but when it has been driven for about an hour and warm up real good it cuts off and wont start again until it cool off....... Can someone please help me


Sounds like the same problem I had about 2 years ago in my 00 e320 cdi. The car was cutting out after about 10 mins in traffic and would only start again when cooled down. I couldnt tell you what sensor it was but it was only a simple sensor and I would be a 100% that it was the same problem.

Dec 21, 2010 | 2005 Mercedes-Benz Mercedes Benz E320 Cdi

2 Answers

Hi I own A 98 Chevy Malibu, my ignition locked n i had to put a new ignition switch in, well now my cars tellin me Something Theft Service. Im wonder what I need to do? Iv unhooked battery for hours ect...


You need to reset the theft system. To do this, try to start it. It should start and die. Then after it dies and the theft light is flashing, leave the key on for 10 minutes. After 10 min, the theft light should go out. After the theft light goes out, turn off the key. Count to 5, then restart it. Then it should work.

Nov 07, 2010 | 1998 Chevrolet Malibu

1 Answer

Hi there, cutting out in traffic


camshaft sensor need repalcing, simple fix is, have a bottle water with u, when engine cut out pour slowly some water on top of engine where the sensor is located, it cool down fast then u can start again and continue drive until it too hot again,
sensor is located on top of engine close to firewall in the middle.

Apr 19, 2010 | 1999 Suzuki Grand Vitara

4 Answers

My 2003 kia turns over but will not start, it ran good earlery


We replaced the crank sensor and another sensor still nothing.

Aug 18, 2009 | 2005 Kia Sedona

1 Answer

My 90 model prelude runs fine for about 10 to 15 mins then cuts out and wont restart but if you leave it for around 10 mins will start again. if i turn it off again same problem it wont start. it seems to...


ignition modual . net time it dies take one of the pluge wires off and check for spark by sitting it close to a ground and crank the engin . if no spark it very well could be a control mod

Jun 04, 2009 | 1990 Honda Prelude

1 Answer

Removal of battery


hi in order to remove the battery u need to unscrew the two nuts on the top and than pull it out .. sometime the nuts are jammed so just put some wd40 or little engine oil and after 3 mins or 5 just try to unsrew it again and it should come out fine..if not only option take it to any garage..if ur car not starting because battery stuffed.
just get ur mate car and pull battery out ..connect ur car leads and start the car..
once car started just un plug ur battery cable and just keep both cables seperate for it wont spark..
your car still remain started the only thing is that you wont be able to use horn or lights and few more electric items..
should work.. i did it before..

May 13, 2009 | 2005 Kia Sportage

2 Answers

My car engine light is on and the problem code p2626


I'm about 99% sure this has to do with a faulty O2 sensor. This sensor is usually located around the header of your car, or down more on your exhaust. Try disconnecting your battery for 30 mins, hook it back up, and start your car again. This will erase the error. See if it comes in again.

"P2626 O2 Sensor Pumping Current Trim Circuit/Open (Bank 1 Sensor 1)"

May 04, 2009 | 2006 Kia Spectra

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

37 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Marvin
Marvin

Level 3 Expert

85216 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...