Question about 1996 Jeep Grand Cherokee

1 Answer

Why does the Engine fire but dies?.

Tach shows 0 rpm and gauges do not work

Posted by Anonymous on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

So you could have bad wiring, or fuel injectors. If your engine fires up it's getting fuel, but you could have bad sensors, or your wiring to your pcm, and fuel controls could be bad.

Posted on Nov 20, 2018

Ad

2 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

JOHN LAPIER

  • 2595 Answers

SOURCE: 2000 Grand Cherokee V8: Cold start Oil Pressure is

Replace the oil pressure sending unit its giveing a false reading . The problem is when the engine is cold the oil pressure is low and it takes a little time to build up whem cranking the engine and that sends a signal to the computer PCM /VCM what ever but your 40 to 60 lbs oil pressure is graet its ideal .The unit switches when the oil pressure is high enough to trip the switch inside the sending unit and that is sent to the vehicle control module

Posted on Feb 05, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Do the RPM gauge supose to move up on dash when cranking?


The tach readout is controlled by software in the Instrument cluster (IC) based on the values sent from the VCM/PCM. The readout on your scanner should show the correct rpm values (120 to 240 is wrong). Therefore, if the engine is running normally, the computer is probably not sending the correct values to the IC, but the crank sensor is OK.

Jan 01, 2017 | GMC Cars & Trucks

1 Answer

The van will start fine but when put in drive it dies and the RPM's gauge will go all over the place from 0 to 7 when at an idle, what could this problem be?


Likely the crank position sensor. That would operate the brain and the tach. You got a "check engine" light? If so, get the codes read, that will confirm or give you something else to look at.

Jun 08, 2015 | 2000 Pontiac Montana

1 Answer

2008 saturn aura xe3.5 motor 56,000 mile just purchased having problems with it already. ..engine light came on had it check out at auto zone ..only one code p 330 knock sensor. Engine light is off..but...


Bad ignition module often will not set a code for itself. Hard to diagnose due to being so random. Also just possible tach feed wire is shorting somewhere, coming and going.

Mar 28, 2015 | 2008 Saturn Aura XE

1 Answer

Ignition module problems


No Start Diagnostic Basics EricTheCarGuy Does it have spark ? fuel pressure ? Maybe your best bet would be to take it to a qualified repair shop .

Mar 11, 2017 | 1999 Plymouth Prowler

1 Answer

My '99 Prowler has been running great for the last 267,000 miles, yes that number is correct, and was until about three weeks ago. I was cruising about 45 mph and it just shut down. I safely got to the...


Start by checking all your fuses. If not, take your time and look for any bad plugs or connections in the wiring harness. Oil or debris might be making a contact you don't need. TAKE YOUR TIME DOING THIS! Also notice Cam and Crank sensor are two different ones.

Mar 10, 2017 | 1999 Plymouth Prowler

1 Answer

When driving down the road engine cuts out and the rpm gauge goes up to about 6000. any ideas??


check your plug wires and or coil packs. my wife's car had hesitation problems and dying and when It died the tach always pegged out until you cycled your ignition switch and or attempted a restart.

Oct 22, 2013 | 2004 Hyundai Santa Fe

1 Answer

I have a 1999 5-speed ford escort zx2, while im driving my rpm will jump up and down all the way to 0 and stay at 0 for a second and jump back up and down, .


Tach spring is breaking, you can get a seperate tach gauge in place of what you got. or how about this take dash out and get another tach gauge they are removable

Apr 22, 2011 | Ford ZX2 Cars & Trucks

2 Answers

75vette tack stuck at max rpm, both with engine on


Chances are its not the Tach. Look over the wiring to the tach. Its it brittle about to crust off? Is it shorted to ground? Now that would pin it. Check its connections off the coil. Engine side of this item is usually where you'll find the problem. This is nothing new with a vette definately not serious. Remember the tach responds to electrical signal it gets. Before you do the surgery on the gauge itself make sure nothing is shorting this out.

Mar 26, 2010 | 2005 Chevrolet Silverado

1 Answer

Defective tachometer and speedometer


Do the following:1)key in the ON position:remove the 7.5 gauge fuse.Tach needle should read "0:". 2)put it back,go on the engine and unplug the green plug on the igniter -the big one,with 5 or 6 wires on it.The needle on tach reading should be zero.If not you have a short circuit on the black wire between that plug and the plug on the conbination meter.3) If the reading is zero with the plug disconnected,the black wire for the tach is short-circuited inside the igniter. I have one available.email daddykouki@gmail.com

May 30, 2009 | 1989 Toyota Corolla 2 Door

Not finding what you are looking for?
1996 Jeep Grand Cherokee Logo

Related Topics:

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

Marvin
Marvin

Level 3 Expert

85223 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...