Question about 2007 Mitsubishi L-200 2.5

1 Answer

Why is my 07 Mitsubishi triton speedo not working?

Hi guys. Took my triton for a detail to sell, and when i picked it up the speedo wasn't working. Checked the sensor and it seems to be fine and the connections in the back of the cluster are all plugged in properly. Is there anywhere else to check. Have not yet tested the signal at the cluster but intend to do that as soon as i get a chance.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 488 Answers

Check the signal at the sensor with a multimeter. Most have three wires, one is a 12volt feed, one is a ground and the third is the signal wire. This wire is usually only 5volts and is grounded and ungrounded by the sensor in precise timing intervals as the sensor rotates. This means that to check its operation, make sure it has the 12volt feed and the ground, then, Jack up one rear wheel and chock the rest. Select neutral and release the parking brake.
Turn the ignition on BUT DONT START THE ENGINE. Reconnect ALL the wires to the sensor and then backprobe the signal wire you found earlier with a multimeter. Once you have the wire probed, slowly rotate the wheel by hand. The meter should show the 5 volt drop to nothing, then back to 5volts, then nothing, then 5volts and on and on as long as you rotate the wheel. If this 5volt is not present, check the instrument cluster as this 5volts comes from the speedo head. If the 12 volts is not present, check all fuses WITH A TEST PROBE - looking at the fuse is not enough and check the wiring to the sensor. If the ground is missing, check the earth point on the chassis under the rear of the cab and under the bonnet and repair and issues found.If all these tests show good and you have the alternating 5volt voltage, check the same signal wire at the cluster, if it still alternates when you turn the wheel by hand, repair the speedo head. If the 5volt signal feed from the speedo head is missing, check the wiring to the speedo head, if the signal is not present at the speedo head, repair the speedo head.

Posted on May 20, 2014

Ad

6 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Anonymous

  • 1 Answer

SOURCE: Problems with lancer MR speedo revs and odometer

exact same problem happened with my lancer i took it to an auto instrument shop and it cost me $330 to fix and hasnt stopped working since.

Posted on Oct 19, 2009

Sabo Gerovski

  • 271 Answers

SOURCE: My 1997 Mitsubishi Galant won't start. Initially

You have short circuit between battery positive terminal and chassis.Follow a cable from battery to an alternator.If O.K. remove alternator and check all diods- 6 pse.Also check cable from battery to a starter motor.

Posted on Dec 01, 2009

Testimonial: "Thank you very much for your help. The problem has been fixed."

bbbman78

Drew Z

  • 681 Answers

SOURCE: What do you mean cluster contacts bad !Whats the solution?

Remove the speedometer head unit, and check the soldered joints on the back. It's a common problem with these and some Chrysler products. "Randomly" is when the crack closes and makes contact, like if you hit the top of the dash and it starts working again. The speedometer head cluster.

Posted on Feb 24, 2010

Testimonial: "Great that explains it well Thanks"

sisadsl

gavin jones

  • 1508 Answers

SOURCE: how do you know if your fuel pump is working

Petrol? put a pressure gauge on the outlet and spin the motor over, I guess it should be 4-5psi. The ethanol in fuel has a habit of eating the internals of fuel pumps

Posted on Apr 24, 2010

Testimonial: "thanks very helpful"

Dennis Stockam

  • 73 Answers

SOURCE: My mother in law owns a CE lancer 2003 auto, and

what ever your last reading was on your odometer thats where it will start to work from. so it will be like you got a new one from like autozone. i hope thats what you wanted to know

stockam auto

If you need further help, reach me via phone at https://www.6ya.com/expert/dennis_f849d3d6a68c6430

Posted on Jul 21, 2011

Testimonial: "cheers"

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1999 f250 4x4 triton v10 tho odometer works now and then it shifts hard out of first and drive is like netural


Unfortunately you need a new transmission. A bad speed sensor can cause the transmission to shift hard but if it is free wheeling in 3rd gear that has nothing to do with the speedo.

May 02, 2012 | Cars & Trucks

1 Answer

'01 Nissan Sentra stalling when stopped - shop has had it 5 months: help!


If the idle air control valve is working, the passage may be clogged. Other things to check are the PCV flow and possible vacuum leaks.

Please see my tip at http://www.fixya.com/cars/r7427423-fix_poor_idle_high_idle_stalling_fuel . These are generic instructions. If you get stuck or need specific instructions for your car, please get back to me with engine size info.

Dec 30, 2011 | Cars & Trucks

2 Answers

2001 Ford Falcon AU111 speedo not working again. 4 weeks ago the sensor was replace as the speedo, odometer and the DTE were all not working. All has been good until last week, now only the speedo not...


Hi,
Just check the connection on the speedo sensor and the wiring that leads up till it gets to the main loom. There could be a loose connection there.

If thats ok then you will need to get the loom checked and the dash. It could be the dash is faulty..

Thanks

Jason

Apr 26, 2010 | Ford Futura Cars & Trucks

1 Answer

Speedo not working in landcruiser. took out put in other toyota and it works fine. replaced speedo sensor in tranfercase thought that might be it still does not work. sensor has power to it. also i can...


No,the tone ring for your speedo sensor should be fixed and not move with your fingers.That is your problem.The tail houseing on your t-case will have to be removed and then you can find what broke.

Oct 06, 2009 | 2003 Toyota Land Cruiser

1 Answer

Speedo and odo dont work


speed sensor that is located in your transmission well in the back partby differential either sensor or wireing coming from it.

Sep 01, 2009 | 2001 Audi A4

2 Answers

Where is the speedo sensor?


do you have the right part,speedo sensor on the dif casing picking up off a half shaft.possible you have been given the wrong part

Jul 29, 2008 | 2000 Ford Focus

Not finding what you are looking for?
2007 Mitsubishi L-200 2.5 Logo

4,561 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

Marvin
Marvin

Level 3 Expert

85216 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...