20 Most Recent 1999 Chevrolet Silverado 1500 - Page 7 Questions & Answers


I would check the actuator motor under the dash in the center to make sure the motor is getting power or it may have gone bad if you are not getting air in the direction you want.

1999 Chevrolet... | Answered on Nov 29, 2015


Save yourself some time and just tighten the sensor until it is tight and don't over tighten it but just turn it tight. Once it is in run the truck and make sure it is not leaking.

1999 Chevrolet... | Answered on Nov 29, 2015


Pull the 02 sensor ahead of the cats and see which one allows the engine to run best and that is the one you want to change. On a 199 you may want to change both because about time you do one it won't be long before you do the other.

1999 Chevrolet... | Answered on Nov 29, 2015


There is a belt routing on the radiator support under the hood.

1999 Chevrolet... | Answered on Nov 29, 2015


check the actuator motor on the heater sounds like the motor is not directing the air as it should. The motor is in the center of the truck inside attached to the heater and has arms on it to move the heater and ac doors.

1999 Chevrolet... | Answered on Nov 29, 2015


Do you have power in and out of the pump relay when the key is turned on ?

1999 Chevrolet... | Answered on Nov 17, 2015


can not get the lights to come on or go into four wheel drive bought new four wheel drive switch for dash but didnt help

1999 Chevrolet... | Answered on Nov 12, 2015


hey check ur abs wheel speed sensors. check data when ur moving lf rf and rears should be reading same speed. its probably gonna be a bad wheel bearing cause that where ur speed sensors are built in to. u need a abs scan tool to monitor ur wheel speed parameters in order to pin point ur bad sensor. or pull codes from ur abs module and see what side it says is failing. good luck

1999 Chevrolet... | Answered on Nov 11, 2015


you knead to find out what numbers on the front dif is and match it up to the back there is numbers on the rear dif that will give your answer

1999 Chevrolet... | Answered on Nov 04, 2015


I wonder if you accidentally disconnected a body plug.
When the truck was assembled at the factory, there were several plugs that were plugged in in the areas of the firewall and fender panels .
In the moving of the engine and transmission, you may have bumped one of these loose.
God bless your efforts.

1999 Chevrolet... | Answered on Oct 29, 2015


check battery charge, starter, spark plugs, spark plug wires

1999 Chevrolet... | Answered on Oct 09, 2015


they are usually a sticker under the hood or core support

1999 Chevrolet... | Answered on Sep 28, 2015


Sounds like the fuel injector on the passenger side is bad. Are the plugs on the driver side clean if so that is your problem.

1999 Chevrolet... | Answered on Sep 16, 2015


unless you know what you are doing serious injury can result due to the front spring is pushing on the lower A-arm.

1999 Chevrolet... | Answered on Sep 02, 2015


read the manual or just ask chevy service

1999 Chevrolet... | Answered on Sep 02, 2015

Not finding what you are looking for?
1999 Chevrolet Silverado 1500 Logo

6,279 questions posted

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

85222 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Silverado 1500 Chevrolet

  • Silverado 1500 Chevrolet

Most Popular Question

1999 chevrolet silverado 1500 z71

  • Cars & Trucks
Loading...