Top 20 1993 Buick Riviera Questions & Answers


First - are all the wires connected properly from when you changed the pump? Next - try taking the positive cable off the battery and touching it to the engine or body of the car or the neg post on the battery. You want to clear any residual energy from the electronics. Make sure that everything is off in the vehicle and the doors are closed. Now reconnect the battery. It is worth a try. You may have arced the connection when you installed the battery and set up false codes on the computer chips in the vehicle.

1993 Buick... | 73 views | 0 helpful votes


Did you check the fuse? Not only check the fuse, check voltage on fuse circuit , goes hot with key on. The bottom info should be for relay center location.
suspension fuse-ah4hlr42fk2bjlxp04hurvgv-1-0.jpg

relay center-ah4hlr42fk2bjlxp04hurvgv-1-2.jpg

1993 Buick... | 147 views | 0 helpful votes


In the high pressure line on the way to the evap core. Look for a connector with factory crimps in the tube. High pressure is the smaller diameter tube.

1993 Buick... | 39 views | 0 helpful votes


you need to have the car scann the ecu and see whtat code show posible you have problem whit coil pack or sark wires or ignition module

1993 Buick... | 99 views | 0 helpful votes


not for sure but it could be your cam sensor. if the check engine light is on then take it to a parts store and they can run a scan and give you more information

1993 Buick... | 266 views | 0 helpful votes


Overheating, maybe? Get a technician to read the diagnostic codes (or rent/buy the tool to do it yourself) they will almost certainly tell you what is wrong.

1993 Buick... | 86 views | 0 helpful votes


The automatic light sensor is a fish eye bubble on top of the dash.

DO NOT use dash mat,it may cover the sensor and disable the auto brightness feature.

1993 Buick... | 148 views | 0 helpful votes


how did you disconnect the battery, pos first then neg ? or neg first then pos ? try starting it and after started, hold your rpm at 1500, for about two minutes, then if still running, drive it to get to.speeds of 40 for about 15 minutes, this is to relearn if not, disconnect your battery, take the pos and neg cable and touch them together and hold for about a minute, then Connect them back, neg.first.then pos, then follow steps above to.relearn.

1993 Buick... | 140 views | 0 helpful votes


Hi Rita, are there any warning lights on the dash? How long does it run for. starting and running for a second or two would indicate an immobilizer fault and that the key has lost its code with the car That would need to go to a garage. Jon

1993 Buick... | 117 views | 0 helpful votes


sounds like it could be in the strut plates or tie rods if the wheel seems sloppy or possibly even a hub

1993 Buick... | 136 views | 0 helpful votes


Could be low pressure from the fuel pump but without my head under the bonnet i couldnt give a proper answer

1993 Buick... | 87 views | 0 helpful votes


check front axles for cracks or rips in boots the axles could have dried up if grease leaked out

1993 Buick... | 41 views | 0 helpful votes


may be a rubber suspension bushing. it can be inspected by someone that has some knowledge.

1993 Buick... | 28 views | 0 helpful votes


If it gets bad enough, it will come apart. The other end will still be attached to the motor and can flip around and damage lots of things.

1993 Buick... | 18 views | 0 helpful votes


Change the spark plugs end wires. One bad plug or a wire can cause a miss like you wouldn,t belive. Evan on a vehicle with low miles on it.

1993 Buick... | 209 views | 1 helpful votes


Hi, Starter has a bad connection or is bad all togeather. Check and/or replace.

1993 Buick... | 22 views | 0 helpful votes


its a fuel issue ! check fuel filter for clogging up with dirt.and be sure fuel pump is working properly.

1993 Buick... | 68 views | 0 helpful votes


Linkage may be worn out if you can't reliably get it into park. I would take it to a certified transmission shop or tech and see what can be done about it.

We had a similar problem on a 1980 Chevrolet Suburban that had a worn out linkage inside of the transmission, and it would not go into park very reliably. It had about 100k mi. on it at the time.

1993 Buick... | 105 views | 0 helpful votes


HEATER AC BLOWER MOTOR POWER CONTROL MODULE or a relay control mod is under hood remove plastic panel above fire wall an its almost in the middle but more toward passanger side with two plugs in it thats most likely yrrr prob

1993 Buick... | 158 views | 0 helpful votes

Not finding what you are looking for?
1993 Buick Riviera Logo

63 questions posted

Ask a Question

Usually answered in minutes!

Popular Products

Top Buick Experts

Marvin
Marvin

Level 3 Expert

85216 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Riviera Buick

  • Riviera Buick

Most Popular Question

1993 buick riviera miss in engine loses

  • Cars & Trucks
Loading...