Question about ATVs

Open Question

What should the settings be on a dynatek installed on a 2008 brute force 750?

Posted by on

Ad

5 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
irtlmn

Behind_Blue_Eyes

  • 1727 Answers

SOURCE: 2006 kawasaki brute force 750 v twin Heard a loud grinding noise and it died and will not turn over. it was full of all fluids. drained oil no shavings, thats as far as i got

check your drive system... it could lock up and cause your issues. Ive seen it before

Posted on Dec 29, 2013

Ad
garbala1

Gareth Williams

  • 16 Answers

SOURCE: 08 750 brute force spuddering in reverse on, any ideas

Press the override button while in reverse. If it's still not working, try checking the wiring harness.

Posted on Feb 18, 2016

AndrexT

Andrew Taylor

  • 29404 Answers

SOURCE: I have a 2011 brute force 750 when I first crank it up what will make it smoke when I give it gas but ones I ride it for a min it won't smoke anymore?

normally a slightly worn bore, or tight piston rings. They leak oil past when cold, and then tighten up and seal when the engine warms up. You can try one of those carbon cleaning liquids that you squirt in the spark plug holes when the engine is hot, leave it overnight and then start up. It frees up rings and gets rid of carbon. Makes lots of smoke when you start back up, so don't get frightened!

Posted on May 08, 2016

emissionwiz

Marvin

  • 85206 Answers

SOURCE: Kawasaki Brute force 750 Eps light on will not reset

The light will go off when the fault that is keeping it on is fixed. You need the system scanned for the fault code.

Posted on Feb 10, 2017

Testimonial: "Thanks for your input!"

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2005 brute force 750 won't start with electric start it will start when I pull start it will run.when it's running the lites and display are flickering .


Sounds like your battery is about dead... replace the battery and clean the connectors/wires/terminals.. and a little waterproof grease will stop the corrosion. Make sure the new connections are tight!

Jan 25, 2017 | kawasaki 2005 Brute Force 750 4x4i

1 Answer

I got a 05kawaiski brute force 750 4x4i and it wont start acts like the batt is diedbut its a new batt


You already gave me a negative. I will let someone else ring in, I just asked a question.

Sep 23, 2016 | kawasaki 2005 Brute Force 750 4x4i

2 Answers

Hit the start button and nothing happens 2008 750 brute force


Check your starter solenoid. You can trace it by following the power wire from the battery to the small solenoid block that contains a 30 amp fuse. You can bridge the posts on the solenoid by using needle nose pliers or whatever else you may have. If it starts up or you hear the starter run, you have a bad starter solenoid.

Feb 02, 2016 | kawasaki 2008 Brute Force 750 NRA OUTDOORS

1 Answer

05 kawasaki bf 750...battery was low......put a new one in..........now backfires out the exhaust.......tried the belt reset.....didnt help......suggestions.?.....


Brute force backfire problem - YouTube

? 1:06
www.youtube.com/watch?v=VFxGBYoVFqk
May 5, 2013 - Uploaded by gubba1957
I bought this 2006 750 it had a backfire problem when I bought it so I cleaned ... 2005 Kawasaki Brute Force 750 - Stock Exhaust Modification ...

Oct 03, 2015 | kawasaki 2005 Brute Force 750 4x4i

1 Answer

09 brute force was running then died now now spark


Check the electronic ignition circuit, you problem lies there. Could be something very simple like a ground wire failing to make contact.

Mar 07, 2015 | kawasaki 2009 Brute Force 750 4x4i

1 Answer

Brute force 2009 750 runs but will back fire an stop


How long since the oil has been changed? Is the oil level OK? It sounds like you have a sticky valve that hangs open once in a while.

Jul 31, 2014 | kawasaki 2009 Brute Force 750 4x4i

1 Answer

Kawasaki atv


There is a video on Youtube
15# How to reset belt light - Kawasaki brute force 750i

Jun 19, 2013 | ATVs

Not finding what you are looking for?
ATVs Logo

Related Topics:

28 people viewed this question

Ask a Question

Usually answered in minutes!

Top ATVs Experts

john h

Level 3 Expert

22486 Answers

Marvin
Marvin

Level 3 Expert

85206 Answers

 Scott Tx
Scott Tx

Level 2 Expert

604 Answers

Are you an ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...