xheli Recent Questions, Troubleshooting Help & Support

Do you work here? Claim your company

  • 36 Products
  • 80 Answers
  • 20K Views

Test the batteries somewhere else, the batteries might be bad.
Then test a different set of batteries in the RC.

xheli 3 Ch Syma... | Answered on Sep 08, 2017


try this,switch the helicopter on,then make sure the left controller stick is fully down then turn the controller on,move left stick fully on then fully off should be ready to fly,have fun

xheli 3 Ch Syma... | Answered on Dec 28, 2015


If you hear the motor spinning but not the blades, check the main gear. One crash can knock out enough teeth to cause this problem. You have to remove the landing gear and battery tray to get to it. If the motor isn't spinning, check the motor by applying voltage to it. If that works, swap out the receiver. I've gone through all of the above over the course of time.

xheli Exceed RC... | Answered on Jun 10, 2014


did you put all 8 of the batteries in it? it takes 8 AA batteries.

xheli 9053... | Answered on May 24, 2014


I own this heli also. The problem is that the tail rotor does not apply enough push to tilt the heli forward. It is this forward pitch that moves the heli forward. Aside form buying a stronger tail motor, upgrading your battery etc, the only thing you can do id this:

Get a credit card, a pair of scissors and some tape. Cut a couple of strips from the credit card about 2 1/2 - 3 times wider thhan the tail rotor blades and the same length. Now tape the strips to the top of the tail rotor blades. Make sure you don't increase the length.

This will help a little by providing more air push when the tail rotor in engaged. Without some serious modding, this heli will never be great.

I have more fun flying my micro size syma helicopter in the garage then I have flying my volitation. If there is even the slightest breeze, the volitation will float in the direction of the breeze and will not fly against it.

xheli 9053... | Answered on Feb 26, 2014


Hi,
Looks like a board circuit problem. If its new, you have to return it and replace it with another one, try it before going home.
Try this, open the board, there are two trimming resistor adjustment, one for the rear motor and the other one controls the main motor, try to adjust it while your switching the remote controller to lift.
If that does not work. The little servo on the board are busted and you need to return the product!

Thanks for using Fixya!

xheli Syma S031... | Answered on Jan 13, 2014

Not finding what you are looking for?

Ask a Question

Usually answered in minutes!

Top xheli Experts

Todd Strom

Level 2 Expert

67 Answers

Heliguy

Level 1 Expert

1 Answers

Tom Chichester

Level 3 Expert

50983 Answers

Are you a xheli Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...