Xact Communication Recent Questions, Troubleshooting Help & Support

Do you work here? Claim your company

  • 38 Products
  • 111 Answers
  • 17K Views

EL SEGUNDO AURICULAR NO ME DA TONO DE LINEA ME MANDA UN MENSAJE EN PANTALLA DE "BORRAR" COMO ACTIVO EL SEGUNDO TELEFONO ....URGE

Xact... | Answered on Apr 10, 2014


This condition is usually caused by a battery that has been charged too much or incorrectly. It has developed a memory and now can only hold a very small charge. I believe it is time for new batteries!

Xact... | Answered on Jan 22, 2014


your device should be marked with polarity and voltage requirements. Any power supply with the correct plug meeting those specs (if amperage isn't marked, look for one that is between 500- 1000 mA) should be fine. MAKE SURE it is a DC supply if the device you are using is marked DC.

Xact... | Answered on Oct 23, 2013


Many times the hissing can be caused by a bad or poorly charged battery, or by activating an interference eliminator code in all your radios. First, we would suggest changing the battery, or exchanging it with a known good radio's battery to see if the problem clears up. Environmental RF can also cause issues, so you might check to see if the same problem exists in a different location.

If these suggestions do not solve the problem, then you possibly have an internal issue which would deem the radio non-repairable. Parts and schematics were never offered for this line of radios.

Best regards.

Xact... | Answered on Oct 17, 2013

Not finding what you are looking for?

Ask a Question

Usually answered in minutes!

Top Xact Communication Experts

ka4iup
ka4iup

Level 3 Expert

4062 Answers

eradiostore
eradiostore

Level 3 Expert

1655 Answers

phgentry
phgentry

Level 1 Expert

2 Answers

Are you a Xact Communication Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...