Razor Logo

Razor Recent Questions, Troubleshooting Help & Support

Do you work here? Claim your company

  • 103 Products
  • 865 Answers
  • 172K Views

i have the same exact problem on 1 of my sons MX5s..i checked all 3 batteries and all that! you left out the controller clicks when the back wheels sapose to be moving ,it's not....so worse case scenerio batt,controller,motor,(650 This time)& throttle....So theres our blue print...lets hope it's just the batteries....!

Razor MX350 DIRT... | Answered on Mar 27, 2016


http://www.scootercatalog.com/ottrshti.html
This site has everything to check if scooter is not running regarding fuse problems.

If you need further help, reach me via phone at https://www.6ya.com/expert/kelley_9a924afdf232bd4d

Razor Cycling | Answered on Mar 14, 2016


Try battery first check with digi. volt ohm meter, but yes it could be module.

Razor Crazy Cart... | Answered on Jan 26, 2016


If the batteries are connected correctly (red to +, black to -) then the motor is trashed

Razor E300... | Answered on Jan 25, 2016


Your battery is no good and needs to be replaced.

Razor Sport Mod | Answered on Dec 23, 2015


you can do anything you want if it is yours . but it may not work as you hope it will

Razor E300... | Answered on Oct 16, 2015


Try connecting the red wire to the + battery post and the black to the - post.

Razor Dirt... | Answered on Sep 27, 2015


by the battery

Razor Trikke E2... | Answered on Jul 28, 2015

Not finding what you are looking for?

Ask a Question

Usually answered in minutes!

Top Razor Experts

Tom Chichester

Level 3 Expert

51371 Answers

Lawrence Oravetz

Level 3 Expert

10528 Answers

ray gallant
ray gallant

Level 3 Expert

62043 Answers

Are you a Razor Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...