Mercury Car Audio & Video - Recent Questions, Troubleshooting & Support


This engine doesn't have any such part, the ignition system is fully computer controlled. Vacuum advances went away with the advent of computers.

Mercury Villager... | Answered on Dec 16, 2016


Most likely ball joint or tie rod ends

Mercury Mariner... | Answered on May 10, 2016


There are a lot of possibilities for this. Have you had the tires checked? How many miles are on the front tires? Tie-rod ends being worn could also be a possible cause as well as wheel bearings.

Mercury Mystique... | Answered on Nov 03, 2015


Door switch is stuck in closed position.

Mercury Villager... | Answered on Oct 18, 2015


round unit in the fusebox

Mercury Villager... | Answered on May 18, 2015


First thing I would look for is a broken small vacume hose or a hole in one.... saw one guy use a spray bottle of just water around the hoses and when water was sucked in the RPM changed... Hence you find the broken hose...

Mercury Sable... | Answered on Apr 28, 2015


If its cranking then the starter is engaging. If there are any check engine lights on, then have them read. Autozone does it for free, just call ahead to make sure it works and there is someone there to use it. Other probabilities are fuel pump not working correctly, fuel filter clogged. Maybe get a chiltons or haynes repair manual and check out troubleshoo

If you need further help, reach me via phone at https://www.6ya.com/expert/frankie_091f536560a54e12

Mercury Villager... | Answered on Jun 11, 2014


My first guess is that you have a problem with your electrical system. I would look at the battery cables first. Any corrosion or loose connections could cause these symptoms. Both the positive and negative cables need to be inspected (from end to end). What tests have you run? What have you inspected so far? The condition of the battery and the alternator need to be determined. If you would write back with more information. I will try to help you narrow this down, good luck.

Mercury Villager... | Answered on Mar 01, 2014


You would think that a brake line would be a standard off-the-shelf item obtainable from a parts supplier, but no. Apparently replacement lines have to be custom made by a shop that specializes in this work.

Mercury Villager... | Answered on Jan 12, 2014


check your distributor rotor it is the white thing under your distributor cap if the ends are blackesh brown its burnt up i was getting a misfire because of that

Mercury Villager... | Answered on Jan 12, 2014


Sounds like a wheel bearing to can't be sure without hearing it for myself call:8174570887 for more info.

Mercury Villager... | Answered on Jan 29, 2013


replace your headlight switch

Mercury Villager... | Answered on Jan 22, 2013


Get your owners manual and look for the fuses that controk those features and then replace them that should fix the problem

Mercury Mariner... | Answered on Dec 18, 2012


Check for a blowin fuse, Resister, Defective Relay, Or burn,t out blower motor,

Mercury Tracer... | Answered on Dec 04, 2012


Borrow a repair manual from a libarry,

Mercury Villager... | Answered on Nov 28, 2012

Not finding what you are looking for?
Mercury Logo

33 questions posted

Ask a Question

Usually answered in minutes!

Top Mercury Car Audio & Video Experts

Marvin
Marvin

Level 3 Expert

85111 Answers

gerry bissi

Level 3 Expert

4387 Answers

xxxxxx xxx

Level 3 Expert

5013 Answers

Are you a Mercury Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...