Hitachi Cameras - Recent Questions, Troubleshooting & Support


Your camera is a fairly low specification by today's standards and it would probably cost more to repair than to replace it.

I suggest you take it along to your local phone doctor for a qualified opinion...

Hitachi Cameras | Answered on Dec 20, 2018


Is this information not in the manual ?

Hitachi Cameras | Answered on Jul 29, 2017


There is a mode switch within the deck assembly that is probably dirty but not cleanable. I haven't repaired one of those for some years and am sure spares are no longer available for it. The 58 is V8 format and should be OK but may show similar symptoms due to age, in the future.

Hitachi i.mega... | Answered on May 24, 2017


Try Googling (hitachi)(X500)(manual) without parens.

Hitachi Cameras | Answered on May 19, 2017


Follow the instructions in the manual

Hitachi Cameras | Answered on Apr 11, 2017


ive just had the same problem and solved it first you have to plug it into the pc with the usb then just before it goes onto the menu for pc,bridge,and pc camera pull the lead out quickly as you can. the camera will stay on to allow you to the next step

go into the menu and click next menu and go to fr. no. reset. and click execute then go back to the second menu and go to sys. reset and click it the click execute.

once this is done turn the camera off wait 10 seconds then hold down the power button until it turns on

done

if you have trouble let me know and il guild you through it slowly

Hitachi Cameras | Answered on Apr 26, 2016


yes system conversion is you need just change the crystals! buy a palsecam crystal then replace the old crystal.

Hitachi M2... | Answered on Dec 08, 2015


Try formatting the card using the option in the camera itself. or take the card out and put in laptop / PC using the card reader and try formatting the card.

Hitachi Cameras | Answered on Feb 22, 2015


Try formatting the sd card using the camera. You should be able to find in the menus.

Hitachi Cameras | Answered on Feb 22, 2015


  • check if the batteries are fully charged.
  • try resetting the camera.
  • zooming motor has gone bad. have it replaced.

Hitachi Cameras | Answered on Feb 22, 2015


Looks like the batteries have lived their life. Please change it.

Hitachi Cameras | Answered on Feb 22, 2015

Not finding what you are looking for?
Hitachi Logo

179 questions posted

Ask a Question

Usually answered in minutes!

Top Hitachi Cameras Experts

Parshiv Luthra

Level 3 Expert

395 Answers

Damen Wong
Damen Wong

Level 3 Expert

1950 Answers

Marvin
Marvin

Level 3 Expert

84027 Answers

Are you a Hitachi Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...