Electric Toys - Recent Questions, Troubleshooting & Support


The battery has probably died. Use a voltmeter to determine what voltage is in the battery. If you don't have one, take it to an auto electrician, he will be able to tell you if the battery is dead or not. Most batteries only last 2 or 3 years. Check if there is enough water in the battery. Use distilled water. If its a "non serviceable" battery , you will only be able to test the voltage. The sticker on the battery will tell you if its 6 or 12 volt DC

Electric Razor... | Answered on May 03, 2019


since fixya did not sell it to you who knows??

Electric Toys | Answered on Sep 22, 2018


If available, it will be on the manufacturers web site.

Electric Toys | Answered on Aug 20, 2018


Don't have one but last year I sent mine to shop in Florida and have it repaired in a week for $199. Sorry but I can't remember name of that shop. I found them using Google and you deal with them via ebay. Check ebay first. It was too complicated for me to try myself. There are logic chips which may require programming etc. $199 was best price I found.

Electric... | Answered on Mar 07, 2018

Tip

Troubleshooting and Fixing Model Trains That Won't Run


If your train won't run at all, the first challenge is to find what is wrong. If the problem only started after you made recent changes to the track or trains, start there first. If you have no idea where to begin, the six steps below will walk you through the most typical problem areas.
Some problems are easy to solve. If you have a broken locomotive or power supply,

Your engine gets its power through the wheels. Make sure all of the locomotives' wheels are on the track by sliding it back and forth gently. Try moving the engine to a different part of the track to rule out a loose rail joint or electrical connection.

Start with the connection between the wires and the track, then the connections between the wires and the power supply . Make sure nothing is loose and the wires don't touch. Make sure the wires are connected to the terminals for the track and not accessories. Inspect the wires themselves to make sure they are not frayed or split. Check the electrical plug and socket, too. Is the outlet turned on?
If you're setting up for the first time, you can probably skip this step entirely. Dirty track and wheels usually result in rough stop-and-go running, not a complete loss in power. If you've had the trains put away for a long time, especially in a damp environment, you could have corrosion or dirt build-up heavy enough to prevent operation altogether.
If you do notice heavy dirt or corrosion, it can usually be removed with some special abrasive cleaning blocks and liquid cleaners
It's important to be sure that the power supply is working. The surest way is to use an ammeter to read the electric current. If you don't have an ammeter, a simple test tool can be made with a low voltage light bulb and two short pieces of wire.
If you don't detect any current at the supply outputs, disconnect the wires to the track and test again. If you get a light, then you probably have a short in the track or wires. If not, then the problem may be a faulty power supply.
If everything checked out at the power supply, retrace the wires to the track again and test here. The ammeter will work, or if you have a second locomotive or even a lighted passenger car or caboose, try putting it on the track.
If you are getting good results with this test, the problem is probably in the locomotive itself. If you are just starting out, your best option is to return the locomotive or find a local service location
If you have detected a short circuit in the track, check your wires again. A short circuit can occur any time one rail or wire touches the opposite rail or wire. If you have more than one set of power leads, make sure they aren't crossed. It is a good idea to color code your wires.
If you are using the 2-rail track, make sure you haven't created a short in a reversing loop or wye . Switches and crossings can also cause a short if the opposite rails touch without an insulated break


Don Derail Troubleshooting Model Train Problems

on Dec 14, 2017 | Toys


I would check for power at the motors when the foot pedal is pressed, if there is power there, then either your motors are bad or just disconnected

Electric Kid... | Answered on Dec 08, 2017

Not finding what you are looking for?
Electric Logo

326 questions posted

Ask a Question

Usually answered in minutes!

Top Electric Toys Experts

Lawrence Oravetz

Level 3 Expert

10543 Answers

Mike Stager
Mike Stager

Level 2 Expert

101 Answers

Brad Brown

Level 3 Expert

18108 Answers

Are you an Electric Toy Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...