Questions & Answers for: Kenwood 640 fine

Ad

Question about KDC-M7024 CD Player

1 Answer

TOC Error If i put an audio disc that i have recorded, or a disc with MP3 on into my player, all i get is TOC error. It works fine with original cd's. When this unit was new it worked fine, but this ...

Ad

Question about DDX-6019 Car DVD Player

1 Answer

Video output not working I have installed the Kenwood DDX-6019 Car DVD Player. video plays fine but the video output rca jack is not sending a signal to my headrest tv's. It's not the rca cord and the

Ad

Question about KDC-MP535U CD Player

2 Answers

Common blank screen.. but no ribbon cable Stereo works fine, all buttons work fine, and buttons light up. However, the LCD screen is now blank.. which would lead me to believe it would be the ribbon ...

Kenwood KAC-9152D I THINK IT SHORTED OUT BUT HOW CAN I FIX IT? i was installing my amp on my other car and it was working fine, but when i was tightening the power cable screw, my screw driver touched

Question about KAC-7201 Car Audio Amplifier

1 Answer

everything was workoing fine. then one day no everything was workoing fine. then one day no sound if power light is on and no sound check audio jacks on amp and to speakers

Question about KAC-9104D Car Audio Amplifier

1 Answer

what does the red light mean i have had mine amp for a year use to run fine but now the subs dont work has power tried amp on otherr subs works fine red light is protection. subs r bad, if it works on

Question about DVF-3080 DVD Player

1 Answer

I tried putting a new DVD into my player ( Kenwood DVF-3080) It's asking me for Parental Control Limit code. I've never set parental controls due to the fact that I have no children. Other DVD's play ...

kvt715 telling me i have a disconnected wire, unit been in for years playing fine ? unit has been in for years , now screen says disconnected wire? If you can, try checking your wire connections. 

my kenwood chef is not turning the mixing blades, although the motor is running fine. It's probably at least 35 years old! But has worked fine until now! Mixed my Christmas cake only 2 weeks ago! ...

fine, except the battery died when I left my truck in the garage for 3 days! I checked the power draw and it was drawing 640 mA when the car was off and the key was out. I reinstalled the factory unit

Not finding what you are looking for?

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio and Video Experts

xxxxxx xxx

Level 3 Expert

5013 Answers

Marvin
Marvin

Level 3 Expert

85161 Answers

Mike Duncan
Mike Duncan

Level 2 Expert

219 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...