Question about Razor MX500 Dirt Rocket

3 Answers

Razor MX500 not working...clueless Mom trying to help 10 yr old get his bike running. Throttle lights up, makes a single click when you turn it, but chain or rear wheel will not turn. I ordered and replaced the throttle and control module, didnt help. Please does anyone have any ideas...how do I tell if batteries are dead?

Posted by on

Ad

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Just tore down my boys mx550 and found the issue I washed it the night before. And it did it when we went to ride in the morning. My first thought was the throttle. It looked good. So i checked the brake sensor. Looked good on the handle bars. So i ran it back to the connection. And took it apart to find wet sand and decent amount of water. Blew it out and it fired up

Posted on Mar 24, 2019

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 225 Answers

Sounds like a battery fault to be honest, do the wheels run unrestricted (when no weight is on them)?
can you force turn the wheels making the motor turn? (this ensures the motor is NOT seized).

Lead Acid batteries are still really expensive, try Google for "lead battery revive"..... you'll need some pure Epsom Salt if you want to try and fix your old batteries.

another option is to ask an electronic savvy friend to get a load of old laptop batteries and make a custom battery pack, which might be cheaper... ensure they understand the importance of Lithium Battery charge & discharge safety though.

Posted on Nov 23, 2017

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

  • Expert
  • 156 Answers

Either the cheap lead acid batteries are near dead (mostly due to improper maintainance (lead batteries are way too much trouble and lithium should be considered!)
There could be a loose or corroded connection - check on all your wiring, especially the ones to the motor.
Also where it goes into the motor is fragile and people bump that area and it rips the wire, there is a steel spring that surroiunds the wire/s and this sometimes shorts out because of the damaged cause from laying the bike on it's side. check these wires over and tug on the connector wires to find the weak connection. Also verify that your charger turns red indicating it is charging when attempting to charge the bike, if it stays green chances are a dead battery or BMS controller inside battery (Lithium only!)\
Most repairs are very simple if you take the time to check out the connectors and wiring, especially if you use it in bad weather, things get corroded from being wet and power shorts out then corrodes the wires and connectors.
Good to insulate them for the rain etc...
Think Im on the right track here, and i have many ebike because people dont know how to fix simple issues with a tester.

Posted on Nov 23, 2017

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

jgwhomeequip
  • 1902 Answers

SOURCE: mx500 razor

Have you checked for a frozen bearing

Posted on Feb 07, 2009

  • 1 Answer

SOURCE: Early model Razor MX-500. Replaced motor, control

the back wheel won't move it try to move but it won't it's making a loud noise.every time you give it gas.what could that be...

Posted on Dec 26, 2009

woodchuck789
  • 4070 Answers

SOURCE: my razor mx500 is not

Look hard for loose wires. Start with the on off switch. Make sure all are plugged up. The fuse should be accessible without taking things apart. Water is a major enemy of the solid state box the wires go into before they go to the battery.

Posted on Aug 23, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

It will not run it just click


Most likely, the last 2 answers are correct. When you charge the battery, does the light on the charger stay red for several hours before turning green? Check the voltage of the 3 batteries after the charger light turns green. It should be 39-40 volts or so no load. Turn the throttle and see if the voltage drops when the relay clicks. You can connect the batteries directly to the motor and it should go full speed if they are good.

Mar 02, 2015 | Razor MX500 Dirt Rocket

1 Answer

The bike runs constant even when the throttle in not engaged, does the throttle need to be replaced?


The cable may need to be adjusted, or the carburetor needs to be adjusted.

Sep 16, 2014 | Razor MX500 Dirt Rocket

1 Answer

I Replaced the charger port on my Razor Mx500 Dirt Rocket and it ran fine and then just stop. The charger still indicates the batteries are charge but no power. Also I went to check the fuses and manu


Well if it's missing fuses obviously it won't run. When you turn it on does the green light on the throttle come on? if you have a voltmeter that would help. Are you sure the charger is good? if so you want to see 39 volts or so across all 3 batteries. Sometimes the switch contacts develop excessive resistance try shorting them with your screwdriver... if it runs you need a switch. can you hear the controller click when you turn the throttle?

May 21, 2014 | Razor MX500 Dirt Rocket

1 Answer

How can i test electrical compontents on the mx500 dirt bike? i bought it used. it will not run the lights on the the throttle light up that the battery is full but when i twist the throttle nothing...


If the lights on a the throttle are showing a full battery then try disconnecting the brake switches at the controller one at a time. If the bike works after disconnecting a brake switch then that switch is faulty and should be replaced.
There is some excellent information on trouble shooting and testing components here http://www.razorama.com/razor-installation-guides.html
also wiring diagrams here http://manuals.monsterscooterparts.com/recreational/Razor/Wiring/

Oct 07, 2013 | Razor MX500 Dirt Rocket

1 Answer

Batteries are charged and the bike doesnt work any ideas on what it might be and batteries are new


yes! if that's the case ,the motor is the culprit.there are 4 things that make our bike run..the a good charger, batteries, the throttle, and the motor. now that you singled out your battery and charger ,you have the throttle and your motor..1st check your throttle & make sure it stops @ a1/4 twist.check all connections, then do an extencive check of your motor for moisture or water/signs of it being wet/riding in the rain..which is a big No-No../no rain No snow, No drizzle,and no puddles clean or muddy..it is not a gas bike....remember!great tip!

Dec 20, 2012 | Razor MX500 Dirt Rocket

1 Answer

Why is my Razor motorcycle MX350 battery showing green but not charging


yes!your battery needs replacement.....throttle clicking after a full charge is a sign,...but that's after 2years or more,depending on how it's being used..your motor can go bad before then if you been riding in the rain--wet connectors in or out the motor can not get wet for any reason..a full dirt motor bike can not get full dirty with mud..mud catains water/water and electricity don't mix/////.motor/thottle/moisture.

Dec 17, 2012 | Razor MX500 Dirt Rocket

1 Answer

Our Razor MX500 won't run with out giving the motor a little help getting going. We took the motor off and hooked it to a battery charger and it works fine, you put it back on the bike and it won&


remember the motor transfer the power to the front..there no weight on the motor when you take it off..the motor can be going bad/a singnal! most people change the battery without checking the motor for wear..

Sep 14, 2012 | Razor MX500 Dirt Rocket

Not finding what you are looking for?
Razor MX500 Dirt Rocket Logo

Related Topics:

1,080 people viewed this question

Ask a Question

Usually answered in minutes!

Top Razor Cycling Experts

Lawrence Oravetz

Level 3 Expert

10543 Answers

Wayne Fraser

Level 2 Expert

83 Answers

ray gallant
ray gallant

Level 3 Expert

63053 Answers

Are you a Razor Cycling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...