Question about Kenwood KAC-9104D Car Audio Amplifier

1 Answer

What does the red light mean i have had mine amp for a year use to run fine but now the subs dont work has power tried amp on otherr subs works fine

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 9 Answers

Red light is protection. subs r bad, if it works on other speakers and not yours.

Posted on Oct 20, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Amp worked fine one day and the next day i get nothing. the red light on the side is on but i dont get any sound. i took the subs that were wired on that amp and wired them on the other punch 800 i have...


did you check all fuses on amp and coming from battery power wire? also check the ground and rca cables connecting to the unit and make sure the remote wire (small blue wire) didnt come lose thats usualy a sign for the red light

Mar 26, 2011 | Rockford Fosgate Punch 800a2 Car Audio...

2 Answers

2 12" subs + 600W amp. Turn on, goes boom once, then red light


Is your gain all the way up? If it done this before, sounds like your over working the amp. Make sure your subs ohm load is capable with the amp load to. If they are 1 ohm and your amp is only 2 ohm stable, it would beat for a lil bit then go into protection mode to. Check your wires too.

May 13, 2010 | Insignia 600W Bridgeable Amplifier with...

2 Answers

My subs don't bump to the beat, they just go THUMP THUMP THUMP...


It sounds like you need to ask for pro help mate, mybe the amp just needs setting properly, Is the amp on bypass for bass, or does the amp run the complete system

Jun 13, 2009 | Cadence TXA 750D High Power Mono Amplifier...

2 Answers

LED Light is on, but no sound from sub at all.. Have double backed on all wires but still nothing! HELP!!


if you change amps and it goes on protection the speakers are blown causing the amp to protect try changing speakers

Mar 24, 2008 | Car Audio & Video

2 Answers

Amplifier problems!!!


it sounds like your running your ohms to low, check to see what the amp can power and then read up online about ohms and your subs and how they should be wired

Oct 12, 2007 | Car Audio & Video

8 Answers

SUBWOOFER NOT WORKING?


if you have real old wires from the amp to the sub try getting new wires on it. check the little wires that go to the cone itself on the sub. sometimes they can manage to get pulled out of their terminals and make sure that thier touching the terminals on the correct spot

Sep 29, 2006 | JBL GT150 Car Subwoofer

Not finding what you are looking for?
Kenwood KAC-9104D Car Audio Amplifier Logo

385 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5013 Answers

Marvin
Marvin

Level 3 Expert

85178 Answers

Mike Duncan
Mike Duncan

Level 2 Expert

219 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...