Question about Power Acoustik BAMF5500/1D Car Amp

Open Question

Water was spilt in 5500 watts bamf series amp-Power Acoustik

Water was spilt in Power Acoustik 5500 watts bamf series digital class D amp. Protection light came on, shut down immediately. I dried amp out and tried to hook back up, however protection light is still flashing, power light is solid. Is there a reset button? or something else i can try Any help would be lovely, thanks!

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: protection light on

i had one of these amps, if you don't have a good ground, the protection light will come on.

Posted on May 16, 2007

Ad
rteemon
  • 578 Answers

SOURCE: i have a 3000 watt power acoustik amp with 6 gauge

one think the picture of that amp and the amount of wattage i recommend you change the wire to 4-guage and check the rca,and spk wiring

Posted on Jun 26, 2009

  • 19 Answers

SOURCE: I have a power acoustik bamf 1600/4. not working 5 hours later

use a multimeter to see if the amp has good power wire and remote turn on voltage. then check the ground and make sure its a good strong ground. check the sub to make sure its not bad. make sure it reads whatever ohm its supposed to. anything less than 4 ohms will clip the amp if bridged. if alll that is good then the only thing left is the amp. it sounds like the power supply is bad but check everything else just to make sure. good luck.

Posted on Dec 30, 2009

Professor_V
  • 92 Answers

SOURCE: I have a power acoustik A3000DB 3000W Mono Class D Series Amplier

I HAVE TWO OF THESE AMPLIFIERS MYSELF. IT IS NO DOUBT AN INTERNAL PROBLEM BECAUSE THROUGH THE PROCESS OF ELIMINATION, YOU HAVE DONE ALL THAT YOU CAN DO AND IT POINTS TO THE AMPLIFIER ITSELF. AS FOR THE CAUSE FOR ITS FAILURE, THERE ARE MANY, BUT IT IS MORE THAN LIKELY IN THE INPUT CIRCUITS AS FAULTS IN THE POWER SUPPLY OR OUTPUT SECTION WOULD MORE THAN LIKELY SHOW UP TRIPPING THE PROTECTION CIRCUITRY. IT WILL SIMPLY HAVE TO BE SERVICED. I AM LISTED IN THE REPAIR DIRECTORY OF THIS SITE UNDER THE ZIP-CODE 70360. LET ME KNOW IF YOU NEED FURTHER ASSISTANCE...V

Posted on Jan 06, 2010

  • 41 Answers

SOURCE: Protection light keeps flashing on and off

try hooking up only the power ground and remote see what happens if protection light is on then u have a problem with amp if it goes off then hook up rca if still off then hook up speaker wire if it turns on then u have a prob with speakers

Posted on Feb 03, 2010

Testimonial: "Thanks, it's the speakers the amp is to powerful for the rated subs."

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a bamf 5500 series and the amp is on and working but when i turn up the volume the amp will go into protect mode and stay there untill i turn the volume back down then the amp comes out of protect...


you probably have a blown sub(s) that short out when the volume is turned up. it would be a good idea to find out which one(s) is bad and replace it. sooner or later it may make the amp go bad if not replaced or removed.

Jan 06, 2011 | Power Acoustik BAMF5500/1D Car Amp

1 Answer

I have a power acoustik bamf 2000 class d amp and i think when i had it unhooked the positive and negative speaker wires might of touched for a few minutes and now the amp comes on no protection light just...


internal components are very sensitive to things like that. sounds like you shorted out some of the fets internaly .. i recomend a complete diagnostic and proceed to repairs.

May 06, 2010 | Power Acoustik SL2-2000 Car Audio...

1 Answer

I have a power acoustik bamf 1600/4. not working 5 hours later


use a multimeter to see if the amp has good power wire and remote turn on voltage. then check the ground and make sure its a good strong ground. check the sub to make sure its not bad. make sure it reads whatever ohm its supposed to. anything less than 4 ohms will clip the amp if bridged. if alll that is good then the only thing left is the amp. it sounds like the power supply is bad but check everything else just to make sure. good luck.

Dec 29, 2009 | Power Acoustik BAMF1600/4 Car Amp

1 Answer

Power acoustik gothic OV2 800 manual


Could not get a manual for you but did get the follwing specs. Hope they help.

Power Acoustik Ov2-800 2-Channel Class A/B Gothic Series Amplifier (800-Watt)
POWER ACOUSTIK OV2-800 2-CHANNEL CLASS A/B GOTHIC SERIES AMPLIFIER

800-WATT 2-CHANNEL
4 ohm RMS: 150W X 2
2 ohm RMS: 180W X 2
Bridged mode MONO RMS: 360W
BRIDGED MAX: 800W
FULL MOSFET POWER SUPPLY
PWM CIRCUITRY
FULL SELECTABLE CROSSOVER
3-WAY PROTECTION CIRCUIT
TRI-MODE CAPABLE
VARIABLE LOW PASS 40 HZ - 120 HZ
VARIABLE HIGH PASS 150 HZ - 1.5 KHZ
VARIABLE 18 DB BASS BOOST @ 40 HZ
FREQ RESP: 10 HZ TO 30 KHZ
S/N RATIO: 98 DB
THD: 0.02%
2 ohm STABLE STEREO
SYSTEM DISTRESS INDICATOR
HIGH/LOW LEVEL INPUTS WITH FLOATING GROUND
4-GAUGE POWER/GROUND CONNECTION
PLATINUM RCA CONNECTORS
LINE OUTPUT WITH FLOATING GROUND

BLUE LED
CHROME TOP PLATE PANEL 2-CHANNEL CLASS A/B GOTHIC SERIES AMPLIFIER (800-WATT)

Aug 18, 2009 | Power Acoustik GOTHIC OV2-800 Car Audio...

3 Answers

When I bridge the BAMF 2200/2 Power Acoustik amp it cuts off


Hello munchisfun,

I'd suspect that the amp is operating into too low of an impedance and going into protection.

The 2200/2 is not rated to drive a 2ohm load when bridged (most 2-channel amps aren't) and when you connect 2 4ohm subs in parallel, the load is 2ohms. I'd run one sub from each channel.

Hope this helps.

Jul 26, 2009 | Power Acoustik BAMF2200/2 Car Amp

1 Answer

Amp and subwoofer problem


try using an ipod or mp3 and hook it up directly to the amp input section-if its lit up and you get sound then youre not getting signal from your deck and youll have to track that problem down at the deck-if you still dont get any sound by connecting directly into the amp inputs then you may want to check all amp settings and be sure that your set up right and if it has external fuses make sure that they are all good and if it still wont give you any sound than take it in and get it checked out-hopefully its just not getting any signal cuz if its the amp then sorry to hear it-but good luck

May 21, 2009 | Power Acoustik BAMF2000/1D Car Amp

Not finding what you are looking for?
Power Acoustik BAMF5500/1D Car Amp Logo

Related Topics:

140 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Dalynn Turner

Level 2 Expert

346 Answers

Marvin
Marvin

Level 3 Expert

84540 Answers

The Knight
The Knight

Level 3 Expert

76036 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...