Question about Lexicon Omega Pro Studio External Sound System

Open Question

Lexion sound problem

Hey,i just bought a lexicon. I did everything it says in the manual, but when i plug in my headphones in the omega, all i hear is a very low signal, at a very low bitrate, almost like white noise. You can distinguish a beat but not individual instruments.

Everything is as it should be in my computer audio settings. Nothing is mute. And i have left my computer's sound card as default peripheral (like it says in the manual) In Reason i have then chosen Asio something, (wich corresponds to my lexicon) but all i hear is a low bitrate crappy sound.

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hello i opened my lexicon omega and the cd wont download, i have tried a number of things but it keeps coming up with stienberg softwear, i have registered but the lexicon omega will still not load onto...


The software is by Stienberg and is called "Cubase" that is delivered with the Lexicon. The Omega doesn't really have any software to speak of except for the drivers. Browse the software disk looking for the section containing the drivers. When you install it, it will create a Lexicon folder with the root of your C drive and in it will be an Omega folder. In that is a driver folder and a folder of help files. In the Driver folder folder you will find the installer file "Omega Setup". Launch that program to install the drivers. Please note I have one of these and it can be frustrating to get things working. Make sure in the PC in the control panel "sounds and devices" that under the tabs that the Omega is the device to send and receive and for voice. Once you have done the install, the Omega should be in the list of available devices to select as default.

Apr 16, 2011 | Lexicon Omega Desktop Recording Studio

1 Answer

I have a lexicon omaga drive but when i hook it up its like i need a 64 bit driver


Don't know what OS you're running. Omega has published drivers for Vista and 7 64-bit versions. They say they don't support XP 64, but when I hooked my unit up to my computer and the hardware install wizard came up the OS found and installed Microsoft published general USB audio device drivers for all inputs, midi, and mac USB channels of the Omega, and automatically set it as my default device. I hooked headphones into the Omega unit and could hear system sounds. So far so good. Went to My Music and fired up an audio file. Windows Media Player started up and the song started playing but I couldn't hear anything. Opened the same file with Audacity, could see the VU meters bouncing, but still no sound in my headphones. Went in to the preferences of Audacity, and manually set the speaker default to the Omega mac USB device. Hit play again and voila! I had sound. Closed the file, started WMP manually, went in to options, and again set the speaker default to Omega mac USB. Opened the same audio file and this time it played just fine. The driver files Windows used for my card were
C:\\WINDOWS\SysWOW64\ksproxy.ax, C:\\WINDOWS\System32\drivers\ks.sys, C:\\WINDOWS\System32\drivers\ksthunk.sys,
C:\\WINDOWS\System32\drivers\portcls.sys,
C:\\WINDOWS\System32\drivers\stream.sys,
C:\\WINDOWS\System32\drivers\USBAUDIO.sys,
C:\\WINDOWS\System32\ksproxy.ax,
C:\\WINDOWS\System32\ksuser.dll,
C:\\WINDOWS\System32\wdmaud.drv,
all version 5.2.3790.1830
Hope this helps everybody else with this problem.

May 21, 2010 | Lexicon Omega Pro Studio External Sound...

1 Answer

How I can to installer a sofwer compatible to windows vista? for lexicon omega studio


at first resistering your product. then you download your vista driver on lexicon website; thanks

Apr 09, 2010 | Lexicon Omega Desktop Recording Studio...

1 Answer

Omega Studio won't record to computer


The omega is like an external sound card. It has to be connected via your computer with a device driver,the software that came with the lexicon. Then you record on a software program such as Cubase.
Go to the guitar center for more help or go to google .com and type in lexicon omega. Lots of sights to look for answers or better yet go to lexicon omega's home site.

Feb 28, 2009 | Lexicon Omega Desktop Computer Recording...

2 Answers

Lexicon Omega will not play any sound on Windows XP


one of several install steps (the steps seem to vary depending on which manual you can find) mention checking your sound device setup in control panel. ON one machine I installed the sound devices were not affeted. On a 2nd PC they were changed from drivers installed with PC to the Lambda driver

Win XP settings->control panel->Sounds and Audio Devices then select Audio tab. Make sure the three areas are set up to use your PC's default drivers and not lambda's.

You may need to verify this again when reconnecting the Lambda USB cable. Sort of new but ran into this "issue" as well.

Found info in Lambda Studio Software Installation Guide I downloaded, step B following driver install.

Nov 21, 2008 | Lexicon Lambda Usb Desktop Recording...

1 Answer

Lexicon omega driver


Yes having the same problem with new driver that Lexicon put on their site 2.5 driver has screwed up everything and the soundcard is nolonger working because of this new driver even their website is down very poor avoid Lexicon Omega

Aug 09, 2008 | Lexicon Omega Pro Studio External Sound...

6 Answers

Device is unrecognised always day per day


I've been struggling with this issue for about a week. My unit was locking up increasingly more often.

Two things I've noticed about my Lexicon interface:

1. Seems to be excessively hot.

2. The unit is not vented.

Yesterday, after reading a comment about the solder possibly being the problem, losing conductivity as the units warms up. I decided to run my Lexicon with the plastic case removed.

Since removing the the case, i have only had one instance where the sound stopped working, which i believe was a problem with Cubase in that instance.

I'm not sure if removing the case to keep the unit cooler is the solution. I may have improved a connection somewhere in the process of opening up the unit.

I can say that I went from getting a "new hardware found" message every two minutes to having virtually no problems since removing the case.

My next step will be to drill about 50 holes in the case to vent it before attempting to use the case again.

Best of luck to ya!!!

Nov 06, 2007 | Lexicon Omega Pro Studio External Sound...

1 Answer

Won't play through Computer Speakers


Hi, go to start, control panel, Sounds and audio devices. You will need to set the audio system up here. Select the connection you have to the system, that should cure your problem. Regards mistyman

Sep 04, 2007 | Lexicon Omega Pro Studio External Sound...

1 Answer

Installing omega lexicon desktop recording studio


Yes it's extremly tempramental, just keep repeating the proces it' will work eventually!

Feb 17, 2007 | Lexicon Omega Desktop Computer Recording...

Not finding what you are looking for?
Lexicon Omega Pro Studio External Sound System Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lexicon Computers & Internet Experts

Tony Raia

Level 2 Expert

254 Answers

Alun Cox

Level 3 Expert

2679 Answers

Thomas F. Schneider

Level 3 Expert

2715 Answers

Are you a Lexicon Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...