Question about Power Acoustik LT-980/2 Car Audio Amplifier

1 Answer

I have a rockfored fozgate 400w amp it was

I have a rockfored fozgate 400w amp it was working fine for a while then, for no apparent reason 1 channel went out. how can i fix the channel?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 269 Answers

Look for popped Capacitors. These are the tiny cans that are on the circuit board. They usually buldge out on the top and leak white paste.
Good luck and i hope this helps.

Posted on Jan 28, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a audiobahn aw1251t 12 inch sub and punch 1000-1db amp how would i wire it up


as your sub is only rated to 400w rms simply connect the sub to either a or b channel outputs you may wish to use an rca splitter before the amp to feed both left and right audio channels into a single channel on the amp. WARNING connecting both channels on the amp to the sub will overload the sub and possibly blow it up so i highly recommend not doing so.

Mar 17, 2017 | AudioBahn Car Audio & Video

1 Answer

Having problems with my highs amp


Use shielded cables.
BTW, how did you check the cables to determine that they are okay?

Nov 27, 2013 | Boss BV7334 3.2-Inch DVD/MP3 Receiver with...

1 Answer

I have a 400w rms @ 4ohm sub. What amp do i need? If i want to connect it via 2 channel, bridgeable amp, what wattage does each channel need to be? Do i need a second amp for 2 6x9s?


almost any amplifier amp would push a 400 watt sub. try to stick with a name brand, and steer away from no name brands like boss, jensen, etc.you will only need a 2 channel amp to run your sub.you will need a second amp to run your 6x9'sor you could get a 5 channel amp, and run all your speakers, and the 5th channel for your sub

Oct 25, 2012 | Car Audio & Video

1 Answer

How do i get the most watts possible from this amp, with out overheating the amp.


you can run your amp at 1 ohm you would need to to have the right ohm subwoofer wired in parralle to get 1 ohm at amp ...... the put a 12 volt fan in the area to keep the amp cool so it doesnt over heat if you plane to
Audiobahn A2X400HQ 2 Ch Amp
1600w x 1 @ 1ohm - 800w x 1 @ 2ohm
600w x 2 @ 1ohm - 400w x 2 @ 2ohm
2-Channel High Current Amplifier -- Ideal for use with all Audiobahn Rack Mount Products


http://www.tintingbyfredjohnson.com

Dec 27, 2010 | AudioBahn A2X400HQ Car Audio Amplifier

1 Answer

I have a four channel rockfor fosgate amp and I need to know hows the best way to connect Infinity Reference 1252w Car Subwoofers


Rockford fosgate usually work best with 2 ohm speakers. Depending on the resistance of your speakers, will then give you best connection. Check the resistance for the subwoofers. If the subwoofers are two ohm then connect them directly right and left. But if they are 4 ohm connect them parrallel (positive to postive, negative to negative and bridge the amp.) Good Luck, please rate.

May 26, 2010 | Infinity Reference 1252W Subwoofer - 12"...

1 Answer

6 mnths old Alto L8 Mixing desk developed hiss on channel 1 only.


The slider or the amps for channel 1 may have a problem.

Sliders do wear out.

Try shorting channel 1 input and see if that affects the noise. A hissing noise is probably a bad preamp chip. That is shop work at a repair facility.

Aug 16, 2009 | Music

1 Answer

Sony amp model 1652z


1000W max power
<b>
165W x 2, 20Hz - 20kHz, @ 0.04% THD + N, at 4 Ohms
200W x 2, 20 - 20kHz, @ 0.15% THD + N, at 2 Ohms
400W x 1, 20Hz - 20kHz, @ 0.1% THD + N, at 4 Ohms
</b>
OTL (Output Transformerless) circuit
Pulse power supply
Line & High Level Inputs
.3-6V Level Adjustment Control (RCA Pin Jacks) 1.2-12V (High Level Input)
80 Hz, -18dB/octave Low Pass Filter Switch

Jan 15, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Samson Servo 170 Amplifier


check see if youy have some coving the vent or the speak connect right

Dec 05, 2007 | Samson Servo 170 Amplifier

1 Answer

Power & protect


my amp says Lo on the digital circle on top of the amp i have a mtx 9500 bridged to the amp and it cuts out at high volumes and suddenly please help



Dec 21, 2006 | AudioBahn A8000V 400W x 1 Car Amplifier...

Not finding what you are looking for?
Power Acoustik LT-980/2 Car Audio Amplifier Logo

Related Topics:

47 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Dalynn Turner

Level 2 Expert

346 Answers

Marvin
Marvin

Level 3 Expert

84625 Answers

The Knight
The Knight

Level 3 Expert

76046 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...