My Scenario:
OS: MS Windows XP SP3 [Version 5.1.2600]
Printer: HP LaserJet 3390 (AiO) (Firmware datecode: 20070331)
Printer Connection: Connected via Ethernet with a static IP address
HP Driver Version: v4.0 (hp_LJ3050-3052-3055-3390-3392_Full_Solution_AMWE.exe)
Ran into same error that everyone else is experiencing. (see below)
Now Launching=X:\hpzmsi01.exe -m dot4msi -l XXX -f X:\DIVins??.DAT
Error
message received: The installer has encountered an unexpected error
installing this package. This may indicate a problem with this package.
The error code is 2753.
X:\HPZBDI32.msi failed with return code 1603
MSIInstall() failed with 1603
Exit code=1603
After
debugging HP's installation scripts for 2 days, here is the cause &
solution I identified to this specific install error. Once I got passed
this error, everything installed without error and all functionality
was working properly (including scanning!).
BACKGROUND:
Microsoft
Installer (MSI) error 1603 is simply a generic "A fatal error occurred
during installation" -- see
http://msdn.microsoft.com/en-us/library/aa368542(VS.85).aspx. This is
basically MSI telling you that something very bad has happened during
the installation. In order to get more details, you can turn on MSI
debug logging by following this MS Knowledge Base article
(http://support.microsoft.com/kb/223300).
The MSI error code
2753 is the code for "The File '<file name>' is not marked for
installation.". This error can be triggered by many scenarios, but
usually, it has to do with the actual installation script not properly
checking for the existence/non-existence of an installation file and
then not marking it for either installation/removal. I know this sounds
confusing, and it is. If your curious about all the possible causes,
just Google for "msi 2753 not marked for installation" and you'll see
lots of results which you can peruse for your own enjoyment.
In order to identify what was causing these 2 errors, I enabled debugging for MSI via the aforementioned MS KB article
CAUSE:
Certain
HP services (and associated DLL files) were somehow
partially/improperly installed. (Possibly, from a previous failed
install?)
The Windows services (files) were:
Pml Driver HPZ12 (C:\Windows\System32\HPZipm12.dll)
Net Driver HPZ12 (C:\Windows\System32\HPZinw12.dll)
The
existence of these 2 files in the System32 directory was causing this
error in my situation. Somehow, the installation script was not
identifying that these files were already installed (or improperly
installed) and failing to properly set them to be installed again.
SOLUTION:
Steps:
1) Check to make sure that the 2 Windows services above are not running (or not installed).
2) Rename/delete the 2 associated service DLL files (this will only be possible once the services are stopped)
3) Run the installation again.
If all goes well, the install should now run without any issues.
Hope
this helps since many people (including myself) have spent a lot of
time (and HP Support chats) trying to find a workaround for this issue.
If you find this solution helped you out, please feel free to make a small
donation to my PayPal ;)
Headstrong: This is a brand new printer, not an older one. HP's drivers for newer printers are typically bundled together. In this case, I am positive I have the right drivers as I am installing from the cd as well as from a downloaded driver package which I know to be correct.
xMadx: I have administrator access.
Hewlett packard and Microsoft have really cocked up on this one they should gibve us all our money back
I have a C3180 HP printer. When I run up the HP Solution Centre, I get the massage that "Scan.MSI" not available the get alot of nuisan be for getting to scan further.
I try to uninsatall all HP drivers and re-intall them again bu still not work. What should I do to resolve it?
I am having the same problem. HP Photosmart C7280. Fatal Error 1310 Config.Msi/xxxxxx.rbf then after working with Hp support i have MSL.AiOscan error. Running Vista Enterprise 32 on a Dell D830. Have downloaded latest drivers from HP web site. Can't install drivers fatal error every time; 6 times.
I have the same problem. I am installing hp laserjet network printer 3390 and everytime it crashes before and gives error msi/exe file. Kindly assist.
[email protected]
el escaner dela impresora no trabaja me pide el archivo scan.msi
es una impresora hp 1410
cuando quiero escanear un documento primero se empieza a instalar automaticamente y luego me pide el archivo antes mensionado y no termina la instalacion
la impresora imprime normal
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