Question about MTX Car Audio & Video

1 Answer

What are the red lights on my mtx tna251 amplifier

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 146 Answers

THE GREEN LIGHT SHOULD SHOW WHEN AMP IS POWER UP AN RED WHEN IN PROTECTION MODE

Posted on Sep 12, 2019

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: What is the HLI port

What is the HLI port on the MTX tna251 amplifier?

Posted on Feb 22, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mtx tna251 amp has bass remote that has a light glowing but turn knob up and down and no difference like simply not working no difference in bass? Posible causes,


It is actually in the controller, if you turn the remote all the way down and press on the controller until the bass goes off, you will be able to turn the bass up and down with the remote, mine worked but stopped after a month, I tried adjusting the amp but then I noticed that if I wiggled the knob on the remote that it would work, I mashed mine until it worked again and velcroed it to my console sonibcan get it on and off easily.

Mar 03, 2015 | MTX Car Audio & Video

1 Answer

I bought a mtx terminator amp model no TNA251 600 watt and two subs installed. It works good for few days but now its not cranking up proper bass and sound. It always has three solid red lights everytime....


does it do this all the time when you turn it on? any sound at all?
provide more information, but my guess its that the amp is blown. replace it or sell it for parts.

Nov 11, 2013 | Car Audio & Video

2 Answers

MTX tna251


I have the same sub combo. The problem is the amp is underpowered for the 2 MTX 12s, get a bigger amp and you should be fine.

Nov 13, 2011 | MTX Car Audio & Video

1 Answer

What is the HLI port on the MTX tna251 amplifier?


What is the HLI port on the MTX tna251 amplifier?

Jul 15, 2011 | Car Audio & Video

1 Answer

Mtx terminator 250 stop workind and red light is on


check the ground make sure its not loose from the frame of your car thats why the red light comes on.

Jun 03, 2010 | MTX Terminator TN400/4 Car Audio Amplifier

1 Answer

Sub not working and red light on amp stays on?


the amp is under to much pressure get a bigger 1

Nov 18, 2009 | MTX Thunder 421D Car Audio Amplifier

1 Answer

Everything works fine but my amp light is red.


if its not coming on it usually means you have a bad ground if it works for a little while then does it then its over heating and you will need to get a fan

May 01, 2009 | MTX Terminator TN400/4 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

33 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

93 Answers

Mike Duncan
Mike Duncan

Level 2 Expert

219 Answers

Philip Armitage

Level 3 Expert

437 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...