Question about Jamo Audio Players & Recorders

Open Question

Hi,I have a jamo s210 subwoofer,it's got current,light on but no sound.what may the cause? input all connected well

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
sanjin
  • 56 Answers

SOURCE: I have no amp for jamo 1060 sub

Dual Voice-Coil
The unique Dual Voice-Coil design allows both left and right channel sound from just one speaker. Simply hook up both the left and the right channels to the special terminals on the speaker. Hook up one channel only, if the speaker is to be used in a conventional stereo set-up.
I found this on jamo site hope that will help you

Posted on Mar 18, 2008

Ad
  • 19 Answers

SOURCE: sound faliure

If the subwoofer has its own power cord seperate from the rest of the audio system, the internal amplifier could be fried or u have a loose connection inside the box

Posted on Apr 03, 2009

  • 263 Answers

SOURCE: How to connect to an subwoofer

You need a subwoofer cable then you attatch the cable from the back of the amp into the sub and power on the subwoofer and amp and hey presto your away.

Posted on Aug 04, 2009

  • 118 Answers

SOURCE: cannot get jamo 250 subwoofer to work via marantz

hdmi has digital audio in it. no need for optical from same device.
check menu settings in receiver to activate sub, set crossover point and levels

Posted on Nov 04, 2009

dunnbiker
  • 8546 Answers

SOURCE: My subwoofer is connected correctly (test mode it

What's the make and model of the subwoofer? It sounds like it's a passive (unpowered) speaker.

http://www.retrevo.com/support/Denon-AVR-589-Receivers-manual/id/23110dj893/t/2/

See page 9

I seriously doubt your test mode worked fine on the subwoofer level adjustmnent.

Get a powered (active) sub.

Posted on Jan 18, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do you connect a Jamo sub250 to a Onkyo tx-sr343 av receiver


You simply connect a RCA type line cable from the subs line input to the dedicated socket on the back of the Onkyo.
When you run speaker set up it will set the subwoofer up.

Jul 11, 2016 | Jamo "SUB250 250 Series Subwoofer, Single"

2 Answers

The fuse of Jamo Sub-200 gets blown off. is there anyone who might know the reason. thanks


try replace the blown fuse with ampere and check the sound if still ok.
some fuse got blown if the load current exceed. maybe high volume can cause the high current.
other cause by short circuit coming from the amplifier.

Aug 26, 2011 | Jamo SUB 200 Subwoofer

1 Answer

I have jamo sub200. I connect to pioneer vsx-rs320k audo video receiver. when I turn the volume of subwoofer to a higher value with the receiver, the bass sound becomes distorted and not satifieng to...


hi,
Do one thing set the control behind the sub. set the level and cutoff control at it half position. Set phase control at "0" position. Then test the sound. if you ate using tower speaker as front speaker then you have to set the position of phase control 180 ,
ok

Apr 11, 2011 | Jamo SUB 200 Subwoofer

1 Answer

Please help! Jamo SUB 300 subwoofer still blows (0.8A) fuses after replacing a faulty thermistor, despite a high ohms reading directly across AC mains terminals on the board. What is causing the fuse to...


hi,
i have a jamo 250 sub.the blue light is working.when i connect the jack to the left line IN according to the manual it makes a sound as well.but seems not working.is it related to the fuse????i know the fuse box.but i dont know how to remove the fuse to check.pls help me out.my receiver is onkyo tx-sr 608

thank you

ron

Jan 08, 2011 | Jamo SUB300BA SUB 300 Powered Subwoofer...

1 Answer

Sound faliure


If the subwoofer has its own power cord seperate from the rest of the audio system, the internal amplifier could be fried or u have a loose connection inside the box

Mar 29, 2009 | Jamo SUB300BA SUB 300 Powered Subwoofer...

2 Answers

JAMO SUB 650


hi

since it is a powered speaker, probably it just needs a sound signal which you can get from the headphone socket. please double check with someone else.

May 26, 2008 | Jamo D 4SUB Subwoofer

2 Answers

I have no amp for jamo 1060 sub


Dual Voice-Coil
The unique Dual Voice-Coil design allows both left and right channel sound from just one speaker. Simply hook up both the left and the right channels to the special terminals on the speaker. Hook up one channel only, if the speaker is to be used in a conventional stereo set-up.
I found this on jamo site hope that will help you

Mar 15, 2008 | Jamo 1060 SW Speaker

1 Answer

Jamo 250


hi, there must be this LINE IN socket (ur so called Hole), then on the onkyo, there must be this sub-line out socket, plug one end of the RC socket to the sub out of onkyo , and other to the line in of the sub, its all to do wirth its appropriate inputs and outputs,let me know

Jan 11, 2008 | Jamo D 4SUB Subwoofer

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

47 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jamo Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5683 Answers

rjivaro

Level 2 Expert

158 Answers

Robert Rankin

Level 2 Expert

357 Answers

Are you a Jamo Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...