Question about Pool & Spa

1 Answer

Garden leisure spa

My garden leisure spa stopped heating completely...we changed the heating element and it worked fine for a few days, now it is not heating again...maintains a low heat

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

Check to make sure you are getting 220 to it if not the check breacker

Posted on Nov 09, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What size Electrical breaker do I need for a 525L Garden Leisure Spa?


check inside power box cover for voltage requirements

Dec 20, 2017 | Leisure Pool & Spa

1 Answer

Leisure Bay -My spa will not heat - no FLC/FLO code/Voltage is correct/4KW Dry Element Heater test 15.9 Ohm across leads and OL on each to housing


It appears per your test that the heater May not be the problem as it shows that it may be good.

Your error message is a Flow condition / Restriction

Try cleaning the filter

Nov 09, 2014 | Pool & Spa

2 Answers

My Therapure four person inflatable suddenly stopped working. electrician says outlet and breaker are fine. I can get the plug to blink red but then it throws my breaker. no luck with 1 800 #


It is more than likely your heating element. Not sure what style they use but if you send me a pic of your equipment, spa pack w/ the cover removed, I can walk you thru how to test it.

If you have a good grasp of electricity, find the heating element and with the power off remove the leads. Try to plug it back in, reset the gfci, and give it a minute. If it doens't trip and everything runs fine replace the heating element. With most spa packs it is possible to replace only the element, some like watkins you have to replace the whole heater. If the spa still trips with the heater disconnected start unplugging your equipment starting with the ozone, then blower, then pumps, one at a time until your braker stays on.

Oct 18, 2013 | Therapure Four Person Inflatable Round Hot...

1 Answer

Leisure Bay spa will not heat past 86 degrees. Element and sensors are new. Spa has excellent flow and correct voltage at terminals.


if the spa does not heat up to 104 degrees then the temp sensor is what you are going to need.
Are there error codes showing on the screen of the topside?
You will need to know the model number of the control box or the model number of the heater tube in order to get the proper sensor.


Rod
US Parts Center
888-521-6183

Feb 09, 2013 | Pool & Spa

1 Answer

Replaced heater failed within 2 months


If your filter is plugged causes the heater to work harder(overheat). Rus

Mar 17, 2010 | Heating & Cooling

Not finding what you are looking for?
Pool & Spa Logo

Related Topics:

258 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1389 Answers

Bill Jordan

Level 2 Expert

373 Answers

David Spradling
David Spradling

Level 3 Expert

10033 Answers

Are you a Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...