Question about Yamaha 12V Air Pump

2 Answers

Have 1997 yamaha gp1200...starts and idles fine...runs fine for first five minutes then just loses power or shuts off. Wait a couple minutes...starts back up runs great then loses power to idle or shuts off. Checked fuel lines, fuel filter, vent hoses, carbs clean, oil lines zip tied tight, compression good, checked kill switch, disconnected thermoswitch and ran....still does it. Someone mentioned rectifier/regulator and cdi? Any help appreciated!

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 216 Answers

Check the converter on the exhaust they do plug up if on too long

Posted on Jun 21, 2017

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Yamaha Master
  • 53,745 Answers

Indicates that a component in the ignition circuit is overheating internally and failing
could be a coil or cdi unit or any sensors if fitted

Posted on Jun 21, 2017

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

finish line
  • 207 Answers

SOURCE: Ran my Yamaha GP 1200R Out of Gas

you cant clean the carbs out once u take the diaphrams out u just need to replace them get three carb kits from riva yamaha and put kits in them and ill bet you $20 it will run

Posted on Jul 08, 2009

finish line
  • 207 Answers

SOURCE: I have a 2002 Yamaha FX140 Waverunner.Fuel problem or electronic?

you have fouled spark plugs change them all fixed all the newq yamaha sare doing it it is the in thing to do

Posted on Jul 08, 2009

  • 1 Answer

SOURCE: 1994 Yamaha Waverunner 3 will idle but wont take throttle

Switch to reserve tanke to check to see if there is a clog at the fuel pickup in the tank.
My friend had the same issue with his waverunner 3.

Posted on Aug 31, 2009

heimlich
  • 1978 Answers

SOURCE: 1998 yamaha waverunner xl760;just purchased it

Take the carburetors apart and clean them. There is probably water caused white corrosion in the fuel needle assemblies. Once the needles are cleaned the fuel should pump and flow through the carburetors again.

Posted on Sep 27, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2010 Ford F150 would suddenly loose power and only idle. Pull over shut off sit a couple minutes crank and run fine for a while then do same thing again. Wrench would show up on instrument panel


Sounds like the catalytic converter or muffler maybe getting plugged up and the computer is putting the truck in limp home mode. Did you put a scanner on the truck. You might try to remove the 02 sensor ahead of the cat and see if it runs a little better it will not be perfect but should stay running if so do an exhaust check. When the cat or muffler gets plugged it puts back pressure on the engine and won't allow the fuel to be pulled into the engine properly.

May 19, 2017 | Ford Cars & Trucks

1 Answer

I have a 1997 SAAB 2.0 Turbo and it has started to run rough after it warms up and when driving it loses power and runs very rough until power taken off. Any ideas?


suspect low fuel pressure to the injectors
run the fault codes to determine where the fault may be before you spend money

Oct 09, 2015 | 1997 Saab 900

1 Answer

1997 yamaha mountain max 700 runs but then boggs then runs normal again


will most likely be the Carburettor is dirty. WHAT CAN YOU DO for this; In the market there to spray purified karmpylater.
DEDUCTIONS after the air filter, the engine ignited and psekazeis the contents of the spray inside the karmpylater while playing with the throttle

Nov 27, 2013 | Motorcycles

1 Answer

It will run good for a while on hot heat and then shuts off for abut 5 mins but it doent shut off on cold cyc


why does my roper electric dryer shut off after five or ten minutes of running fine. then wait five or ten minutes, restart and it runs fine for another five or ten minutes, and so on....

Dec 29, 2012 | Roper REX4634KQ Electric Dryer

1 Answer

High idle 1997 gp1200


obviously your fuelling isn't set up correctly

Jul 13, 2012 | Yamaha 98 Gp 1200 Air Box Intake Mount...

1 Answer

Car runs for about five minutes then shuts off


1999
mit eclipse runs for five ten min then shuts off i have to wait a while befour starts back up why?

Apr 13, 2010 | 1997 Mitsubishi Eclipse

1 Answer

Truck idles fine but has no power


Does the exhaust sound muffled? Could be a bad catalytic converter.

Mar 05, 2009 | 1999 GMC Sierra

Not finding what you are looking for?
Yamaha 12V Air Pump Logo

Related Topics:

1,904 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Water Sport Experts

boomanfoo

Level 1 Expert

23 Answers

Craig Butler
Craig Butler

Level 3 Expert

1730 Answers

Marvin
Marvin

Level 3 Expert

84625 Answers

Are you a Yamaha Water Sport Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...