Question about Power Acoustik LT-980/2 Car Audio Amplifier

1 Answer

Hooked up an amplifier and two woofers to my car stereo. the amp powers up but no sound comes out of the woofers. they work when hooked up to the stereo directly but not when i hook up the amp...what am i doing wrong?

Posted by on

  • nascarchris Sep 08, 2011

    What is your input? Wires or RCA's?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 147 Answers

Look on amp for a dial or button that says GAIN or LEVEL try adjusting

Posted on Sep 08, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I want to install a self powered woofer and tap it to the rear speakers. Can you please tell me what are the colors and polarity of the rear speaker wires for 2006 Honda odyssey right hand drive


FIRST OF ALL --- THERE IS A FEW THINGS YOU NEED TO KNOW BEFORE HOOKING UP
A WOOFER LIKE THIS ---- IS THIS A STORE BOUGHT POWERED SUB WOOFER ? DOES IT HAVE IT'S OWN CROSSOVER BUILT INSIDE ?? I WOULD GUESS IT NEEDS TO BE HOOKED
UP TO A SUB WOOFER OUTPUT FOUND ON THE BACK OF THE IN DASH PLAYER ..
THE WOOFER NEEDS TO RECEIVE ONLY LOW FREQUENCY AUDIO WHICH MOST OF THE NEWER CAR STEREOS PROVIDE BY AN RCA JACK ON A SHORT WIRE COMING OUT OF THE STEREO ...
IF YOU TRY AND TAP IT TO FULL RANGE SPEAKERS THAT ALREADY ARE CONNECTED TO AN AMPLIFIED SIGNAL THE SOUND WILL BE DISTORTED .......
POWERED SUB WOOFERS NEED A LINE LEVEL INPUT WHICH IS MUCH LOWER THAN SAY
SPEAKERS ALREADY RECEIVING AN AMPLIFIED SIGNAL.
POWERED WOOFER WILL ALSO NEED TO HAVE A 12 VOLT ELECTRICAL CONNECTION AND A GROUND WIRE TO OPERATE THE AMPLIFIER BUILT INSIDE.
IF YOU HAVE NO EXPERIENCE WITH THIS TYPE OF HOOK UP I WOULD STRONGLY RECOMMEND SOMEONE WHO DOES [ CAR AUDIO SHOP ]

Jun 29, 2011 | Car Audio & Video

1 Answer

How to install spr-17s


The six 1/2 speakers are your woofers,connect the positive and negative wires from the speaker to the 2 connections labeled on the crossover as W(woofer)+ pos and W(woofer) -- neg,hook the tweeters to the crossover connections labeled T(tweeter)+ pos and T(tweeter) -- neg,then hookup the 2 remaining connections labeled Amp to your amplifier,amp must be 2 or 4 channel stereo capable and give out enough power to properly drive the speakers so they achieve optimal performance.

Mar 05, 2011 | Alpine SPR-17S Car Speaker

1 Answer

Can I hook up 2 single coil subs at a 2 ohm load on my sony xm-1252gtr?


If your sub woofers are SVC (single voice coil) 2 OHM each, then connecting one to each channel would make the amplifier run in 2OHM stereo Then again, if your sub woofers are 2OHM each, it would be better to connect both together in series and connect them to the BRIDGE specified speaker terminals of your amplifier making it run a 4OHM load into one channel. This will give you all the power the amp can give and still run stable. A 2OHM load into one channel will likely damage your amplifier. Do not forget to set the LPF (low pass filter)on if you are going to use the amplifier to run sub woofer/s. dreamsystems

Feb 07, 2011 | Sony XM-1252GTR Car Audio Amplifier

1 Answer

When I hook up my amp the prot. lite comes on. Whats the deal?


IT MIGHT BE A BAD WOOFER, AMP.. WHAT YOU CAN DO IS PLUG THE AMP UP WITH NO WOOFER AND THEN SEE WHAT HAPPENS AND THAN PLUG THE WOOFER UP AND IF AMP GOES TO PROTECT THEN ITS WOOFER IS BAD AND MAYBE ITS VOICE COIL

Aug 11, 2009 | Cd3 Clif Designs .2LX Car Audio Amplifier

1 Answer

No sound coming from sub woofers amp is connected and powered properly,all connections are correct,i have checked all connections to head unit,to battery i have disconnected and re connected all...


check your amp fuse also any car fuses, then check inside the sub box at the connections as they dont come connected when you buy it, try that 1st

Jul 11, 2009 | Car Audio & Video

1 Answer

Cant get but one side to work


This amp (kenwood  819)  was designed for use with a sub-woofer, hence the single chanel. It will however power up 4 speakers in mono, and if they are capable of handling the amps.while robbing you of the benefits of stereo as well as left, right and fade control.Good luck...
If you still want it connected. You should purchase an amp installation kit, and review the topics and videos at this web site. www.installdr.com

Good luck...

Feb 24, 2009 | Kenwood KAC-819 Car Audio Amplifier

1 Answer

Amp powers on but sub does not come on


I would double-check your RCA's on the amplifier. You should hear a thud if you unplug them. If not they are either not hooked up or defective.

Feb 07, 2009 | Sony XM-2150GSX Car Audio Amplifier

3 Answers

The red light on my amp keeps coming on and it wont work


You need to check your woofers. Most likely one or both may be a) blown or at a dead short or b) the ohm rating on them may be too low. What model woofers and amp do you have??

Nov 17, 2007 | MTX Thunder TA7801 Car Audio Amplifier

1 Answer

How do i know if my amp is blown


Hey Yoo,

 

Go to Radio shack and get you an adapter that will take an earphone jack and convert it to RCA male.  You use this to simulate the signal coming from the reciever.  Hook up to a Cd player or Walkman, anything with an earphone output jack. Test that the device actually puts out music or anything worth listening to.  Connect the device to the input of your amp, with the car running, and the reciever turned on.. This will tell yo if the signal is getting from the reciever to the amp. You may not be getting signal from the head unit. 

If you still get no sound to the woofers, dsisconnect the woofers and try a different speaker.  If that speaker dont work,  Change setting and switches., and if you still get no sound, then your amp is toast.

Oct 23, 2007 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

Not finding what you are looking for?
Power Acoustik LT-980/2 Car Audio Amplifier Logo

Related Topics:

101 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Dalynn Turner

Level 2 Expert

346 Answers

Marvin
Marvin

Level 3 Expert

84625 Answers

The Knight
The Knight

Level 3 Expert

76046 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...