Question about Sony STR-DE595 Receiver

1 Answer

I have a Sony STR-DE 597 reciever. I have been using it fine for a few years with no problems and it sounded great. I turn the unit on recently and a message was displayed on the unit that said PROTECT. After a few seconds the unit shut off. Any ideas what the problem may be? I did call Sony and they wanted $200 for a repair and wouldn't offer any other suggestions.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 17 Answers

Protect will usually show up if the receiver was turned up too loud to the point where the speakers will crackle, the receiver will switch to protect to not damage anything. Unplug it for about 30 seconds and check all the audio wiring in the back to make sure everything is plugged in good and tight and no loose cables or stray pieces of copper audio wire and plug it back in.

Posted on Aug 21, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi. my sony STR-DE 597 go in protect mode. how can I fix/repair this? Give me a tips.


protect mode means there is a shorted components inside your reciever it's probably the out put transistors take out the transistors and test it with a multimeter.

Jul 11, 2011 | Sony STR-DE597 Receiver

1 Answer

5.1 Surround sound not working


Maybe the surround processor is having a bad day... My kenwood would do similar and a reset was necessary to correct. Have you tried resetting the system? On my Sony STR DE 597 this is accomplished by powering off. Then while holding the 2 channel button down (front face plate) power on. A reset message is displayed. Your model may be similar but check your manual or download the PDF of the manual from Sony's support website. Hope this helps

Sep 05, 2009 | Sony STR-DE685 Receiver

1 Answer

Low sound at high volume


Hi,

THe problem is with the variable resistor present behind your volume control knob, try replacing the volume controls variable resistor, this must work fine... this is a common prblem for all the music equipment that has knob control for the volume....

This resistor can be replaced with your product warranty, contact your seller for the details regarding warranty...No need to woory about this, this is a sommon problem for most of recievers


ENJOY! RATE THIS SOLUTION
RNJ VINOD KUMAR

Jul 04, 2009 | Sony STR-DG1100 Receiver

1 Answer

Sound Problem with Sony STR-DE 845 receiver


Check for bad solder connections and tighten any and all screws that hold the circuit boards to the chassis.

Nov 20, 2008 | Sony STR-DE845 Receiver

Not finding what you are looking for?
Sony STR-DE595 Receiver Logo

319 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5699 Answers

The Knight
The Knight

Level 3 Expert

76140 Answers

Ekse

Level 3 Expert

13434 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...