20 Most Recent Power Acoustik PTID-5800 Car Video Player - Page 7 Questions & Answers


Make sure you have the amp grounded. I put one in last week and would not work till I grounded the amp to the car....Run a seperate wire to the car/truck.

Power Acoustik... | Answered on Jul 22, 2012


check the signal cable, there could be interference that causes a high peak that keeps the protection light on because of constant high output

Power Acoustik... | Answered on Jun 11, 2012


discus clearly.what's your problem ?

Power Acoustik... | Answered on May 30, 2012


you need to get your ribbon cable replaced. It's a cable that goes from the face to the main unit. they go out a lot. My suggestion is the next radio you buy, make sure it has no moving parts. Try to find the part at pacparts.com.

I’m happy to help further over the phone at https://www.6ya.com/expert/chris_7f7f91eb941fb23f

Power Acoustik... | Answered on May 22, 2012


It's a straight forward swap, just make sure you line up the cathode leg (the one nearest the stripe) the right way before you solder.
If the are any resistors around the capacitor it's worth changing them too, things don't normally blow on their own.
The caps and resistors are easy enough to get hold of from maplin or RS.

Good luck

Power Acoustik... | Answered on Apr 22, 2012


Hello
Check for any short circuit with wiring of the amp. If there is no such fault, surely your amp need service. It has some internal shorted components. This work is really a skilled one, and can only be done by any experienced service personal only. OK.

Power Acoustik... | Answered on Jan 17, 2012


Unless he connected the black to positive and the red and yellow to negative, it should not have fried his dvd player.

Power Acoustik... | Answered on Jul 13, 2011


contact the manufacture the should have the part

Power Acoustik... | Answered on Jun 04, 2011


  • You double the watts to the speaker for the channels bridged. This also depends on the Ohms of the speakers being used. The lower the Ohms of the speakers used in relation to the Ohms of the amp also increases the watt output of the amp.

Regards, Tony

Power Acoustik... | Answered on May 22, 2011


it sounds like you have a shorted wire or a blown speaker in system

try disconnecting all speakers and see if light goes out if so it is bad speaker if not try disconnecting all speaker wires and see if light goes out then

also if disconnecting speakers fixes problem you might want to check what the Ohm load is and how you have multiple speakers hooked up if Ohm load is too high or low you will get same light

is it possible you have too much moisture in car - sometimnes that will cause error

if this does not help please contact me with as many details as you can give me and i can try to help more - number of speakers, how they are wired to amp, what amp, how many channels for amp, etc - the more info the better i can help

good luck!

Power Acoustik... | Answered on Mar 25, 2011

Not finding what you are looking for?
Power Acoustik PTID-5800 Car Video Player Logo

18 questions posted

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Dalynn Turner

Level 2 Expert

346 Answers

Marvin
Marvin

Level 3 Expert

85206 Answers

Professor_V
Professor_V

Level 2 Expert

93 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Power Acoustik Car Audio & Video

  • Power Acoustik Car Audio & Video

Most Popular Question

bypass e brake veiw movies all time

  • Car Audio & Video
Loading...