20 Most Recent Alpine MRD-M301 Car Audio Amplifier Questions & Answers


If your Alpine MRD-M301 is not new, the output stages may have been burned out by overload.

Alpine MRD-M301... | Answered on Oct 26, 2017


Hello diana_soto55,

The MRD-M301 is a discontinued model but originally sold for around $250-300. A more powerful current model is the MRP-M500 that sells for around $200 and under at discounted online stores.

Hope this helps.

Alpine MRD-M301... | Answered on Oct 03, 2009


http://www.shopping.com/xPO-Alpine-Alpine-MRD-M301-150W-x-1-Car-Amp-Mono-Subwoofer-Amps

Alpine MRD-M301... | Answered on Jul 31, 2009


check your fuse on the amp hopefully you didnt burn it did you brige 2 subs into 1 channel on your amp

Alpine MRD-M301... | Answered on Jun 22, 2009


HI DUDE .. U CAN ONLY SINGLE PC OF JL SUB BY BRIDGE MODE ... COZ UR MTX AMP HAVE 300WATTS RMS ....

Alpine MRD-M301... | Answered on Jun 21, 2009


have you disconnected all inputs and outputs on amp and retried starting it power only? if so your amp has an internal solder bridge and must be repaired by authorized repair center. Repair it or replace it at wholesale price from www.godspeedaudioheaven.com

Alpine MRD-M301... | Answered on Jun 10, 2009


No, needs repair..Contact ALPINE ELECTRONICS OF AMERICA, INC. 19145 Gramercy Place, Torrance, California 90501, U.S.A. Phone 1-800-ALPINE-1 (1-800-257-4631)

Alpine MRD-M301... | Answered on Jun 10, 2009


Make sure the amplifier setting "disable" is off then turn off remote power and turn back on.

Alpine MRD-M301... | Answered on Jun 10, 2009


disconnect all inputs and outputs then restart it if problem persists you have a internal solder bridge youll need to have it repaired by authorized repair shop or buy a new amp at wholesale from this site:
www.godspeedaudioheaven.com

Alpine MRD-M301... | Answered on Jun 10, 2009


have you disconnected the inputs and outputs? try that if problem persists you have a solder bridge internally which can only be repaired by authorized repair center if your amp is knackered either repair it or buy a new one at wholesale from this site:
www.godspeedaudioheaven.com
for all your needs also good place to make cash!

Alpine MRD-M301... | Answered on Jun 10, 2009


you could have a bad ground or the power wire could have a short i would start there

Alpine MRD-M301... | Answered on Jan 31, 2009


check all fuses on the unit, pull them all.
look for a way of resetting the amp.

LEAVE THE MAIN FUSE OUT TILL THE INSTALL IS COMPLETE!!!

that way you wont short a screw driver across the terminals on to the chasis.

Alpine MRD-M301... | Answered on Jan 25, 2009


Best thing to do is call the dealer and tell them you replaced the battery and the car didn't have an owners manual. They can get pull one off their computer, they just need a S/N from the radio. If that doesn't work, I can tell you a different idea. Don't forget to leave feedback

Alpine MRD-M301... | Answered on Dec 31, 2007

Not finding what you are looking for?
Alpine MRD-M301 Car Audio Amplifier Logo

25 questions posted

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5013 Answers

Robert Salgado
Robert Salgado

Level 2 Expert

200 Answers

Jaime Hernandez

Level 3 Expert

2337 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Alpine Car Audio & Video

  • Alpine Car Audio & Video

Most Popular Question

sounded great only 10min

  • Car Audio & Video
Loading...