Question about 2005 Kymco People S 200

2 Answers

I HAVE A 2009 PEOPLE S 200 THAT JUST CLICKS WHEN I TRY TO START IT. IS IT MY CONNECTION? WHAT DO YOU RECOMMEND

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have a kymco people s 200. I,ve owned my for about four months now. i bought mine brand new. I had it for less than a month and had trouble similar to what your does. kymco must have used really cheap solenoids in these bike. So have your solenoid checked.

Posted on May 12, 2012

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 120 Answers

Battery is low and needs charging most likely.

Posted on Aug 18, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 Volvo s80 clicks but won't start


This procedure usually works:
·Check the battery cable connections:
Make sure the negative cable makes a good ground connection at the battery and (preferably) at the engine. Make sure the positive cable, makes a good connection at the battery and at the starter.

·Check the battery the simple way, like this:
Turn on the headlights, then try to start the car.If the headlights do not dim or go out, then the battery is likely ok.

·Check the starter and solenoid:
If the wiring looks ok, then look at the starter solenoid for a good connection, and proper voltage at the starter(10 volts minimum while cranking).
If the starter spins and no crank, the problem is most likely the Solenoid's pinion gear is stuck.
Have someone hit (not too hard) the starter while you try to start the car. This usually works by dislodging a stuck pinion gear.
·Make a simple test of the alternator:
If you can, somehow get the engine running, measure the voltage at the battery. It should be at least 13.6 volts to properly charge the battery.

May 01, 2015 | 2000 Volvo S80

1 Answer

2000 Crown Victoria only clicks when I try to start it.


Check ground wire. It can build up rust where it bolts to frame.
If this doesn't work then have someone check starter.

Mar 13, 2014 | Ford Crown Victoria Cars & Trucks

1 Answer

Crank sensor


Clicking when trying to start is usually the sound of the starter solenoid. The problem based on the fact that eventually it will start will either be a loose or dirty connection at the battery (most likely if it is a connection issue), ground on the block, or power wire at starter, or the starter itself is on the way out.

Nov 05, 2013 | 1996 GMC Jimmy

1 Answer

1988 Mazda RX7 won't start, just clicks


check battery and connection.could be starter try to tap the starter.tune up.

Mar 09, 2013 | Cars & Trucks

1 Answer

Car won't start. New battery installed recently. Only clicks when trying to start.


one single click any time you turn the key usually indicates a bad solenoid on the starter. A new starter will typical get you going.

A series of rapid clicks when you try to start usually indicates a weak battery. There could also be a bad connection at the terminals on the battery or even a poor connection at the starter.

If you get a single click and everything goes dead for a couple of seconds than you definitely have a bad connection at the battery.

Let me know what you find or if you have any questions.

I’m happy to assist further over the phone at https://www.6ya.com/expert/jeremy_d728a59f986299fa

Dec 28, 2011 | 2007 Chevrolet Tahoe

1 Answer

Sometimes when I try to start my 2004 Titan it just clicks (like a bad connection) and then it starts up fine and no other problems occur...baffling!!


Most likey a loose connection..check connection on battery terminals and than check for loose connections on starter.

Nov 17, 2011 | Cars & Trucks

1 Answer

My 99 mitsubishi galant won,t start battery is brand new and it still won't start it clicks like the battery is dead I even tired jumping starting land it still won't start


either you have a bad connection to your battery or,, you have a bad starter. no other solution. if it clicks when you try to start it and the batterys fully charged,you're getting fire to the starter and it's trying to start,but the starter bendix isn't kicking out.which means it's a bad starter. thank you for choosing fixya.com

Mar 27, 2011 | Mitsubishi Galant Cars & Trucks

1 Answer

My car wont crank, replaced solinoid and starter tested good, and battery is good, but when i turn key will not crank, just clicks.


Heres a good test to test the solenoid and the starter, make sure the car is in park and turn the key on, using a screw driver jump the solenoid and see if it spins the engine or clicks, if you look at the solenoid you will see a small wire and the two connections for battery cables,locate the connection that the battery goes to ,the other big connection will be the cable to starter, take the battery connection and jump it to the small wire connection, if it clicks then you must have a bad starter or bad connection at the starter, also another test is to turn the headlights on and try to start the car while someone watches the lights, if the lights go out then you have a bad connection at battery or the ground to engine. start with these tests and let me know what happens, good luck.

Mar 05, 2011 | 1988 Mercury Grand Marquis

1 Answer

Starter just clicks when i try to start it


Could be loose connection Pos or Neg or could be bad starter. You have to test the power at the starter to see if you're getting 12 volts

Nov 16, 2009 | 2004 Jeep Grand Cherokee

1 Answer

When i start my lucida it cranks once ,then clicks and clicks and


go ahead and jump it. your battery is dead or you have a bad connection with the battery cables. try jump starting it or at least hooking up a battery charger over night. (the engine size of the vehicle wont determin if it will be able to jump start the other vehicle.)

Apr 22, 2009 | 1996 Toyota 4Runner

Not finding what you are looking for?
2005 Kymco People S 200 Logo

Related Topics:

320 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kymco Experts

Marvin
Marvin

Level 3 Expert

84625 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

5856 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Are you a Kymco Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...