Question about Ford Escort

1 Answer

Hi. My ford escort 97 lx wagon transmission is not shifting anymore it is stuck in first gear(althought if i put it in neutral while driving and switch back to drive it picks up for a few seconds...) and the spedometer went out 2 days after !! Could it be the speed sensor? I removed the trans oil and put some trans fix oil but it worked only for 1 day(...). Could you please help me ! thanks

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 980 Answers

My brothers 2000 ford ranger the fuse went out to the speed sensor. I change the speed sensor because it did not shift out of 1st gear and the speedometer stopped working. I then found out the fuse was missing in the fuse panel. My brother could not tell where the fuse went but when I put a fuse in it started shifting and the speedometer started working. everything was good. You should have a code if it is the speed sensor.

Posted on Aug 15, 2017

Ad

6 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Anonymous

  • 1010 Answers

SOURCE: SPEED SENSOR

Start by checking these items-
* Open or short in vehicle speed sensor circuit
* Vehicle speed sensor
* Combination meter
* ECM

Posted on Jun 25, 2008

Julie Applegate

  • 11 Answers

SOURCE: 02 Neon won't shift out of second gear in Drive

Sounds like the valve body is loose, warped or blown

Posted on Apr 07, 2009

Anonymous

  • 2 Answers

SOURCE: vehical stuck in limp mode

This only applies if you have an allison transmission, which based on the problem you are reporting I would guess that you do.

It sounds like your vehicle is stuck in limp mode. This is probably due to a bad NSBU switch(Neutral, saftey, back up) (if you have an allison transmission. Prior to 2002 the NSBU switches had a very poor seal which resulted in water intrusion into the NSBU switch causing corrosion. If the switch is corroded it is likley confusing your transmission. Unfortunatly you cannot repair the bad switch, it needs to be replaced. If you order one through Chevy it will cost around 200 dollars. I found one at merchant Automotive for 91 dollars. ( http://www.merchant-automotive.com/allisonnsbuswitch2001-2004.aspx ).

The switch is relativly easy to replace. the electrical connections are the hardest part as they are glued into the switch. A little heat from a butane torch should soften it up and make the connectors slide off more easily. Other wise you may have to break the NSBU switch appart to remove the connectors.

I replaced the switch for the first time and it took me 15 minutes.

Posted on Apr 22, 2009

Anonymous

  • 11 Answers

SOURCE: where is the pcv valve in a 1997 ford escort wagon

If you look at your valve cover its at the back on the right, it comes up and then its an elbow, it comes over the top of the valve cover then down. the PCV valve is either the elbow or the piece in front of the valve cover after the elbow.

Posted on Jul 07, 2009

drallim

  • 4088 Answers

SOURCE: '97 subaru legacy L,AWD wagon, 2.2L, auto trans.

Do you hear a 'click' when the key is turned to start? Have someone try the key while you listen under the hood. It should be the starter solenoid clicking. You need either a test light or voltmeter to test further. One large terminal on the solenoid has the large wire from the battery positive, and should always show voltage/light at all times. Test the other side of the solenoid (large terminal) that is connected to the terminal on the starter motor. It should show light/voltage when the key is turned. If it doesn't, the solenoid must be replaced. If it does show light/voltage, then the starter motor is defective (probably brushes). If you get no click when turning the key, test the small terminal on the solenoid, you should see a voltage/light change when the key is turned. If you see a change, but no click, the solenoid coil is open or the case of the solenoid is not grounding where it is mounted. Try loosening the mounting and re-tighten. If no help, replace the solenoid. If you see no change at the small terminal, remove the wire from it and using a spare piece of wire, touch the small terminal to, first, the large terminal that the battery is connected to, then to the the mounting bolt for the solenoid. If the solenoid is good, the starter should operate with one of these two tests. In that case, the starter position of key switch is open--replace the ignition switch.

Posted on Sep 15, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ford escort w/automatic transmission - shift stick not smooth anymore


first check the gear oil or replace it before you change the automatic gear completely

Dec 04, 2013 | 2003 Chevrolet Impala

1 Answer

Ford escort shift gear


Does the shifter move - in other words, can you change the shifter position, but the car still stays in Drive? Or can you not move the shifter at all? A bit more information, please.

Oct 04, 2013 | Cars & Trucks

1 Answer

My transmission in my 97 ford f150 wont move unless i put it in 4 low and now wont switch out of 4 low


Its Possible the chain in transfer case is stretched I had the same problem a used case was 250 at my local salvage yard

Nov 23, 2012 | Cars & Trucks

1 Answer

5-speed 97 escort wagon... on the dash, there will be an orange arrow light that pops up in between shifting gears. the arrow points up/forward. what does it want? does it want me to shift into a higher...


Some cars came with this light to help the driver know when to shift to the next gear. IE: 1st, 2nd, 3rd and so on. It will not indicate when to downshift to a lower gear. It's main function was for optimal mileage and proper RPM shifting. Happy driving.

Feb 22, 2011 | 1997 Ford Escort

1 Answer

Transmission does not shift into gear at times even though rpms go up. if i shift to neutral and back to drive real quick , transmission shifts into drive gear ok.


its the velve block inside the gearbox its sticking it needs a strip down and new seals fitted,,,thats pricy too,,,,there is an oil that you could try out first,,its called "smooth shift" or "auto box shift" its just tiped into the gearbox

Aug 28, 2010 | 1994 Ford Escort

1 Answer

I have a 1994 ford escort wagon 1.9l sohc and the automatic transmission will not work in 1st gear but if i put it in "low" it will work to 2omph then i shift it manually into drive then it works fine but...


you can locate and fix the problem with the help of repair manual it will also help you to repair the fault your self to get the manual go to the given link from where you will get the manual very easily http://toolsnyou.com/

Sep 17, 2017 | 1994 Ford Escort

1 Answer

I have a 95 ford escort wagon with a auto trans,, I was getting on a road and there was a bang,, nothing,,,the motor runs, theres fluid in the trans(still red and smells good not burnt) I have no gears...


typical problem is the pump shaft and gear in the transmission,i cant remember if it can be changed with the transmission in it,its behind the pan on the drivers side,i pulled a transmission out of a 95 escort to fix the same problem a few years ago that had 150,000 miles on it and it drove to California and back with no problem

Jan 30, 2010 | 1995 Ford Escort

2 Answers

My 2003 Mercury Mountaineer Gear Shift is stuck.


THERE IS A SENSOR ON THE BRAKE PEDAL THAT RELEASES THE THE SHIFTER.THERE A 3 COMPONENTS INVOLVED.U CAN PUT IT IN NEUTRAL BEFORE U START THE CAR.THEN WIL SHIFT.

May 01, 2009 | 2004 Mercury Mountaineer

1 Answer

Ford Escort 1999 popping out of gear while driving


hi i have the fault code here and it says gear 4 incorrect ratio.wiring fault,transmission switch,shift solenoids or mechanical faults in the gear box.hope this helps ,best of luck.

Oct 03, 2008 | 1999 Ford Escort

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

87 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

Marvin
Marvin

Level 3 Expert

85206 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

gerry bissi

Level 3 Expert

4388 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...