Question about Chevrolet Malibu

7 Answers

Car runs good then cuts off going down the road then 2 -3 min will crank upagain and run good changed battery fuel pump relay fuel filter checking coils next

Posted by on

  • Anonymous Mar 29, 2011

    We could use a vehicle etc
    Fuel pump may have failed

×

Ad

7 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I have a 1994 bucik Park Avenue Ultra The car dirve good then it cuts off the service engine light will come on and stay on for the duration of the trip. the car will start back up but now it will cut off and take a while for it to start back up, sometimes when im driving and give it gas it will stall unless i ease off the gas a slightly give it gas. whats the problem? I also have a 1994 buick Lesabre had a slight similar problem I was told its the throttle control sensor is it?

Posted on Jun 12, 2011

  • tracey ruffin
    tracey ruffin Jul 20, 2014

    i have 2001 mitsubishi galant es it run good then it ut off it will turn over but wont stay crunk until cool down then willrun for 2-3 minutes then cut back off

×

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 36 Answers

So the Security light is on or flashing in your vehicle and you are looking at 1 of 3 things. Either the vehicle won't crank over and start, It cranks but dies in a few seconds, or your vehicle shuts off while driving scaring the **** out of you. You have now experienced GM's worst security system ever created. GM's security, also known as Passlock Passkey or Vats.

There are 3 parts in this system:

1.The CHIPKEY
Normally a black resister chip in key which "communicates" to the lock cylinder. Sometimes is hidden in the plastic part of keys in new models. Same concept, might say PK1 PK2 PK3 PL or something similar to that. The newer ones work on frequency. Same thing tho.

2.The LOCK CYLINDER
Inside there are pins that read the chip in the key or the part that reads the frequency on new models. This then "communicates" to the TDM)

3.The TDM
Theft Deterrant Module-Sometimes called the "computer" or "brain". This is the part that sends the signal (**NOTE**) to your car and allows your car to start or continue running depending on your type of system.
If any of these parts are not communicating properly, your SECURITY light will come on and shut down your vehicle. The idea being, that without the chipped key or FOB key, the vehicle wont start and cant be "hotwired" or stolen. Pretty nice when working, but these systems are flawed and the average life is 6-10 years. Every single aspect of this system is expensive to replace and can only be worked on by "authorized" GM service men with out voiding warrenty. Most garages dont even touch them and if they do,
they will sell you every part they can before "fixing" the problem

*QUICK FIX TRICKS*
1st trick
Try a spare key that is newer or used less. The pins wear down with use and so do the keys causing the security to fail.

2nd trick
(if not starting) turn the key forward 2 clicks till right before it would normally start, leave like that for 10 minutes. ( no less ) After 10 minutes, turn key back then forward and your car might start. I did this in my Buick for more than a year. Remember this is a temporary fix... If its shutting down while running, I'm sorry I have no quick fix...
*PERMINANT FIX*
Well since the lifespan of these systems are so short, and are extremely expensive to fix, and in my opinion far worse of a threat to owners than theives, my only perminant suggestion is to eliminate it completely. After a year of 10 minute tricks and a "key bypass" that lasted 2 months. I have only one good suggestion. After surfing the web for hours thru forums and websites i came across http://newrockies.com/passkey to the starter or injectors and so on. Thus eliminating the ENTIRE system COMPLETELY. I came upon a fork in my road. A TDM for $600 in my $1000 car or the $200 bypass. Or throw my car away. Lets say i now drive a Buick with the chip ripped out of the key and the TDM sitting in my glovebox for show
and tell. If you have any questions or anything else. Comment on this post
and i'll get an E-mail to reply to you. If you do choose to buy the bypass,
i have pictures of what a TDM looks like and will definately help you when
installing the newrockies bypass. Good luck
Here is a list of known effected cars that can be fixed with the
newrockies bypass. This is the same list from the site and updates
frequently.
Trucks
.
GMC/Chevy
1998-2006 S10/T10/Sonoma
/Blazer/Jimmy
1998-2007 Suburban/Avalanche
/Tahoe/Yukon
1998-2006 Sierra/Silverado
2002-2008 Trailblazer
2003-2006 SSR
1998-2006 C1500/C2500/C3500
1998-2006 K1500/K2500/K3500
2003-2007 Hummer H2
.
Isuzu
1998-2000 Hombre
2005-2006 I280/I350
2007-2008 I290/I370
.
Cars/Vans
.
Isuzu
2003-2007 Ascender
.
Pontiac
1994-2003 Grand Prix
1998-1999 Montana
2006 Torrent
1996-2005 Grand AM
1994-1998 Trans Sports
1988-1999 Bonneville
1988-2002 Firebird
1995-2005 Sunfire
1996-2002 Trans Am
.
Buick
2004-2007 Rainier
1994-1996 Century
1993-1996 Regal
1982-1999 LeSabre
1991-1996 Park Avenue / Ultra
1994-1996 Roadmaster
1991-1996 Roadmaster Estate Wagon
1982-1999 Riviera
1988-1991 Reatta
1996-1998 Skylark
1982-1990 Electra (all models)
.
Oldsmobile
1996-1998 Achieva
1999-2004 Alero
1994-2004 Aurora
1998-2004 Bravada
1991-1993 Delta 88
1994-1999 Eighty-Eight
1991-1996 Nighty-Eight
1998-2002 Intrigue
1990-1992 Toronado
1994-1997 Cutlass Supreme
1997-1999 Cutlass
1997-1999 LSS/Regency
1997-1999 Silhouette
1991-1996 Custom Cruiser
.
Chevrolet/GMC
1998-2005 Astro/Safari
1998-2008 Envoy
2005-2006 Equinox
1998-2007 Savana/Express
1995-2005 Monte Carlo
1997-1999 Venture
1995-2001 Lumina
1988-2002 Camaro
1995-2005 Cavalier
1982-1991 Corvette
1994-1996 Caprice/Caprice Wagon
1995-1996 Impala SS
2000-2005 Impala
1997-2005 Malibu Classic
1997-2003 Malibu
.
Cadillac
1986-1993 Allante
1982-1996 Fleetwood
1985-1996 Fleetwood Brougham
1992-1995 Seville
1992-1995 SLS/STS
1985-1995 Deville
1994-1995 Deville Concours
1988-1995 ElDorado
1994-1995 ElDorado Touring
1999-2007 Escalade
.
Saturn
2000 LS/LS1/LS2/LW1/LW2
2001-2002 L100/LW100
2001-2003 L200/LW200
2001-2005 L300/LW300
2004-2005 L-Series
2002-2008 VUE
1996-2002 SL/SL1/SL2
1996-2002 SC1/SC2
1996-2002 SW1/SW2

Posted on Mar 29, 2011

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Got a 1991 Grand Am that had the same problem and i just fixed it yesterday. The problem is the ignition system which consists of the coil packs, the ignition module and the crank sensor. The crank sensor sends a signal from the crank as it turns. The system is timed so that the right fuel and air mixture is correct per cylinder. The signal is sent to the ignition module which processes it for the computer. The computer takes the signal and control the necessary components such as the fuel pump and injectors etc. On this particular car the crank sensor sticks through a hole on the back of the motor exposed to oil and it started breaking down. It would run good until it get hot and the motor shuts down until it cools off. Crank back up like nothing ever happened and would repeat the process. Change the crank sensor and have some peace of mind...

Posted on Oct 15, 2012

  • mack flynn Dec 16, 2012

    ive changed the crank/cam sensor and theignition module and all coil packs still cuts off

  • mack flynn Dec 16, 2012

    i have a 1999 p0ntiac grandprix 3.1

×

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

OK, back again, I THINK I got it remedied,,, I repositioned the TPS sensor just a hair after tinkering with it for about an hour,, THEn I pulled the PCM fuse to reset the computer.. it appears that it has solved the problem. It starts up and goes right to 750 rpm and stays there,, it runs well on partial throttle , but sometimes under hard throttle it "bogs: just a bit,, I havent had it over 40 mph longer than a mile, so I dont know if the OD is working yet,,Ill keep all ya posted as the days progress..Im keeping my fingers crossed, I know Im on the right track,,M

Posted on Aug 14, 2012

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

I have run into this problem allot with the olds alero . i do about 3 to 4 a year i have tried new keys resetting the security system which you leave the key on till the light stops flashing. only fix i have found is replace the key and the cylender worked everytime for me and it runs about 125.00 if you do the work your self

Posted on Nov 22, 2011

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Chevrolet Master
  • 401 Answers

Sounds like your coil pack is breaking down, it reconnects when it is cold but when it gets hot it breaks down. I would make it cut off and then run a check on the coil module

Posted on Jan 08, 2015

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Chevrolet Expert
  • 175 Answers

If its a gmc / chevy,, the Security system cutting the fuel pump off,,,, try resetting your fob,,,,"aka keyless remote".gm and chevy products are bad about doin this,, you may go to a dealer and have a new key made ,,, that has the chip in it,,, they do go bad
taterhead

Posted on Sep 11, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Why I have no power on 1996 geo metro fuel pump when I try to star it ?


Sep 28, 2014
too old, to post ...? seems not.
check pump voltage at the pump cranking.
then if that fails to be 11v.
then at the fuel pump relay, cranking, (the big pink wire is it)

FI fuses
and ig-coil fuse must be good.
and the CEL lamp glow key on, or ECU may be dead.(ask)
always test with a $10 volt meter,
voltages matter, test lamps were great back in 1950/60.
these cars love to have, like 6 or 8v on the way to the pump, due to rust on the connectors.
the meter shows this truth, and never a lamp.

Sep 28, 2014 | 1996 Geo Metro

3 Answers

Crown vic 2005 no start replaced fuel pump


check your crankshaft position sensor. fuel+spark+compression+timing=ignition.

Mar 13, 2014 | Cars & Trucks

3 Answers

We have a 2002 Chevy Suburban and it cuts out while driving down the road, about 20-30 mins after starting the vehicle. We've cleaned the fuel filter. As soon as we crank it up it'll run for 20 mins than...


there is code that does not turn on the service engine soon. have code retrieve.And when the problems occured have fuel pressure check.You have to find out if the problem is electrical or fuel and air .Another way to find it is move engine harness while engine running if it stall could be short to ground or wire cut open

Aug 28, 2013 | 2002 Chevrolet Suburban

4 Answers

Fuel is not flowing to engine, changed fuel filter but still not running.


Did the engine just quit going down the road? or was it parked and then would not start? Did it have fuel before you replaced the filter? Did you check all the fuses in the fuse box. I think 2 of the fuses is marked ECM, check both Fuel pump relay? swap it with another relay in the fuse box. You should hear the pump come on for 2 seconds when you turn the key on, do you? If not as you are cranking the engine have someone rap on the bottom of the fuel tank with a mallet or block of wood, or hammer and see of the pump will run. If that gets it running, the pump is bad and will need replacement.

Nov 15, 2009 | 2003 Chevrolet Suburban 1500

1 Answer

235k miles. cut off one time going down road, immediately restarted. a week later after cutting off would not restart in 8 long cranks. 5 mins later cranked. next morning after starting 2 different time...


I have seen crank sensors go and leave no codes, but, likely the fuel pump is going away...they get hot and seize, then cool down and work again. I would not replace either without proper testing only because parts are expensive and there are other heat sensitive components in there. (coil etc) Be aware that it will check out good if it is running right while tests are being done.

Sep 24, 2009 | 2000 Jeep Cherokee

3 Answers

1985 Ford F-150 Truck (EFI) Fuel Problems


i actually have a 1985 302 efi... there are 2 pumps one one the rail right under drivers door and one in the tank.. there are also two filters... one just behind the pump one the rail.. its actually inside a canister that you open with a oil filter wrench then it has a paper element inside..then there is a inline filter that is actually part of the high pressure line the hose is about 3 feet long and runs from your front pump up to the fuel rail agaist the firewall...this one is really hard to find (Buy) good luck wish i hade a carb

Feb 14, 2009 | 1985 Ford F150

4 Answers

1985 Ford F-150 Truck (EFI) Fuel Problems


Same problem with my 85 F-150 5.0 EFI---turned out that the fuel pump relay under the hood was teriffically corroded on the inside (I opened up the relay to look inside). When I checked the voltage at the fuel pump it would show 3.5-6 volts instead of 12 volts.

I was thinking fuel blockage or perhaps failure of the in-tank pumps. Sometimes the truck would start and run, othertimes it would neither start nor run. Typically, if running it would stay running until turned off (where the relay had to break).

Changing the green fuel pump relay fixed the problem--12 volts now at the pump and no reoccurance.

Good luck--let me know if this fixed your F-150.

riippa@aol.com

Feb 14, 2009 | Ford F-150 Cars & Trucks

2 Answers

My truck 99 ford ranger died while driving down the road


fuel filter usually dont cause it to die and not start back, thay usually cause rough running. see if your fuel pump is running by getting in and roll up all windows so as quite as possible then cycle the key from off to run and lisen for the pump to run for 2 to 3 seconds should be a faint buzz sound if no sound is heard then replace the fuel pump relay, if no help probably going to need fuel pump

Dec 10, 2008 | 1999 Ford Ranger SuperCab

3 Answers

2002 7.3 F350 WONT START


Have you checked the fuses? i had one the fuel heater shorted out and blew a maxi fuse cut off going down the road

Aug 27, 2008 | 2004 Ford F350

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

16,655 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

84625 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...