Question about 1996 Chevrolet Camaro

2 Answers

1996 camaro 3.8 v6. Hard start, rough or won't hold idle, stalling at stop and while driving. Engine cuts out under acceleration, causing the car to accelegate roughly.

Exhaust has strong gas scent on first start. Very definite miss only on morning start. Have to feather peddle at 2-3000rpm till miss goes away. Some days are worse than others, but never goes away completely.

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 5,476 Answers

Injectors may be shorting or worn out . Multecs had several issues in these years .

Posted on Jan 07, 2018

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Chevrolet Master
  • 873 Answers

Clogged carbon canister or valve.

Posted on Jan 07, 2018

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

  • 14 Answers

SOURCE: 1995 Chev S10 4.3L V6 rough idle and under power

This make/model has a chronic problem with EGR clogging. If you have a dashboard indicator showing "check engine" most likely it is a trouble code indicating and EGR (exhaust gas recirculator) valve problem. Symptoms are rough idle, and surging and stalls.

What happens is sediments from the exaust manifold get sucked up into the valve when it opens, then stick in the valve and keep it from closing. When the valve is open when it should be closed, the engine runs very rough.

I removed my egr and then dislodged the sediment (pea-sized debris) and then re-installed the valve. Three days later, the same "check engine" and same rough idle. I must have did this at least three or four more times.

What I found that gave me a permanent solution was an aftermarket filter gasket that keeps debris from clogging. I don't remember the name of the product, but a search for "EGR filter gasket" may lead you to the product.

Install the gasket between the EGR and the exhaust manifold and you should be good to go. Note: on 1995 and newer models, disconnecting the EGR from the wiring harness (common on R&R) may require the computer to be reprogramed.

Posted on Dec 24, 2008

motor1258
  • 6674 Answers

SOURCE: Hard start, rough idle, some black smoke, engine service light on

A scan for trouble codes may point you in the right direction quickly, rather than hit & miss, with replacing parts. Some of the autoparts stores will scan for free, and your right where you need to be to get the right part at the same time.

Posted on Mar 04, 2009

66 chrgr
  • 1011 Answers

SOURCE: 1999 S10 Blazer 2WD 4.3L V6. Starts hard, idles rough.

you have a single injector under the intake plenum it has 6 branching fuel leads off of this.A very common problem is the regulator attached to this and it leak off fuel which falls into the intake .causing this problem. it needs to be replaced .i have done at least 80 of these in my career.this will fix your problem.thanks for choosing fix ya

Posted on Mar 04, 2009

  • 58 Answers

SOURCE: check engine light is on, motor runs rough, sometimes stalls

Go to Advance or Auto Zone and have them run an obd scan on it and it will pin point why your light is on and could solve your problem. This is often done for free.

Posted on Apr 12, 2009

  • 599 Answers

SOURCE: Car stalls when idling at stop light

have the car checked when the check engine light is on,also a good scanner will be able to give you the history codes,get back to me with the codes and we'll go from there. you need someone with a professional scan tool

Posted on May 13, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

91 SAAB 900 starts and stalls immediately, what is the problem? I should add I have got a spare LH control unit, which I have swapped out. I have replaced the ignition control module as well.


Could be two problems. First the pump running, could be the ignition switch or ECM. second could be the fuel pressure regulator. You definitely have gas fouled plugs.

Jul 25, 2015 | Saab Cars & Trucks

1 Answer

White smoke comes out from the exhaust on cold start 80%of the time or after few short trips and goes away in few seconds


that's just condensation in your exhaust is this car a diesel or gas? diesels will do that till they warm up gas till water is gone

Jun 09, 2014 | 2006 Volkswagen Passat

1 Answer

2005 doge neon. sputters on occasion when i excellerate quickly. will still run fine if peddle is part way and idles fine. If I shut engine off the problem goes away but will start again the next day. ...


I have seen fuel pressure issues cause this. Fuel filter, or fuel pump. However, I have also seen the catalytic converter cause this issue. The honeycomb, located inside the catalytic converter, breaks up and will block the exhaust when you accelerate. Engine power is lost, until you let off the gas and let it idle. Then, the chunk falls down from the exhaust port, and it runs fine again. Until you get on the gas and increase the velocity of the exhaust, and the chunk blocks the exhaust gasses again. Good luck

Nov 30, 2017 | Dodge Neon Cars & Trucks

1 Answer

1994 Mercury Cougar 4.6, hard start, miss, gas smell


This is an idea not a for sure. Bad or worn valves can cause what you describe. Had something similar happen to an 2004 Toyota. Due to bad lubrication, crazy huh?

Mar 12, 2010 | 2004 Ford F150

3 Answers

Strong smell of gas on cold startup


I have a 2002 Impala, and on cold days on the first start of the day had strong fuel smell. I troubleshot the problem to the fuel pressure regulator on the fuel rail was leaking around the seams. I replaced the regulator and have had no problems since. Hope this helps.
Chad

Aug 04, 2009 | 2003 Chevrolet Impala

1 Answer

Truck won't stay running.


Sounds like you have a vacuum leak check all rubber hoses going to the intake manifold .

Jun 07, 2009 | 1992 Chevrolet S-10

1 Answer

Engine misses on take off from stop.


check your fuel pressure, slightly low fuel pressure can cause this and it is possible that your other coil is breaking down under heat. also it could be as simple as your plug wires breaking down under heat

Jun 04, 2009 | 1999 Chevrolet Metro

3 Answers

Was running great, quit running when in gear or given gas


sounds like you need to have fuel pressure test and check for plugged fuel filter

May 09, 2009 | 1994 Chevrolet Suburban

1 Answer

2002 jaguar x type


Hello
Definitely the battery has a big role in Jaguar cars, as Jaguar cars are very sensitive when it comes to battery.
You never go less than specified , going a little higher is ok but not lower

May 17, 2017 | 2003 Jaguar X-Type

Not finding what you are looking for?
1996 Chevrolet Camaro Logo

Related Topics:

195 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

85161 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...