Question about 2007 Mercedes-Benz ML350

Open Question

Mercedes benz ml350 blue tec exhuast back pressure sensor internal fault 159300

Going into limp mode

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
BearWeb
  • 357 Answers

SOURCE: Mercedes Benz C180 Fault Message Brake Assist.Visit Workshop BAS

Hi there

BAS is the Brake Assist System and if there is a malfunction it would only come into play in an Emergency stop while applying full pressure. BAS applies full braking force because people tend to lighten up their pressure on the pedal in these situations. I would suggest that the best thing to do is go to a Workshop or Service Center and have it checked out. Please remember to put a good rating on my profile.

Kind regards
Dustin Ellse

Posted on Jun 26, 2008

Ad
  • 510 Answers

SOURCE: how do i reset the clock in a ml350 mercedes benz

Press services ,left of screen,then system,right ofscreen
Use up/down/left/right on rotary button bottom right/screen

Posted on Mar 14, 2010

alicantecoli
  • 22484 Answers

SOURCE: My low beam light bulb

well this is not easy unless you make a accessby removing anything in the way,or just take the headlight out ,How did you manage to open the bonnet as these vehicles from around this year started using a sealed bonnet that only the dealers can open with a special electronic key that uses rolling encrypted software.

Posted on Aug 30, 2010

steve_e_uk
  • 1675 Answers

SOURCE: I have an engine fault code of p0170 on a mercedes

hi this is showing fuel trim bank 1 malfunction, this could be caused by the following things, intake leak, AIR system, fuel pressure/pump, injector/s EVAP canister purge valve, or HO2S ( air fuel mix incorrect) if it starts and runs fine, i do not think it will be fuel pump, or the injectors as this would make it run rough or even not start at all, if it was an intake leak, you would be suffering from high rev's when you start the car and would take a long time for the rev's to come down, so really, that just leaves the HO2S (sensor/s) these are located one on the exhaust manifold ( from engine follow exhaust manifold you will come to a things sticking out with some wires on) this is HO2S sensor bank 1, or if you look under the car on the exhaust, just past the catalytic converter you will see the same thing, this is HO2S sensor bank 2, it may be either of these, but i possibly would go for the first one, EVAP..it could be, if you have an air leak on it, the EVAP can be found under the hood/bonnet, at the front on the right hand side as you look into the engine/motor bay just in front of the screen was bottle...hope this helps

Posted on Oct 02, 2010

leedavidian
  • 1420 Answers

SOURCE: reset service code B mercedes

Welcome to FIxYa.com


Reset Service Indicator
1. Insert key into ignition, switch to position "1". The mileage counter has to be
displayed.
2. Press repeatedly until the TRIP option is highlighted.
3. Press and hold and within 1 second press and hold both for 5
seconds. The shop menu is displayed.
4. Press repeatedly until "Assyst Plus" is highlighted and confirm with .
Options "Service Data" and "Full Service" are displayed.
5. Press until "Full Service" is highlighted. Confirm with .
6. Press until "Conf. Full Serv." is highlighted, confirm with . The display
shows "Service carried out?."
7. Press to select "Yes". Confirm with . "Cannot be undone" displays.
8. Press until "Confirm" is highlighted. Confirm by pressing . The display
reads "Full Service carried out".
9. Confirm by pressing .
MB

Regards, Lee Davidian

Thank you for using FixYa.com

Posted on Nov 03, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

C270 goes in limp mode M Benz tech department said maf sensor and throttle control, I replaced both and the same happened


the limp mode is also activated by problem sensors in the transmission. Have the fault codes read again or have the system reset after replacing the faulty items.

Jan 16, 2015 | Mercedes-Benz C-Class Cars & Trucks

1 Answer

Mercedes benz limp mode


You need to first have the systems computer scanned for fault codes.

Apr 02, 2014 | 2000 Mercedes-Benz C-Class

1 Answer

Mercedes benz limp mode


WHEN YOUR VEHICLE GOES INTO LIMP MODE IT INDICATES A PROBLEM THAT NEEDS ATTENTION CAN BE TRANS OR ENGINE TRY TURNING SWITCH OFF AT A STOP AND GO AGAIN WITHOUT HOTRODDING IT. THERE ARE TIMES WHEN WIPING AROUND DANGEROUSLY IT WILL GO INTO LIMP MODE.

Oct 30, 2013 | Mercedes-Benz ML320 Cars & Trucks

1 Answer

Brake lights on mb ml350 don't work even after installing new bulbs


Rick,
The brake lamps on your Mercedes are computer-controlled. I would recommend scanning your computer network for possible fault codes.

Nov 18, 2011 | 2007 Mercedes-Benz ML350

1 Answer

I have a Mercedes S class diesel saloon built in 2007 and the car has developed a fault wherby the engine management comes on (but not always). When it comes on it sometimes goes into limp mode and...


engine manage lights and limp mode are activated from the engine AND the transmission faults
may be the mechanic is looking in the wrong area for the fault as it could be a TCM or wiring problem in the transmission
discuss it with MB headquarters technicians as the local shop may not have the experience to fix problems

Apr 19, 2017 | 2007 Mercedes-Benz S-Class

2 Answers

02 mercedes clk430 stuck in limp mode. Transmission has been rebuilt, we have no power to the speed sensor, we changed the connector plate and the car is still in limp mode what can be wrong? all fuses are...


HI

Since you have rebuilt the transmission it is suggested to replace the speed sensor,this is the cause that your car is stuck in limp mode.

Let us know if you want to know somethin more else accept the suggestion.

Thanks for contacting fixya.com

Apr 27, 2010 | 2001 Mercedes-Benz CLK-Class

1 Answer

Engine light for 2003 ML350 Benz


one of the engine sensors must be having a problem! have the vehicle diagonised! use a scan tool please

Jun 18, 2009 | 2007 Mercedes-Benz ML350

1 Answer

My 2005 Ml350 rear wiper fluid is low.


Hi, The rear and the front washers both use the same resevior. I think the fluid level sensor is at fault.

Mar 04, 2009 | 2007 Mercedes-Benz ML320 CDI

Not finding what you are looking for?
2007 Mercedes-Benz ML350 Logo

Related Topics:

222 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Marvin
Marvin

Level 3 Expert

84966 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...