Question about 2000 Kia Sportage

Open Question

Upon restart, engine missing, shudders, acceleration in idle helps sometimes...

It never misses going down the road, only on restart after 20 miles or more....no difference whether a/c is on

Posted by on

  • wadingriver
    wadingriver Mar 22, 2016

    Hi Beverly Bratton, Are you saying that Cold start it runs fine But after car is warmed up it sometimes runs bad?? Rev'ing the engine when it's in Neutral helps?

×

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 158 Answers

SOURCE: my kia loses power randomly going down the road

replace the fuel filter its probley partially blocked and also check the fuel pump pressure.
good luck Lindz

Posted on Apr 18, 2009

Ad
  • 14092 Answers

SOURCE: 2000 kia sportage

you have air leak around the throttle body gasket .

Posted on May 20, 2009

  • 1 Answer

SOURCE: Car is running fine then

I had the same problem, but only when it rained. There was a crack in the ignition coil unit and the water was creating an arc. When I drove long enough to heat the engine and evaporate the water it would run fine. Strangely, though, I still had to stop and restart the engine. $150 bucks the replace the ignition coil, and now no problems (at least with that)

Posted on May 22, 2009

  • 225 Answers

SOURCE: Have an 07 Kia Rio, replaced timing belt road test

check your distributor cap may need replacement also other components to check spark plugs and wires good luck

Posted on Nov 24, 2009

jturcotte
  • 8980 Answers

SOURCE: my 2006 kia rio 5 has and intermittant engine

Hi, maybe it's the wires. Can you tell me if it's a random miss or specific to one particular cylinder? Do you have the trouble code? If it's random, it could be a lot of things.

Please see my tip at http://www.fixya.com/cars/r6715318-causes_gasoline_engine_misfires . These are generic instructions. If you get stuck or need specific instructions for your car, please get back to me with model, year and engine info.

Posted on Jan 30, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine misses when idling and upon acceleration


Spark Plugs--replace at 70,000 miles

COP Ignition Coils-breaking down when hot

O2 Sensors--replace front 2 only --100,000 miles

Clean Throttle Plate and MAF --with CRC Products

TPS Sensor--Test

Feb 13, 2011 | 2006 Ford F-150

1 Answer

Chevy V8, 5.3L, 4wd, engine missing between 48 and


based on what you say here i suspect maybe theres an open in the tps. you can test it with an ohmeter if you have one. some scanners will even show what its doing.

Feb 24, 2018 | 2005 Chevrolet Silverado

1 Answer

2004 Ford F250,6.0 Deisel .When starting cold,won't turn above1500 RPM,without choking out black smoke,hacks and coughs till back to idle then idles fine ,not drivable till idles for half an hour,will not...


Ford 2004 6.0, Driving down road seams like when it starts warming up it starts Missing or accelerating,jerking,as long as you keep the acceleration it seems to work as soon as you level it out it starts missing,even dies at stoping sometimes...Changed fuel filter, put fuel additive in tank still missing,HELP

Jan 02, 2010 | 2004 Ford F250

1 Answer

1988 cutlass ciera boggs down when i accelerate


Hello! You have symptoms that point to incorrect fuel pressure.
First have the fuel pressure tested as follows; #1...engine running at idle: 13- 20 psi. #2...key on engine off: 23-30 psi. If pressure is incorrect change the fuel pump.

Does the engine "surge" at idle? If so, check the "fuel injection pressure regulator idle air control valve". Apply a vacuum to it; If fuel flows it is not the problem.


Guru.............saailer




I’m happy to help further over the phone at https://www.6ya.com/expert/david_6df67de3b14de867

Dec 13, 2009 | 1988 Oldsmobile Cutlass Ciera

2 Answers

Audi - Shudder when accelerating


to be honest i would need to drive it to know for sure but it could be anything from the clutch ,loose flywheel bolts to a drive shaft or evan a deformed tyre,Sorry i couldnt give you an instant fix and i sound like a solicitior because they always beat around the bush

Oct 23, 2009 | 2003 Audi A4 Cabriolet

1 Answer

2000 Impala LS, 3800 engine has been 'missing' (intermittently losing acceleration in quick succession) when temp is at or over half way to 'hot' on temp gauge. That's usually after about 30 minutes on...


you sure its missing and not a torque converter shudder . as a auto tech some times its hard for me to tell the difference. it it was missing it would throw a miss fire code not a torque converter code at 126 k sounds the the trans needs to come out and a good tech needs to rebuild it

Jun 12, 2009 | 2000 Chevrolet Impala

3 Answers

Engine is missing and shaking bad when idleing or driving slow


MY CHECVY ASTRO 92 ,,STARTS FINE IT JUST SHAKES WHEN IN IDLES IN DRIVE OR REVERSE..HAVE NEW WIRES AND DISTIBUTOR

Mar 28, 2009 | 1990 Chevrolet Astro Extended

1 Answer

Transmission shudder


I had a similar problem on my 93 Accord after I accidentally threw the car in reverse at 50 mph, obviously wrecking the transmission. When I got it rebuilt I was told the transmission pump was to blame (clogged with "shrapnel"). I, and your car manual, recommend taking the car in to get the tranny looked at. Especially considering you just had the fluid changed which is what would normally cause the problems you are describing.

Jul 23, 2008 | 1993 Honda Accord

1 Answer

Missfire


Locate you computer (right front kick panel) and tap on it with a pen while the car idles... Also flex it back and forth with your hands to see if the car runs rough or quits... You may need a new one.

May 15, 2008 | 1988 Oldsmobile Delta 88

Not finding what you are looking for?
2000 Kia Sportage Logo

Related Topics:

100 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Marvin
Marvin

Level 3 Expert

85111 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...