Question about 1998 Mitsubishi Montero Sport

1 Answer

The front and back wipers do not work

They worked last night but does not work this morning front or back

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Champion:

    An expert who has answered 200 questions.

  • Mitsubishi Expert
  • 228 Answers

Check your fuse

Posted on Mar 23, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2001 Volvo XC (V70), I think the fuel gauge may be frozen. Is this possible?


Electrical issue is causing your hassles. Look for a bad ground in circuit common to those items.

Apr 24, 2017 | Volvo V70 Cars & Trucks

1 Answer

2001 Town & Country lxi. Front blower worked last night but not this morning. Fuses and relays all OK (swapped known working etc) How to check beyond this? Power at blower motor? Where is blower motor?...


Ummm if the blower motor is bad it's a ***** to replace, I'd spring for a dealership repair to replace the motor
try this (But I doubt it) look under the hood on the firewall near the far right side, if you see the back of the blower motor, whack it with a hammer, this may work and it's tmporary at best, if you're very lucky the blower can be unbolted and removed on he engine side, but that's rare
Sorry

Aug 30, 2009 | 2001 Chrysler Town & Country

1 Answer

My 2006 heaer doesn't work


check the coolant level on the radiator..it sounds low

Feb 04, 2009 | 2006 Hyundai Accent

1 Answer

Check engin light is on?


ok the fuel system is a sealed unit. so try taking the red cable off the battery . ( ONLY ) try starting you car this will drain the car of the electricity from the car. ( not the battery so dont worry. ) hook the cable back up and restart your car. if that does not work your going to have to bring it to a shop. it wont cost much

Jan 23, 2009 | 2003 Toyota Matrix

Not finding what you are looking for?
1998 Mitsubishi Montero Sport Logo

Related Topics:

41 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

Marvin
Marvin

Level 3 Expert

85161 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...