Question about 1997 Chevrolet C1500

1 Answer

What is the function of the speed sensor?

My speedometor isn't working and the tranny isn't shifting.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 21,873 Answers

The speed sensor would be a likely suspect.
It takes the place of the speedo cable going from the transmission to the speedometer.

Posted on Sep 05, 2013

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 32 Answers

SOURCE: the speedometor wont work on my blazer.i changed

You need another instument cluster,the thing with all the gauges. New is pretty pricey but have had good luck with them from a local salvage yard.

Posted on Feb 28, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Speedometor quits working


Sounds like your VSS. Vehicle speed sensor. I don't have that year vehicle, but my older Prelude did the same thing.

Mar 31, 2014 | 1996 Honda Accord

1 Answer

Will a transmissin shif with a broken seed omter


Yes it will shift as long as the Vehicle speed sensor is working, if it isn't working you should have a check engine light on

Oct 04, 2012 | Cars & Trucks

1 Answer

2000 Ford Focus. Transmission won't upshift unless I let up on the gas pedal. It will shift if I'm accelerating easy, but under a heavier load it won't. - Catalytic Converter isn't blocked...


it sound like it could be a vacuum problem. I have experienced this on cars i have worked on it usually turns out to be a vacuum problem 90 percent of the time.

Jul 14, 2011 | Ford Focus Cars & Trucks

1 Answer

High speed miss,new plugs,cap rotor wires fuel filter,cleaned tbs and maf,starts missing @60 mph rpms good 164000 miles ign mod.or coil dont know.tranny feels a little weird sometimes shifts good,other...


if its backfiring at 60 regap the plugs and check the rotor,, if this isn't the case and taking the tranny into the mix, I'd look for a vacuum leak of some sort

May 29, 2011 | 1993 Mercury Cougar

2 Answers

Trans started shifting hard &speedometor &MILAGE INDIcator stopped working at same time


is the ABS light on? the Rear Wheel Speed Sensor is a common problem. Its located on the top of the rear axle.

Oct 04, 2009 | Ford F-150 Cars & Trucks

2 Answers

My tranny is slow shifting and the s light is blinking


The "S" light flashing means the speed sensor went out. Is an easy fix. I got mine for less than $40 and it was not hard to install. As for the gears going in too slow, I dont know. Good luck.

Sep 16, 2009 | 1991 Honda Accord

1 Answer

Won't shift out of first gear


good diagnosis that is correct if the vehicle speed sensor is not working the speedo doesnt work and the trans doesnt know when to shift

Jul 17, 2009 | 1998 Ford Windstar

2 Answers

Not sure wich speed sensor to replace on my 97 town and country.speedometor very erradic and tranny not shifting correctly


you need to replace the output speed sensor..located on front of transmission..near driver's side wheel..2 pin connector..unscrews from transmission case..fairly inexpensive part..around 35-40 bucks

Jun 11, 2009 | 2001 Chrysler Town & Country

1 Answer

1993 ford tempo a/t wont come out of 1st gear.


well i would try replaceing that sensor first it is a speed sensor and it has a lot to do with the shifting of that tranny if it dose not work yea with what you have exsplained it is probly time for a tranny but this fix is worth a try thanks kdc744

Jan 03, 2009 | 1993 Ford Tempo

Not finding what you are looking for?
1997 Chevrolet C1500 Logo

Related Topics:

143 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

85206 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...