Question about 1993 Ford Taurus

1 Answer

1993 Ford Tauras engine light comes on intermdently @ 45 mph then goes off . What to do for smogging?

The code 157, MAF sensor comes on. I cleaned the sensor with MAF air flow cleaner, put new air filter in, and did a visual check on the wires and they seemed ok. I used a code reader and cleared the 157 code. The engine light came on again with the 157. By the way, the check engine light comes on at about 45 mph and stays on for a few seconds, then goes off again. I am trying to pass smog. What do I do next?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 2,101 Answers

That is the code for your down stream o2 sensor . you need to replace that

Posted on Nov 12, 2012

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have 113 and 157 coad on a 1995 mustang how can i fix it a5.0


Hi, code 113 indicates an open circuit of the Intake air Temperature sensor.

Code 157, is the MAF sensor ( Mass Air Flow) before you replace the sensor make sure there are no air leaks between the MAF and the inlet valves.

I think probably one of your symptoms would be engine stalling when you depress the accelerator.

I hope this helps

Mar 14, 2015 | 1995 Ford Mustang

1 Answer

Check engine light comes on after my 1993 ford tauras gets warm


Get someone to run an OBD-II diagnostic on the engine. Most chain part stores will do it for free.

Feb 23, 2015 | Ford Cars & Trucks

1 Answer

HC were high on smog on 1998 deville


Replace the exhaust converter if it is 15 years old

New Spark Plugs

New Air Filter

New Clean Engine Oil --Full Synthetic 5W-30

New Upstream Oxygen Sensors

Clean MAF Sensor

Feb 08, 2013 | 1998 Cadillac DeVille

1 Answer

Code 157


Error code 157 on your vehicle indicates a problem with your mass airflow sensor. The mass airflow sensor gives a reading based on the air intake and output within the engine compartment. A properly functioning sensor will contribute to better fuel economy. In some instances, you may be able to clean your mass airflow sensor to clear the error code, but the error will most likely return in a short time. Fortunately, replacing the mass airflow sensor is a reasonably simple repair.

Read more: How to Correct Engine Code 157 ' eHow.com http://www.ehow.com/how_7982654_correct-engine-code-157.html#ixzz2IH5Ki64X

Jan 17, 2013 | Ford Windstar Cars & Trucks

1 Answer

OBD1 code 157 for 1993 ford explorer


Check MAF Wire Connector & remove & clean
the sensor with CRC MAF Cleaner

Code is for MAF going below .4Volts,
basically not working too well

Dec 12, 2012 | Ford Explorer Cars & Trucks

1 Answer

I have a 1992 7.3 L ford that "lopes" or cuts out


Have you tried changing the gas filter? It sounds like it is starving for gas.

Dec 13, 2010 | 1992 Ford F250

1 Answer

Hesitates and misses at low speeds , check engine light comes on and when i put the code reading scanner on it i got a code 172, need to know ow to fix it


DTC 172 can be set by a variety of things from a bad Mass Air Flow (MAF) sensor to a vacuum leak to a bad EGR system.

I would start with cleaning the MAF sensor.

http://www.therangerstation.com/tech_library/CleanMAF.html

Nov 08, 2009 | 1993 Ford Ranger SuperCab

1 Answer

Chevy truck '02 surges between 45 and 55 mph


you should change the tps( throtal position sensor) this can cause that problem

Aug 15, 2009 | 2000 Chevrolet Silverado

1 Answer

My 96 tauras stalls when accerating but idols fine


un-plug the MAF sensor and see if problem goes away, if it does replace the MAF sensor, then clear code by disconnecting battery for 10 minutes. See picture to identify sensor.
0021656.jpg

Mar 13, 2009 | 1996 Ford Taurus

Not finding what you are looking for?
1993 Ford Taurus Logo

165 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

Marvin
Marvin

Level 3 Expert

85160 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

gerry bissi

Level 3 Expert

4387 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...