20 Most Recent 1995 Ford F350 Questions & Answers


It Sounds like it is staying in the "cold start" routine. It also sounds like the diagnostic computer is not working right, because it must be rich and the O2 is not telling you a thing.

I would start by looking for a temperature sensor. You may have 2, with 1 being for the dash and the other being for the engine controls. You want to replace the temperature sensor for the Engine controls. This will help get it out of "cold start" routine.

Change your thermostat. The onboard computer does not monitor operating temperature.

Fuel pressure regulator. Have pressure checked.It could be forcing too much gas in each time an injector opens.

If you can not do this yourself, tow it in. At 2 mpg it may be cheaper to tow it than to drive any distance for repair. The Mechanics are going to need some gas left over in it to work on the engine.

Also turn on ignition and energize the fuel pressure, check for leaking fuel lines. Put on fuelcap locks if fuel drops when parked.

For this much of an extreme problem, I would like to know what you find wrong with it. I hope my solutions help.

1995 Ford F350 | Answered on Dec 15, 2018


2004 f350
If you're finding it difficult to service/repair your car, get one of those online manuals. You'll not have to wait for others to answer, or rely on mechanics and all. Plus i know a website that sells very cheap but very very good manuals online, without expiry i.e. for lifetime. and under $10 I got my work done

1995 Ford F350 | Answered on Jan 25, 2018


if i say you need the service and repair manual for your knowledge you will think i am selling my product but trust me if you got this manual you don't need the mechanic any more so get the manual from the given link http://toolsnyou.com/ imh had tried this link and saving my money and time so best of luck

1995 Ford F350 | Answered on Dec 21, 2017


check for a bad/loose ground wire in the battery or where it connects to the engine or chassis

1995 Ford F350 | Answered on Aug 01, 2017


-check your transmission fluid level. park the truck on a level surface with the engine running and pull your dipstick and read the level in regards to the engine and trans temp (hot or cold)
-if that checks out i would go under the truck and check all of the electrical connectors that go to the transmission making sure they are secure and making good contact. also check the wiring to the tcm(normally located on the right side frame rail if i remember correctly)and make sure they are all secure and in good condition

Did you do the rear main seal yourself or did you pay a garage to do it? and is there anything else that was done at that time?

1995 Ford F350 | Answered on Aug 17, 2016


I would start by double checking all my work with the lock and tumblar installation and making sure they are aligned properly.
- then i would focus on checking the grounds first. starting with the one on the right front fender that connects directly to the battery. I also would check the one underneath the drivers side dash near the parking brake pedal and clutch pedal (if equipped).
- i would also check the power and ground feeds to you underhood fuse box as well.
--Let me know what you find and ill see if i can be of more help

1995 Ford F350 | Answered on Aug 17, 2016


What size engine ? gas or diesel ? Did you check fuel pump inertia switch for being tripped ?

1995 Ford F350 | Answered on Mar 05, 2016


most diesels don't have a fuel pressure regulator,  The primary pump pressurizes a fuel loop keeping fuel ready for the injector pump. Throw in a few filters and thats about it.
And you certainly don't want to mess with the injector pump. 

1995 Ford F350 | Answered on Jun 26, 2015


I believe there is a fuel pressure regulator on each bank maybe the one not betting fuel is defective

Ford Cars &... | Answered on Jun 13, 2015


Is this a no crank, no start issue? Or is it a crank, but no start issue? If no crank no start, when turning the ignition key to the start position, and you get no cranking, then you have a couple possibilities...
bad starter, bad solenoid at starter, or bad Battery connections.
It could even be a bad positive battery cable. Bad battery terminal connections, are the most common result of a no crank no start issue. Check the terminals, clean them, clean them, and did I say clean them?

check this... Turn the key to the on position just in front of the start position. Then turn the lights on, are your headlights on. If they are on, that means you' are getting power through the ignition system. So ignition switch is not problem.
There is also a circuit breaker in the under the dash fuse box. It runs your power for the ignition system. It's a small half inch by 1 inch? Silver block. Try replacing that?

1995 Ford F350 | Answered on Mar 26, 2015


Start system. Most likely bad connection to Block temp sensor that sends data to ECU there are two sensors, one for the dash temp gague, and this one. I had this problem on 20 yr old car.
Found the correct sensor removed connector cleaned connector with contact spray and toothpick, scraped male spade connector on sensor to bright metal. Cleared codes. Instant start, just like new. Didn't have to change sensor as many claim needs to be done. Hope this helps. Sorry I don't know where yours is. Try a google image search for yr, Make model "Temp sensor" this one is probably near the back of the block. It has a "spring lock" to make sure it stays on. The dash temp is just a standard electrical connector.

1995 Ford F350 | Answered on Mar 13, 2015


wet with what gas or antifreeze if anti freeze head gasket check anti freeze level and oil level and color.

1995 Ford F350 | Answered on Mar 09, 2015


Catalac converters plugged up from unburnt fuel .remove & replace .tune up replace plugs & gap correctly .

1995 Ford F350 | Answered on Feb 04, 2015


As tight as u can tighten by hand wrench then back off 1/4 turn then limit.

1995 Ford F350 | Answered on Feb 04, 2015


Remove vaccum line from brake booster.start truck put finger over hose sucking in @3 sec. Its good.most times vaccum pump locks up .replace the pump

1995 Ford F350 | Answered on Feb 04, 2015


3 possible senerios
Check the the fluid level is on the hot oil mark (in drive) on the dipstick. Too much oil will aeriate and overheat and lower operating pressure in the tranny causing band and clutch package slippage causing more problems adjust to correct mark
2-- have a pressure test done on the tranny for low operating prerssures from failing pumps and blocked filters.
3-- check oil lines to tranny cooler are not bent kinked or blocked
Check the oil colour It should be a bright cherry red but if it is dirty black or brownish it indicates the oil is burning and the tranny should be looked at.

1995 Ford F350 | Answered on Feb 04, 2015


Check.volage.both.sides.of.fuse

1995 Ford F350 | Answered on Dec 24, 2014

Not finding what you are looking for?

433 questions posted

Ask a Question

Usually answered in minutes!

Top Ford Experts

Marvin
Marvin

Level 3 Expert

85206 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

gerry bissi

Level 3 Expert

4388 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

F-350 Ford

  • F-350 Ford

Most Popular Question

change glow plugs in 06 f350

  • Cars & Trucks
Loading...