2003 Mercedes-Benz E-Class - Page 5 - Answered Questions & Fixed issues


6 liters of that precious oil is needed!

2003... | Answered on Nov 02, 2012 | 1,436 views


I think there is a brake wear sensor that will need replacing when you replace the brake pads.

2003... | Answered on Nov 15, 2010 | 187 views


If the brake wear light on you can't reset the light without replace brake pads and sensors inside the pads must replace both after replace it will off automatically

2003... | Answered on Nov 13, 2010 | 1,025 views


did you check the fuse block side of the instrument panel, it should be fixed in it, I don't know either the your car is left hand drive or right hand drive so check both side of the instrument panel which is the covered by door, if you have a good look you can see that side cover can pull it out you have to use some thing like plastic or wooden wedge for open the side cove after open the side cove you can see small fuse block inside, top of the fuse box you can see folded fuse diagram have fix in it. is this information helped you?

2003... | Answered on Nov 03, 2010 | 728 views


first check the brake fluid, if need fill it up by right brake fluid, if it's not help you must drive the car to Mercedes experienced workshop better way go to dealers workshop for diagnose, is this information helped you?

2003... | Answered on Oct 30, 2010 | 1,171 views


Welcome to FIxYa.com




Regards, Lee Davidian


Thank you for using FixYa,com.

2003... | Answered on Oct 28, 2010 | 110 views


Sounds like a sensor shorting or the gauge is faulty.

2003... | Answered on Oct 28, 2010 | 400 views


Yes it could but i would suggest checking the crank position sensor as it will not throw check engine codes. Also go to an auto store and have them pull the codes for you for free.

2003... | Answered on Oct 21, 2010 | 86 views


check heating water circulation pump or heater valve, pssibly one of them faulty, heating water circulation pump have fitted side of the coolant receiver tank, heater valve have fitted under the wiper mechanism, is this information helped you?

2003... | Answered on Oct 20, 2010 | 351 views


Well, I agree, MB should have been able to resolve the issue. Next items to check are all tire pressures and then the brakes. Typically the tech will want to drive your car before and after an alignment, so this is strange...

2003... | Answered on Oct 19, 2010 | 140 views


Hi Mike,
Several possibilities for the short crank time on initial start up. The battery was a good place to start. Yes there is a back up battery on this vehicle but its solely for the braking system. It will play no part in the starting characteristics of the vehicle. It's location is in the engine compartment underneath the a/c cabin filter by the right hood hinge (passenger side). The battery, remote key, tip start relay can all play a factor in this condition. If you have second key I would try that one for awhile and see what happens. It would be impossible to say exact problem with out looking at the car. Can only give most likely cause. Last time I ran into this problem replacing the battery did the trick. The main battery is located in the trunk under the carpet. Guessing that is the one you replaced.

2003... | Answered on Oct 10, 2010 | 221 views


Remove radio to obtain radio serial number and take to a dealer or call the selling dealer to obtain the code!

2003... | Answered on Oct 08, 2010 | 206 views


Try changing the remote batteries first sometimes that can be the problem. If that doesn't help at all then most likely you may need to replace the remote key. Also double check the setting in the instrument cluster to make sure the easy entry option is set to steering wheel and seat. The other possibility may be if the battery in the trunk is weak. A low charge can cause problems too and you may or may not get a message on the cluster that reads consumers offline.

2003... | Answered on Oct 03, 2010 | 107 views


WHY HAFT TO RESET ???

2003... | Answered on Oct 01, 2010 | 768 views


you need new brakes and rotors your rotors are warped also check make sure no debris is stuck between the brake pad and rotor

2003... | Answered on Sep 24, 2010 | 148 views


generally resets , push odo buttom and hold while key on w/o engine start

2003... | Answered on Jul 23, 2010 | 690 views


I would look for a short in a wire and double check the light controls to make sure the interior lights aren't set to be on continuous. If that fails remove the light switch and see if that resolves the battery issue. If it does you know that is the problem and can replace it. Also, check the Main power line from the battery to make sure you haven't had the insulation where thin on it someplace allowing it to ground out.

2003... | Answered on Jul 22, 2010 | 87 views


you are required to take your vehicule for a scheduled maintenance. basically just a reminder from your friendly dealer to bring your money to them

2003... | Answered on Jul 05, 2010 | 94 views


sounds like the dual zone climate control is malfunctioning, does your car have this feature?

2003... | Answered on Jun 22, 2010 | 211 views


One of my customers had the same problem. I sprayed all the bushings with WD-40 and the noise went away. The rubber bushings have metal sleeves inside them that bolts go thru, over time, rust will build up and you'll get a squeak. The newer cars have alot of bushings on them.

2003... | Answered on Jun 02, 2010 | 751 views

Not finding what you are looking for?
2003 Mercedes-Benz E-Class Logo

419 questions posted

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22484 Answers

Marvin
Marvin

Level 3 Expert

85178 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...